Jump to content
Калькуляторы

Объединить 2 сети c5350

Добрый день Господа!

Появилась возможность протестировать AS5350. fa0/0 включил в локальную сеть, fa0/1 в тестовую в виде прямого подключения к ноуту.

192.168.0.0/24 - lan

192.168.20.0/24 - test net

 

Задача кажется жутко тривиальной. Ноут (192.168.20.2) может пинговать оба интерфейса (fa0/0 - 192.168.0.10, fa0/1 - 192.168.20.1), а так же один пк локалки (192.168.0.178). Другие узлы не пингуются. С циски пингуется всё.

Привожу схему и конфиги


!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname something
!
boot-start-marker
boot system flash c5350-ik8s-mz.123-21.bin
no boot startup-test
boot-end-marker
!
no logging console
enable secret 5 $1$v8K/$dY0ZHdYBLrUkRaW5Yhl5U1
!
!
!
resource-pool disable
spe default-firmware spe-firmware-1
aaa new-model
!
!
aaa session-id common
ip subnet-zero
!
!
ip cef
ip domain name xxxxx
ip name-server xxxxx
!
username xxxxxx password 7 110D1C03141D05
!
!
controller E1 3/0
!
controller E1 3/1
! 
!
!
!
interface FastEthernet0/0
ip address 192.168.0.10 255.255.255.0
duplex full
speed 100
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex full
speed 100
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Async1/00
no ip address
encapsulation slip
!
.
.
!
interface Async1/59
no ip address
encapsulation slip
!
interface Group-Async0
no ip address
encapsulation slip
no group-range
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip http server
ip http authentication local
no ip http secure-server
!
!
!
ip access-list standard ssh_access
permit 10.10.0.0 0.0.255.255
permit 192.168.0.0 0.0.255.255
!
snmp-server community xxxxx RO
snmp-server enable traps tty
!
!
!
!
!
!
!
banner motd Hello! I'm $(hostname). You are connected on line $(line) on domain $(domain)
!
line con 0
line aux 0
line vty 0 4
access-class ssh_access in
exec-timeout 0 0
password 7 1413170D0F0B24
transport input telnet ssh
line 1/00 1/59
modem InOut
!
scheduler allocate 10000 400
end

something#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

C    192.168.20.0/24 is directly connected, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.0.1
something#

something#ping 192.168.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/16 ms
something#

something#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.0.10            -   000b.fda2.0242  ARPA   FastEthernet0/0
Internet  192.168.0.1             0   0015.171d.61d6  ARPA   FastEthernet0/0
Internet  192.168.20.1            -   000b.fda2.0243  ARPA   FastEthernet0/1
Internet  192.168.20.2            2   001d.7227.0820  ARPA   FastEthernet0/1
Internet  192.168.0.178           0   0011.6b31.a0ac  ARPA   FastEthernet0/0
something#

post-71960-008077500 1333523632_thumb.jpg

 

Как понять такое поведение в виде доступности только одного узла локалки из тестовой сети? Может я что то упускаю?

Edited by radiskull

Share this post


Link to post
Share on other sites

Добрый день Господа!

Появилась возможность протестировать AS5350. fa0/0 включил в локальную сеть, fa0/1 в тестовую в виде прямого подключения к ноуту.

192.168.0.0/24 - lan

192.168.20.0/24 - test net

 

Задача кажется жутко тривиальной. Ноут (192.168.20.2) может пинговать оба интерфейса (fa0/0 - 192.168.0.10, fa0/1 - 192.168.20.1), а так же один пк локалки (192.168.0.178). Другие узлы не пингуются. С циски пингуется всё.

Привожу схему и конфиги


!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname something
!
boot-start-marker
boot system flash c5350-ik8s-mz.123-21.bin
no boot startup-test
boot-end-marker
!
no logging console
enable secret 5 $1$v8K/$dY0ZHdYBLrUkRaW5Yhl5U1
!
!
!
resource-pool disable
spe default-firmware spe-firmware-1
aaa new-model
!
!
aaa session-id common
ip subnet-zero
!
!
ip cef
ip domain name xxxxx
ip name-server xxxxx
!
username xxxxxx password 7 110D1C03141D05
!
!
controller E1 3/0
!
controller E1 3/1
! 
!
!
!
interface FastEthernet0/0
ip address 192.168.0.10 255.255.255.0
duplex full
speed 100
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex full
speed 100
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Async1/00
no ip address
encapsulation slip
!
.
.
!
interface Async1/59
no ip address
encapsulation slip
!
interface Group-Async0
no ip address
encapsulation slip
no group-range
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip http server
ip http authentication local
no ip http secure-server
!
!
!
ip access-list standard ssh_access
permit 10.10.0.0 0.0.255.255
permit 192.168.0.0 0.0.255.255
!
snmp-server community xxxxx RO
snmp-server enable traps tty
!
!
!
!
!
!
!
banner motd Hello! I'm $(hostname). You are connected on line $(line) on domain $(domain)
!
line con 0
line aux 0
line vty 0 4
access-class ssh_access in
exec-timeout 0 0
password 7 1413170D0F0B24
transport input telnet ssh
line 1/00 1/59
modem InOut
!
scheduler allocate 10000 400
end

something#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

C    192.168.20.0/24 is directly connected, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.0.1
something#

something#ping 192.168.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/16 ms
something#

something#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.0.10            -   000b.fda2.0242  ARPA   FastEthernet0/0
Internet  192.168.0.1             0   0015.171d.61d6  ARPA   FastEthernet0/0
Internet  192.168.20.1            -   000b.fda2.0243  ARPA   FastEthernet0/1
Internet  192.168.20.2            2   001d.7227.0820  ARPA   FastEthernet0/1
Internet  192.168.0.178           0   0011.6b31.a0ac  ARPA   FastEthernet0/0
something#

post-71960-008077500 1333523632_thumb.jpg

 

Как понять такое поведение в виде доступности только одного узла локалки из тестовой сети? Может я что то упускаю?

А 192.168.0.1 что знает о маршруте в сеть 192.168.20.0/24 ?

Share this post


Link to post
Share on other sites

На пк из 192.168.0.0/24 сделал route add 192.168.20.0 mask 255.255.255.0 192.168.0.10

Не помогло. Сделал на нём же адрес fa0/1 как default gw - всё равно.

Share this post


Link to post
Share on other sites

покажите таблицу маршрутизации хоста, который не отвечает (я там понял это 192.168.0.200 ?).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this