Jump to content
Калькуляторы

Trunk + HP2910 Собрать транк между ProCurve и сервером

Добрый день.

 

Никак не могу разобраться с одной простой задачей. Нужно настроить агрегирование каналов, между сервером и железкой HP2910, для получения пропускной способности в 2G. На сервере установлена сетевая карточка Intel 82576 и настроен Bonding.

alias bond0 bonding
options bond0 mode=4 miimon=100 xmit_hash_policy=1

 

Настройки на HP2910

trunk 2-3 trk1 lacp

 

Тестирование показывает, что один порт только используется, а второй служит резервом. Даже если один порт загружен на 100% второй не используется.

Подскажите пожалуйста как правильно настроить оборудование, что бы была возможность пропустить между ними более 1Г ?

Share this post


Link to post
Share on other sites

На 2910:

trunk 2-3 Trk1 Trunk

Edited by Zohan

Share this post


Link to post
Share on other sites

На 2910:

trunk 2-3 Trk1 Trunk

Спасибо, за быстрый ответ.

Если прописываю Trunk вместо lacp, сервер не отвечает (после добавления Trk1 в влан, проходить к серверу только три пинга)

Share this post


Link to post
Share on other sites

Ну сначала уберите lacp c портов 2,3:

conf t
int 2-3
no lacp

 

потом

trunk 2-3 Trk1 Trunk

 

если порт тегированный, то тэги вешать не на 2,3 порт, а на созданный Trk1:

 

int vlan2
tagged trk1
int vlan3
tagged trk1

Share this post


Link to post
Share on other sites

 

Документацию читал.

 

Настройки на железке:

LACP
no LACP ports found.

Load Balancing

 Port | Name                             Type      | Group Type 
 ---- + -------------------------------- --------- + ----- -----
 2    | server-eth5                      100/1000T  | Trk1  Trunk
 3    | server-eth7                      100/1000T  | Trk1  Trunk

show vlan

Trk1             Tagged   Learn        Up

 

Если меняю настройки на lacp, то все корректно работает. Может проблема связана с режимом сетевой карточки на сервере, при статическом агрегировании канала на ProCurve, стоить использовать режим mode=4 (IEEE 802.3ad)?

Share this post


Link to post
Share on other sites

Если изменить опцию сетевой карточки на mode=0 или mode=2, тогда сервер доступен. Но проблему это не решает, при нагрузке канала используется только один порт ProCurve.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this