Jump to content
Калькуляторы

Mikrotik Hotspot и PPtp на одном интерфейсе

Возникла необходимость на одном LAN-интерфейсе обеспечивать и PPTP подключение и HotSpot.

 

HotSpot включил стандартным образом, все работает. PPTP сервер отдельно тоже, какие правила надо добавит что бы PPTP шло минуя hotspot , причем PPoE на этом же интерфейсе работает нормально.

 

Hotspot работает нормально.

PPTP подключаеться и дает Ip но трафик не идет.

PPoE все нормально работает

Edited by kybix

Share this post


Link to post
Share on other sites

Для начала вывод "/ip firewall filter export" в студию.

Скорее всего, правила для хотспота блокируют GRE.

Share this post


Link to post
Share on other sites

Для начала вывод "/ip firewall filter export" в студию.

Скорее всего, правила для хотспота блокируют GRE.

/ip firewall filter
add action=accept chain=forward disabled=yes src-address=11.11.13.0/24
add action=accept chain=forward disabled=yes dst-address=11.11.13.0/24
add action=accept chain=forward disabled=no src-address=11.11.11.6
add action=accept chain=forward disabled=no dst-address=11.11.11.6
add action=accept chain=forward disabled=no src-address=192.168.62.2
add action=accept chain=forward disabled=no dst-address=192.168.62.2
add action=accept chain=forward disabled=no dst-address=192.168.117.19
add action=accept chain=forward disabled=no src-address=192.168.117.19
add action=drop chain=forward disabled=no dst-address=119.70.190.27
add action=drop chain=forward disabled=no dst-address=10.0.6.0/24
add action=accept chain=forward disabled=no src-address=86.16.224.51
add action=accept chain=forward disabled=no dst-address=86.16.224.51
add action=accept chain=forward disabled=no src-address=86.16.224.50
add action=accept chain=forward disabled=no dst-address=86.16.224.50
add action=accept chain=forward disabled=no src-address=192.168.144.7
add action=accept chain=forward disabled=no src-address=192.168.144.3
add action=drop chain=forward disabled=no dst-address=192.168.144.0/24 \
   dst-address-list=""
add action=drop chain=forward disabled=no dst-address=192.168.117.0/24
add action=accept chain=input disabled=no dst-port=1723 protocol=tcp
add action=passthrough chain=unused-hs-chain comment=\
   "place hotspot rules here" disabled=yes

 

Можно уточнение на счет gre

Edited by kybix

Share this post


Link to post
Share on other sites

Прямого запрета не видно.

На всякий случай попробуйте:

/ip firewall filter

add place-before=0 action=accept chain=input protocol=gre

add place-before=0 action=accept chain=output protocol=gre

 

Можно уточнение на счет gre

Можно.

 

P.S. Извращения с поштучным разрешением-запретом отдельных адресов замените на списки:

http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Address_list

 

Скорее всего, разрешения можно убрать вообще - в фильтре всё разрешено по умолчанию.

Если нужны именно поштучные разрешения, тогда надо добавить в конец правил явный запрет всего, что не разрешено.

Share this post


Link to post
Share on other sites

Прямого запрета не видно.

На всякий случай попробуйте:

/ip firewall filter

add place-before=0 action=accept chain=input protocol=gre

add place-before=0 action=accept chain=output protocol=gre

это не помогло ,

Куда можно еще копать, а как нибудь можно отличит трафик PPtp что бы явним образом можно было его разрешить.

Edited by kybix

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this