Jump to content
Калькуляторы

Cisco 2800 + bridge + rate-limit Собсвтенно, а как резать скорость на бридже

Имеется роутер 2851, на который спускается один sub-vlan из supervlan-а уровнем выше.

Ниже имеются 2 клиента, которым необходимо подать две различные полосы.

Маршрутизировать на этом устройстве нельзя. Чтобы спустить трафки вланы сбриджеванны в одну группу.

 

Внимание вопрос. А каким образом можно порезать полосу?

При текущей настройке, полисинга не происходит, счетчики в sh rate не растут.

 

!
bridge irb
!
interface GigabitEthernet0/0.76
description Subvlan of Super vlan at uplink
encapsulation dot1Q 76
bridge-group 1
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0/1.100
description test1
encapsulation dot1Q 100
rate-limit input access-group 1 512000 8000 8000 conform-action transmit exceed-action drop
rate-limit output access-group 1 512000 8000 8000 conform-action transmit exceed-action drop
bridge-group 1
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0/1.101
description test2
encapsulation dot1Q 101
bridge-group 1
bridge-group 1 spanning-disabled
!
bridge 1 protocol ieee
!

Share this post


Link to post
Share on other sites

Что полисинг не происходит - это вы из счётчиков умозаключаете, или это смотрите какими-то утилитами вроде iperf?

ACL показать можете?

Share this post


Link to post
Share on other sites

Что полисинг не происходит - это вы из счётчиков умозаключаете, или это смотрите какими-то утилитами вроде iperf?

ACL показать можете?

 

Разумеется проверял и утилитами в том числе (да и по графикам с сабинтерфейса).

ACL на что? Нет его, всё попадать должно под резалку. (upd, забыл выкинуть из конфига выше access-group, там было permit any any)

На самом деле проблему решил, довесив маршрутизацию. Я писал, что маршрутизировать здесь нельзя, т.к. шлюз висит выше уровнем, но как оказалось это ничего не значит при условии использования ip unnumbered.

В ядро мы пригоняем маршрут на конкретный адрес через ospf; клиенту мы всегда отвечаем своим mac-ом на его arp-запросы, а дальше главное пробросить в default gw.

 

!
interface Loopback1
description some network for directly connected users
ip address 10.10.10.33 255.255.255.224
!
interface GigabitEthernet0/0.217
description main uplink
encapsulation dot1Q 217
ip address 10.10.11.18 255.255.255.252
!
interface GigabitEthernet0/1.100
description test1
encapsulation dot1Q 100
ip unnumbered Loopback1
rate-limit input 512000 8000 8000 conform-action transmit exceed-action drop
rate-limit output 512000 8000 8000 conform-action transmit exceed-action drop
!
interface GigabitEthernet0/1.101
description test2
encapsulation dot1Q 101
ip unnumbered Loopback1
rate-limit input 2048000 384000 768000 conform-action transmit exceed-action drop
rate-limit output 2048000 384000 768000 conform-action transmit exceed-action drop
!
router ospf 1
redistribute connected subnets
redistribute static subnets
!
ip route 10.10.9.1 255.255.255.255 GigabitEthernet0/1.100
ip route 10.10.9.2 255.255.255.255 GigabitEthernet0/1.101
!

Edited by vurd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this