Jump to content
Калькуляторы

проблеммы с копированием ключей/конфигов на TFTP Error opening (Permission denied)

Доброго времени суток!

Специалисты, помогите слоупоку(

Был собран стенд GNS3 - VMWare (Windows XP SP2), топология выглядит где-то так (циски 7200):

Topology.jpeg.jpg

Конфиг R0:

Current configuration : 1481 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R0
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
interface FastEthernet0/0
ip address 192.168.1.20 255.255.255.0
duplex full
!
interface Serial1/0
ip address 12.1.1.1 255.255.255.252
serial restart-delay 0
!
!
router eigrp 1
redistribute static
network 12.0.0.0
network 192.168.1.0
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 12.1.1.2
!
no ip http server
no ip http secure-server
!
control-plane
!
gatekeeper
shutdown
!
!
line con 0
password 7 110A1016141D
login
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 05080F1C2243
login
!
!
end

Пинги между Варей и Р0 проходят.

Задача следующая была: сгенерировать ключи RSA и экспортировать их на TFTP сервер.

Сделать это ну никак не выходит. При попытке сохранить ключ на ТФТП:

R0(config)#crypto key export rsa test_keys_rsa pem url tftp: 3des 123456789

, получаю ошибку:

% Key name: test_keys_rsa
  Usage: General Purpose Key
Exporting public key...
Address or name of remote host []? 192.168.1.29
Destination filename [test_keys_rsa.pub]?
TFTP: error code 2 received - 16739
% Error: failed to open file.
% Error: failed to export key.

При создании ключей, добавлял параметр "exportable".

R0#show crypto key mypubkey rsa
% Key pair was generated at: 09:04:35 UTC Jul 28 2011
Key name: test_keys_rsa
Usage: General Purpose Key
Key is exportable.
Key Data:
 305C300D 06092A86 4886F70D 01010105 00034B00 30480241 00C4B29D CDB14B5C
 18BC1B94 A4D2E75D 467A5FA4 7A1EAB70 31F81D41 1B840642 8DA1904A 59F4426A
 7D3FB33D 43DD6D29 132A5A34 95FBAAC2 8FB14734 D6A6884B 9F020301 0001
% Key pair was generated at: 09:52:36 UTC Jul 29 2011

также присутствует другая проблемка - не могу копировать файл конфигурации на ТФТП:

R0#copy running-config tftp:
Address or name of remote host []? 192.168.1.29
Destination filename [r0-confg]?
TFTP: error code 2 received - 16739

%Error opening tftp://192.168.1.29/r0-confg (Permission denied)

Службу ТФТП в Винде вручную ставил, руководствуясь данным гайдом: http://www.panvasoft.com/rus/blog/144/

Фаервол погасил.

Сразу извиняюсь, если понаписывал (-ваю) глупостей - я в цисках новичек.

Заранее спасибо)

 

//заранее прошу прощение, если подобная тема уже обсуждалась, но поиск мне в этом деле не помог)

//надеюсь тема в правильном разделе.

Edited by Former_Human

Share this post


Link to post
Share on other sites
Permission denied

Не хватает привилегий на запись в корневую директорию tftp сервера?

Edited by KaraVan

Share this post


Link to post
Share on other sites

Тему можно закрыть, вопрос решился установкой и настройкой tftpd32 и убиванием склепаной вручную ТФТП-службы)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this