Jump to content
Калькуляторы

Cisco ESR 10008 PPPoE проблемы с MTU

Добрый день!

 

Столкнулся с проблемой поднятия PPPoE на ESR/PRE-3 - 12.2(33)SB1

 

После установки соединения клиент не может передавать/принимать (ICMP) пакеты, большие чем 146 байт на BRAS.

 

Конфиг типовой, игры с mtu на физическом интерфейсе и в Virtual-Template к успеху не привели. Клиент исправный, обычная тестовая винда.

 

Никто не сталкивался с подобной проблемой?

 

Current configuration : 3232 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
aaa session-mib disconnect
!
!
aaa authentication ppp default group radius
aaa authorization network default group radius 
aaa accounting update periodic 5
aaa accounting network default start-stop group radius
!         
!
!
!
aaa server radius dynamic-author
client 10.4.1.2
server-key key
auth-type any
!
aaa session-id common
facility-alarm outlet-temperature major 58
facility-alarm outlet-temperature minor 48
facility-alarm intake-temperature major 51
facility-alarm intake-temperature minor 41
!
!
!
card 1/0 1gigethernet-hh-1
card 1/1 1gigethernet-hh-1
card 2/0 1gigethernet-hh-1
card 2/1 1gigethernet-hh-1
qos match statistics per-match
ip subnet-zero
ip vrf vvv
rd 111:111
!
!
!
!
!
multilink bundle-name authenticated
username admin password 0 admin
!
redundancy
mode sso
!
!
bba-group pppoe global
virtual-template 1
sessions max limit 100
ac name NAS10
sessions per-mac limit 10
sessions per-vlan limit 10
sessions auto cleanup
!
!
interface Loopback2
ip vrf forwarding vvv
ip address 9.8.8.8 255.255.255.0
!
interface GigabitEthernet1/0/0.94
encapsulation dot1Q 94
ip address 10.4.1.1 255.255.255.0
!
interface GigabitEthernet1/0/0.8051
encapsulation dot1Q 805
pppoe enable group global

interface Virtual-Template1 
mtu 1492
ip vrf forwarding vvv
ip unnumbered Loopback2
peer default ip address pool PPPoE
ppp max-bad-auth 3
ppp authentication chap eap
ppp authorization radius
ppp accounting radius
ppp ipcp dns 8.8.8.8
ppp timeout authentication 45
ppp timeout idle 3000
!
ip local pool PPPoE 1.0.0.0 1.0.0.255
!
radius-server attribute 8 include-in-access-req
radius-server attribute nas-port format e UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
radius-server attribute 31 mac format unformatted
radius-server host 10.4.1.2 auth-port 1812 acct-port 1813 non-standard
radius-server retransmit 5
radius-server timeout 30
radius-server deadtime 1
radius-server key key
radius-server vsa send accounting
radius-server vsa send authentication
!
control-plane
!         
!
!
end


Share this post


Link to post
Share on other sites

ip pxf adjust-mss 1452

Не помогает, было (не с TCP, даже ICMP большие дропаются).

 

Да, ESR включен оптикой в DGS-3627, проблем с ним нет (есть пакеты с нормальным MTU без PPPoE), клиента пробовал и через qinq (второй коммутатор) и напрямую медью - различий нет.

Edited by andhero

Share this post


Link to post
Share on other sites

Вообще лучше сделай меньше чем 1452. Сделай 1360 раз у тебя там ещё и QinQ.

У всех не работает или только у кого-то конкретно.

Share this post


Link to post
Share on other sites

Вообще лучше сделай меньше чем 1452. Сделай 1360 раз у тебя там ещё и QinQ.

У всех не работает или только у кого-то конкретно.

Пробовал и меньше mtu, нет результата.

Это стенд - не работает исправный бук (подключение тут же к другому бразу - проблем нет).

Сильное подозрение на IOS. Никто в таком виде на 10008 браз не поднимал?

Share this post


Link to post
Share on other sites

Сильное подозрение на IOS

Даже на рутрекере есть новее

Share this post


Link to post
Share on other sites

Сильное подозрение на IOS

Даже на рутрекере есть новее

Менял на 12.2(31)SB11, 12.2(34)SB - ситуация не меняется... Пробовал linux-клиента - спотыкается на psize 157 байт. Без PPPoE - с MTU и Jumbo 9216 без проблем (отключение Jumbo не помогает). Может кто-нибудь подсказать работающий IOS на ESR/PRE-3 c PPPoE (или пример конфига)? Тупик какой-то.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this