Jump to content
Калькуляторы

Помогите с OSPF и BGP Согласовать две подсети в одной AS

Имеется несколько НАС, по внешному каналу соединены с BGP маршрутизатором. Поднята своя AS и 1024 PI адресов.

Между НАС и пограничным маршрутизатором подняты OSPF для вещания реальников.

 

Проблема: получили дополнительную подсеть реальников, завели их в одну и туже AREA на всех NAS. Прописали ее в параметры BGP и OSPF на пограничном коммутаторе

Но они не вещаются.....Как найти причину? Новую подсеть зарегистрировали в RIPE и завели ее в AS.

Edited by RHAMZIN

Share this post


Link to post
Share on other sites
Покажите конфигурацию EGP и IGP.

interface Vlan3701

ip address 273.18.20.21 255.255.255.252

!

interface Vlan4320

ip ospf 174.19.21.1 priority 255

ip address 174.19.21.1 255.255.255.224

!

router ospf

ospf router-id 174.19.21.1

network 124.25.17.0/21 area 0

network 174.19.21.0/21 area 0

!

router bgp 47356

network 124.25.17.0/21

network 174.19.21.0/21

neighbor 273.18.20.21 remote-as 36721

Edited by RHAMZIN

Share this post


Link to post
Share on other sites
Прописали ее в параметры BGP и OSPF на пограничном коммутаторе

Но они не вещаются.....Как найти причину?

на пограничном коммутаторе маршрут на всю (/21) вещаемую сеть имеется?

 

Share this post


Link to post
Share on other sites

На циске я бы либо прописал redistribute-network(s?), либо ip route 124.25.17.0 255.255.248.0 Null0 200 и для 174.19.21.0/21 тоже.

Edited by ipaddr.ru

Share this post


Link to post
Share on other sites
Прописали ее в параметры BGP и OSPF на пограничном коммутаторе

Но они не вещаются.....Как найти причину?

на пограничном коммутаторе маршрут на всю (/21) вещаемую сеть имеется?

судя по конфигам с коммутатора там прописаны в OSPF и BGP на две подсети на /21 и на /22.

Share this post


Link to post
Share on other sites
Уточните, не анонсируются ваши роуты в OSPF или в BGP?

Проблема решена.

 

Прпописали в RIPE и у верхнего провайдера новую подсеть. Дополнили в конфиг BIRD и маршрутизатор L3 анонс на новую подсеть. и Все .... вуаля... все отлично маршрутизируется!

Share this post


Link to post
Share on other sites

Чёткое описание проблемы - полпути к её решению.

Edited by ipaddr.ru

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this