Jump to content
Калькуляторы

Как настроить роутинг через разные субинтерйфесы

Маршрутизатор 2621, на одном внешнем интерфейсе - 2 влана, внутри - две сетки - голос и данные. Нужно что бы голос уходил с одного субинтерфеса, данные - со второго.

 

interface FastEthernet0/0.101

encapsulation dot1Q 101

ip address 192.168.1.1 255.255.255.252

 

interface FastEthernet0/0.102

encapsulation dot1Q 102

ip address 192.168.2.1 255.255.255.252

 

Внутри - две сетки, одна для голоса, вторая - пользователи.

 

route-map VPN permit Voice

match ip address VPN_Voice

set interface FastEthernet0/0.101

 

route-map VPN permit User

match ip address VPN_User

set interface FastEthernet0/0.102

 

 

Как правильно прописать маршруты?

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 ?

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.101 ?

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.102 ?

ip route 0.0.0.0.0 0.0.0.0 следующий хоп?

 

Спасибо

Share this post


Link to post
Share on other sites

Для данных сделайте один vrf, для голоса другой, загоните в них соответсвующие интерфейсы и пропишите в каждом vrf свой маршрут по умолчанию

Share this post


Link to post
Share on other sites

Спасибо, пробую, но пока безуспешно

 

Для данных сделайте один vrf, для голоса другой,

ip vrf voice

rd 2621:33

!

ip vrf data

rd 2621:44

 

 

загоните в них соответсвующие интерфейсы и

делаю на внутреннем фейсе

 

interface fa0/1.4

description voice

encapsulation dot1Q 4

ip vrf forwarding voice

ip address хххх хххх

 

interface fa0/1.5

description data

encapsulation dot1Q 5

ip vrf forwarding data

ip address yyyy yyyyy

 

но не заработало (думаю потому, что лвс филиала (она подключена к фа0/1) собрана неизвестно на чем и может не знать про 802,1ку )

и перестали пинговаться внутренние фейсы (но пашет как ping vrf voice)

 

поэтому решил извратится через роут-мапы

1) сделал АЦЛки на голос и данные

2) route-map VPNS permit 40

match ip address voice

set vrf voice

 

вижу матчи

 

пропишите в каждом vrf свой маршрут по умолчанию
вроде просто:

ip route vrf voice 0.0.0.0 0.0.0.0 192.168.1.1

ip route vrf data 0.0.0.0 0.0.0.0 192.168.2.1

 

Но не работает -((

Что смотреть?

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this