Jump to content
Калькуляторы

QinQ Проблемма Перестают ходить пакеты при включении порта

Решили сделать как написанно по ссылке написанно, но обнаружились некоторые проблемы. Пришлось делать с провайдером два порта fa 0/2 vlan 17 и fa 0/12 vlan 906, когда включаем порт fa 0/12 коммутатор D начинает пинговатся через сеть провайдера, но коммутатор С перестает, а коммутатор В и A пингуются впринципе так случается со всеми vlan которые одновременно уходят за коммутатор D и одновременно за B и С, что удивительно интерфейс коммутатора В всегда работает. Об оборудовании:

1. Коммутатор А Cisco 3560

2. Коммутатор B это тупой полу управляемый свич

3. Коммутатор С это сектор базовой станции Wimax пропускет L2 напрямую

4. Коммутатор D Cisco 3560

 

Конфиг коммутатора А у D аналогичный.

 

!

archive

log config

logging enable

notify syslog

hidekeys

no file verify auto

!

spanning-tree mode pvst

spanning-tree extend system-id

no spanning-tree vlan 100

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

description - - - -

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 99,100,103,110-125,127,128,131-138,200,201

switchport trunk allowed vlan add 203-217,219-221,225-227,230-251,336

switchport mode trunk

!

interface FastEthernet0/2

description -

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 17,704

switchport mode trunk

!

interface FastEthernet0/3

description - - -

switchport access vlan 100

switchport mode access

!

interface FastEthernet0/4

description ----

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,103

switchport mode trunk

mls qos trust dscp

!

interface FastEthernet0/5

description - - - -

switchport access vlan 100

switchport mode access

!

interface FastEthernet0/6

description--

switchport mode access

!

interface FastEthernet0/7

description - -

switchport access vlan 100

switchport mode access

!

interface FastEthernet0/8

description

switchport mode access

!

interface FastEthernet0/9

description - - -

switchport access vlan 100

switchport mode access

!

interface FastEthernet0/10

description

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,103

switchport mode trunk

mls qos trust dscp

!

interface FastEthernet0/11

description -

switchport access vlan 103

switchport mode access

!

interface FastEthernet0/12

description transport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 906

switchport mode trunk

!

interface FastEthernet0/13

description Q-in-Q

switchport access vlan 906

switchport mode dot1q-tunnel

switchport nonegotiate

no cdp enable

!

interface FastEthernet0/14

description Q-in-Q Loop

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 99,100,103,138,251,411-450

switchport mode trunk

!

interface FastEthernet0/15

switchport access vlan 103

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 99

switchport mode access

!

interface FastEthernet0/17

description

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/18

description

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/19

description -

switchport access vlan 103

switchport mode access

speed 100

duplex full

spanning-tree portfast

!

interface FastEthernet0/20

description

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/21

description -

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/22

description

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,99,100,103,114,132-138,200,201,222-224,701

switchport mode trunk

!

interface FastEthernet0/23

description -

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,100,201,210

switchport mode trunk

!

interface FastEthernet0/24

description - -

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,17,100,121,122,200,201,203-217,219-227,230-251

switchport trunk allowed vlan add 336,700,701,704,705,1000

switchport mode trunk

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

description --- Management ---

ip address 10.xx.xx.254 255.255.255.0

!

interface Vlan411

no ip address

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.123.1.2

ip route vrf 126 0.0.0.0 0.0.0.0 94.28.126.5 global

no ip http server

!

logging trap debugging

logging facility local6

logging

logging

tacacs-server host

tacacs-server directed-request

tacacs-server key

radius-server source-ports 1645-1646

!

control-plane

 

line con 0

line vty 5 15

!

!

monitor session 1 source vlan 103 rx

monitor session 1 destination interface Fa0/6 , Fa0/8

ntp clock-period 36028929

ntp server

 

 

 

Смотрел STP включал выключал в vlan 100 ничего не помогло, по ссылке в начале стати есть в настройках bpdufilter и bpduguard тоже пробовал включать и выключать не помогает. А вот если потушить порт с 906 vlan то начинает пинговатся но не сразу а минты через 3. Может кто чего знает подскажите ? схема прилагается.

post-64043-1280565637_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this