Jump to content
Калькуляторы

PPPoE под MPD + Quagga

Привет всем.

 

Есть сервер Freebsd, ядро обновлено до версии 7.3

test-02# uname -a

FreeBSD bras-02.global 7.3-STABLE FreeBSD 7.3-STABLE #0: Wed Apr 7 18:38:19 MSD 2010 root@test-02.local:/usr/obj/usr/src/sys/GENERIC amd64

 

Установлен и настроен MPD. PPPoE туннели поднимаются и работают без проблем. Так же на сервер было установлена Quagga поднят OSPF. Соседи друг друга видят.

test-02.ospfd.psl# show ip ospf neighbor

 

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL

255.255.255.255 100 Full/DR 35.850s 192.168.0.17 em0:192.168.0.22 0 0 0

 

 

Но есть проблема. Как только поднимается туннель в конфе OSPF появляется интерфейс ng со строкой.

interface ng

ip ospf network broadcast

После чего соседи отваливаются

 

Если руками убрать строку ip ospf network broadcast то все начинает работать без проблем.

 

Собственно вопрос как указать Quagga не следить за интерфейсами ng либо не добавлять данную строку. Искал по форуму не чего подобного не нашел...

Вот конфиг Quagga

password test

log syslog

!

!

!

interface cdce0

!

interface em0

description NET-test

ip ospf network non-broadcast

ip ospf priority 10

!

interface em1

!

interface em2

!

interface em3

!

interface emo

!

interface lo0

!

interface ne

!

interface ng

ip ospf network non-broadcast

!

interface ng0

!

interface ng1

!

interface ng2

!

interface ng3

!

interface vlan

!

interface vlan112

!

interface vlan114

!

router ospf

ospf router-id 192.168.0.22

log-adjacency-changes detail

redistribute connected route-map connected-to-ospf

network 192.168.0.16/29 area 0.0.0.0

network 192.168.0.32/27 area 0.0.0.0

area 0.0.0.1 stub no-summary

neighbor 192.168.0.17

distribute-list ospf out connected

!

access-list ospf permit 192.168.0.16/29

access-list ospf permit 192.168.0.32/27

!

ip prefix-list connected-to-ospf seq 10 permit 192.168.0.16/29

ip prefix-list connected-to-ospf seq 30000 deny 0.0.0.0/0 le 32

!

route-map connected-to-ospf permit 10

match ip address prefix-list connected-to-ospf

!

line vty

!

end

 

С уважением

Edited by kinder

Share this post


Link to post
Share on other sites

Проблему решил следующим образом

 

Для общения с соседями указал другой IP нежели используется для туннелей в MPD, при такой схеме соседи перестали отваливаться, но при этом не чего не работало. На интерфейсе все так же появлялось ip ospf network broadcast , а в логах ospfd видно было что он себя ставит DR.

 

После долгих танце убрал строку.

network 192.168.0.32/27 area 0.0.0.0
, это сеть со стат IP на туннелях. Оставил только сеть по которой общаются соседи. После этого туннели стали подниматься, в ospf роуты создаются и все работает... Не могу сказать насколько это правильно, так как на кошках надо было указывать сети, которые требуется анонсировать...

 

Так же поправил в настройках

router ospf

ospf router-id 10.0.0.22

log-adjacency-changes detail

redistribute connected route-map connected-to-ospf

network 10.0.0.0/27 area 0.0.0.0

passive-interface default

no passive-interface em0

distribute-list ospf out connected

 

Разрешение работать ospf только на interface em0

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this