Jump to content
Калькуляторы

вопрос по конфигу микротиков

нужно мне собрать такую вот сеть

есть одна база, и к ней цепляется много клиентов, все на микротиках

требование - чтоб все было прозрачно и забриджевано, т.е. с ethernet порта базы трафик прозрачно ходил на ethernet порты клиентских устройств

 

на базе настраиваю wlan так:

R name="wlan1" mtu=1500 mac-address=??????????? arp=enabled 
      interface-type=Atheros 11N mode=ap-bridge ssid="???" frequency=2447 
      band=2.4ghz-onlyg scan-list=default wds-mode=dynamic 
      wds-default-bridge=bridge1 wds-ignore-ssid=no 
      default-authentication=yes default-forwarding=yes 
      default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=yes 
      security-profile=default compression=no

 

создаю bridge1, добавляю в него ether1

#    INTERFACE             BRIDGE             PRIORITY PATH-COST  HORIZON   
0    ether1                bridge1            0x80     10         none      
1  D wds2                  bridge1            0x80     115        none      
2  D wds1                  bridge1            0x80     100        none

 

 

на клиентах вот такой конфиг:

0  R name="wlan1" mtu=1500 mac-address=????????? arp=enabled 
      interface-type=Atheros 11N mode=station-wds ssid="?????" frequency=2447 
      band=2.4ghz-onlyg scan-list=default wds-mode=disabled 
      wds-default-bridge=none wds-ignore-ssid=no default-authentication=yes 
      default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 
      hide-ssid=no security-profile=default compression=no

 

в бридж добавлены ether1 и wlan1

 

вообщем проблема такая, когда висела одна железяка-клиент, все было более чем отлично

как подцепили вторую, они обе начали беспорядочно отваливаться примерно раз в минуту, а то и чаще

т.к. с уровнем сигнала все хорошо, в районе -63 дб, то думаю что нужно копать проблему в плане настройки wds

в логах базы вот такие вещи творятся:

08:15:44 wireless,info @wlan1: connected, wants WDS 
08:15:49 wireless,info @wlan1: reassociating 
08:15:49 wireless,info @wlan1: disconnected, ok 
08:15:49 wireless,info @wlan1: connected, wants WDS

 

в какую сторону смотреть?

Edited by MaksMMS

Share this post


Link to post
Share on other sites
на базе настраиваю wlan так:

R name="wlan1" mtu=1500 mac-address=??????????? arp=enabled

interface-type=Atheros 11N mode=ap-bridge ssid="???" frequency=2447

band=2.4ghz-onlyg scan-list=default wds-mode=dynamic

wds-default-bridge=bridge1 wds-ignore-ssid=no

default-authentication=yes default-forwarding=yes

default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=yes

security-profile=default compression=no

 

на клиентах вот такой конфиг:

R name="wlan1" mtu=1500 mac-address=????????? arp=enabled

interface-type=Atheros 11N mode=station-wds ssid="?????" frequency=2447

band=2.4ghz-onlyg scan-list=default wds-mode=disabled

wds-default-bridge=none wds-ignore-ssid=no default-authentication=yes

default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0

hide-ssid=no security-profile=default compression=no

Странные у вас конфиги. :)

Share this post


Link to post
Share on other sites
поэтому и спрашиваю :)
Вот пример прозрачного бриджа с использованием WDS http://wiki.mikrotik.com/wiki/Transparentl...ge_two_Networks.

Для мультиточки использовать вместо бридж, ап бридж. В таком конфиге все работает нормально, у вас же неизвестно что. :))

Share this post


Link to post
Share on other sites
Вот пример прозрачного бриджа с использованием WDS http://wiki.mikrotik.com/wiki/Transparentl...ge_two_Networks.

Для мультиточки использовать вместо бридж, ап бридж. В таком конфиге все работает нормально, у вас же неизвестно что. :))

так база у меня и так в ap bridge, на клиентах station wds

где еще что-то поправить?

а этот мануал у меня давно в закладках, точка-точку не раз настраивал

вот с многоточкой в таком виде на микротиках сталкиваюсь впервые

Edited by MaksMMS

Share this post


Link to post
Share on other sites
Вот пример прозрачного бриджа с использованием WDS http://wiki.mikrotik.com/wiki/Transparentl...ge_two_Networks.

Для мультиточки использовать вместо бридж, ап бридж. В таком конфиге все работает нормально, у вас же неизвестно что. :))

т.е. на клиентах, как и на базе - ставить ap bridge ?

а этот мануал у меня давно в закладках, точка-точку не раз настраивал

вот с многоточкой в таком виде на микротиках сталкиваюсь впервые

На клиентах station wds, на базе ap bridge.

Share this post


Link to post
Share on other sites

вообще-то так и стоит, в конфигах выше это видно :)

вопрос был из-за чего могут отваливаться

Share this post


Link to post
Share on other sites
вообще-то так и стоит, в конфигах выше это видно :)

вопрос был из-за чего могут отваливаться

1)зачем стейшн+вдс ? обычный стейшен псевдобридж и не нужно на стороне базы никаких вдс-ов что логично само собой оберёт причину - конект вонтс вдс...

2)какие сскю на юзерах и какая обстановка в эфире?

Edited by fastvd

Share this post


Link to post
Share on other sites
вообще-то так и стоит, в конфигах выше это видно :)

вопрос был из-за чего могут отваливаться

У вас там стоит непонять что. :) Я специально выделил в первом посте.

Share this post


Link to post
Share on other sites
вообще-то так и стоит, в конфигах выше это видно :)

вопрос был из-за чего могут отваливаться

1)зачем стейшн+вдс ? обычный стейшен псевдобридж и не нужно на стороне базы никаких вдс-ов что логично само собой оберёт причину - конект вонтс вдс...

2)какие сскю на юзерах и какая обстановка в эфире?

1. думал об этом, наверное стоит попробовать...т.к. вдс мне вообщем то и не нужен, главное чтобы прозрачная сеть была

просто не разобрался как настроить правильно

подскажите пожалуйста, что нужно поменять для такой конфигурации, только режим работы клиентов или на базе еще что-то? нужно ли что-то изменять в настройках бриджа?

 

2. CCQ на одном юзере 98/99, на другом 98/90, обстановка в эфире так себе, но работать еще можно

 

на клиентах в логах еще вот такие надписи вылетают:

05:56:00 wireless,info _________@wlan1 established connection on 2442, SSID lt 
05:56:52 wireless,info _________@wlan1: lost connection, no beacons received 
05:56:54 wireless,debug wlan1: must select network

Edited by MaksMMS

Share this post


Link to post
Share on other sites

попробовал переключить одного клиента в station-pseudobridge, он приконектился, но столкнулся с тем что перестал пинговаться IP для управления, который висел до этого на ether1

на каком интерфейсе должно висеть управление в таком варианте?

Share this post


Link to post
Share on other sites
попробовал переключить одного клиента в station-pseudobridge, он приконектился, но столкнулся с тем что перестал пинговаться IP для управления, который висел до этого на ether1

на каком интерфейсе должно висеть управление в таком варианте?

bridge

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this