Jump to content
Калькуляторы

вопрос по ospf

Прошу прощения заранее за глупый вопрос, что-то затупил при настройке данной схемы

 

drawing1rw.jpg

 

проблема:

на sw2 перебивается дефолт приходящий от router2 и указывает на sw1 . а надо сделать так чтобы с sw1 пакеты шли через router1 а с sw2 пакеты через router2 и

только в случае недоступности - отправлялий через другой хост.

подозреваю что надо с cost-ом играться, но не уверен. кто сможет подсказать как правильно сделать?

Edited by Denis Samsonov

Share this post


Link to post
Share on other sites
Прошу прощения заранее за глупый вопрос, что-то затупил при настройке данной схемы

 

drawing1rw.jpg

 

проблема:

на sw2 перебивается дефолт приходящий от router2 и указывает на sw1 . а надо сделать так чтобы с sw1 пакеты шли через router1 а с sw2 пакеты через router2 и

только в случае недоступности - отправлялий через другой хост.

подозреваю что надо с cost-ом играться, но не уверен. кто сможет подсказать как правильно сделать?

Измините(уменьшите) bw на портах что связывают коммутаторы.

Share this post


Link to post
Share on other sites

не спасло ( в итоге все равно на обоих коммутаторах дефолт роут выбирается на один из маршрутизаторов.

Share this post


Link to post
Share on other sites

может будет проще.

--ospf router1 --

router ospf
ospf router-id xxx.xxx.xxx.69
network xxx.xxx.xxx.68/30 area 0.0.0.0
default-information originate metric 100
!

router 2

router ospf
ospf router-id xxx.xxx.xxx.217
network xxx.xxx.xxx.xxx/30 area 0.0.0.0
default-information originate metric 100
!

 

на коммутаторах такие настройки

sw1

interface Vlan10
description ospf
ip address xxx.xxx.xxx.218 255.255.255.252
!

interface Vlan15
description ospf
ip address xxx.xxx.xxx.73 255.255.255.252
ip ospf cost 1000
!

router ospf 1
router-id xxxxxx.xx.1
log-adjacency-changes
redistribute connected metric 2 subnets
redistribute bgp 65000 metric 4 metric-type 1 subnets
network xxx.xxx.xxx.72 0.0.0.3 area 0.0.0.0
network xxx.xxx.xxx.216 0.0.0.3 area 0.0.0.0
!

 

sw2

interface Vlan6
description ospf gw1-c3560-k18
ip address xxx.xxx.xxx.70 255.255.255.252
!
interface Vlan15
ip address xxx.xxx.xxx.74 255.255.255.252
ip ospf cost 1000
!
router ospf 1
log-adjacency-changes
redistribute connected metric 2 subnets
network xxx.xxx.xxx.68 0.0.0.3 area 0.0.0.0
network xxx.xxx.xxx.72 0.0.0.3 area 0.0.0.0
!

Edited by Denis Samsonov

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this