Jump to content
Калькуляторы

Проблема с MikroTik v. 3.30

Постараюсь донести суть происходящего.

 

Есть 2 узла (узел А и узел Б) соединённые между собой оптикой через SFP порты коммутаторов.

 

На узел (А) в железку D-link dgs-3216g приходит оптический линк от клиента и vlan-ом проходя через D-link dgs-3100 терминируется на MikroTik-е v.3.30

На узле (Б) тоже MikroTik v.3.30 и есть много vlan-ов на которых весит много РРРоЕ.

Во всех коммутаторах включена поддержка STP

 

Как только выключается или включается конвертер на стороне клиента который включен в узел (А) у меня отваливаются клиентские РРРоЕ частично на узле (А) и

огромное кол-во на нескольких vlan-ах узла (Б).

Непонятно как это всё может быть взаимосвязано.

Так же на узле (А) имеется Linux сервер который тоже занимается терминацией, клиенты на нём не отваливаются.

Есть подозрение на какой-то совершенно лишний интеллект, как будто MikroTik не адекватно реагирует на STP.

 

Помогите разобраться что к чему. У меня уже нету мыслей.

Share this post


Link to post
Share on other sites

NetViruS

приложи картинку, так не очень понятно

и конфиги портов коммутаторов, я в dlink-е не силен, но кто-то наверное подскажет. Сдается мне именно там проблема.

Попробуй сменить порт/влан у клиента из-за которого проблема.

Включи дебаг на микротике, сзеркаль трафик с клиентского порта, в общем пособирай еще инфы.

 

Share this post


Link to post
Share on other sites

Сегодня повторилось.

В логах коммутаторов я обнаружил вот что.

В одном:

 

214748358203042010 10:42:0404-Mar-2010 10:42:04 Notice%STP-W-PORTSTATUS: e1 of instance 0: STP status Forwarding

3214748358303042010 10:41:1104-Mar-2010 10:41:11 Notice%STP-W-PORTSTATUS: e1 of instance 0: STP status Blocking

4214748358403042010 10:36:5704-Mar-2010 10:36:57 Notice%STP-W-PORTSTATUS: e1 of instance 0: STP status Forwarding

5214748358503042010 10:36:0104-Mar-2010 10:36:01 Notice%STP-W-PORTSTATUS: e1 of instance 0: STP status Blocking

214748358903042010 09:34:1504-Mar-2010 09:34:15 Notice%STP-W-PORTSTATUS: e1 of instance 0: STP status Forwarding

10214748359003042010 09:33:1504-Mar-2010 09:33:15 Notice%STP-W-PORTSTATUS: e1 of instance 0: STP status Blocking

 

И в другом:

 

30559 2010-03-04, 10:42:14 Topology changed

30558 2010-03-04, 10:37:07 Topology changed

30557 2010-03-04, 09:34:23 Topology changed

 

Порт е1 это это оптический линк между узлами.

Я так понимаю что STP почему-то погасил и поднял порт :(

Edited by NetViruS

Share this post


Link to post
Share on other sites

Конфиг AT-8000S: узел (Б)

 

spanning-tree

spanning-tree mode mstp

interface range ethernet e(2-24)

spanning-tree disable

exit

interface ethernet e2

spanning-tree cost 19

exit

interface ethernet g1

spanning-tree cost 100

exit

interface range ethernet e(18-24)

shutdown

exit

interface ethernet e1

description bla-bla

exit

interface ethernet e3

description bla-bla

exit

interface ethernet e7

description bla-bla

exit

interface ethernet e11

description bla-bla

exit

interface ethernet e16

description bla-bla

exit

interface ethernet e17

description bla-bla

exit

interface ethernet g1

description bla-bla

exit

interface range ethernet e1,g1

switchport mode trunk

exit

vlan database

vlan 5,7-8,14,18-20,22,44,226,232

exit

interface range ethernet e1,g1

switchport trunk native vlan 5

exit

interface ethernet e4

switchport access vlan 7

exit

interface ethernet e1

switchport trunk allowed vlan add 7

exit

interface range ethernet e1,g1

switchport trunk allowed vlan add 8

exit

interface range ethernet e1,g1

switchport trunk allowed vlan add 14

exit

interface ethernet e2

switchport access vlan 18

exit

interface ethernet e1

switchport trunk allowed vlan add 18

exit

interface ethernet e3

switchport access vlan 19

exit

interface ethernet e1

switchport trunk allowed vlan add 19

exit

interface range ethernet e(6-10,12-17)

switchport access vlan 20

exit

interface ethernet e1

switchport trunk allowed vlan add 20

exit

interface ethernet e5

switchport access vlan 22

exit

interface ethernet e1

switchport trunk allowed vlan add 22

exit

interface ethernet e11

switchport access vlan 44

exit

interface ethernet e1

switchport trunk allowed vlan add 44

exit

interface range ethernet e1,g1

switchport trunk allowed vlan add 226

exit

interface range ethernet e1,g1

switchport trunk allowed vlan add 232

exit

interface vlan 5

name bla-bla

exit

interface vlan 7

name bla-bla

exit

interface vlan 8

name bla-bla

exit

interface vlan 14

name bla-bla

exit

interface vlan 18

name bla-bla

exit

interface vlan 19

name bla-bla

exit

interface vlan 20

name bla-bla

exit

interface vlan 22

name bla-bla

exit

interface vlan 44

name bla-bla

exit

interface vlan 226

name bla-bla

exit

interface vlan 232

name bla-bla

exit

interface vlan 5

ip address 10.0.0.6 255.255.255.0

exit

ip default-gateway 10.0.0.3

hostname bla-bla

Edited by NetViruS

Share this post


Link to post
Share on other sites

Проблема обнаружена.

Нужно грамотно конфигурить MSTP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this