Jump to content
Калькуляторы

Cтранное поведение dhcp snooping'a

Опишу ситуацию.

 

Есть Cisco 3750G и 3560G

 

На обеих поднят dhcp snooping.

 

### На 3750G

Подняты интерфейсы

interface Vlan5 (создан для OSPF и маршрутизации между сисками)

ip address 10.10.255.0 255.255.255.254

no ip redirects

no ip proxy-arp

ip policy route-map server2-pool

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 7 *********************************

load-interval 30

 

Interface Vlan101

Interface Vlan102

Interface Vlan103

 

также заведены просто VLAN'ы

Vlan 5 (по нему между сисками обмен идёт)

Vlan 80

Vlan 100

Vlan 101

Vlan 102

Vlan 103

Vlan 104

 

 

 

### На 3560G

Подняты интерфейсы

interface Vlan5 (создан для OSPF и маршрутизации между сисками)

ip address 10.10.255.1 255.255.255.254

no ip redirects

no ip proxy-arp

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 7 ************************************

load-interval

 

Interface Vlan80

Interface Vlan100

Interface Vlan104

 

также заведены просто VLAN'ы

Vlan 5

Vlan 80

Vlan 100

Vlan 101

Vlan 102

Vlan 103

Vlan 104

 

 

###Поднят OSPF на 3750G

router ospf 1

router-id 10.10.255.0

log-adjacency-changes

area 0.0.0.0 authentication message-digest

passive-interface default

no passive-interface Vlan5

network 10.0.0.0 0.255.255.255 area 0.0.0.0

network xxx.xxx.240.0 0.0.15.255 area 0.0.0.0

default-information originate

 

 

### Поднят OSPF на 3560G

router ospf 1

router-id 10.10.255.1

log-adjacency-changes

area 0.0.0.0 authentication message-digest

passive-interface default

no passive-interface Vlan5

network 10.0.0.0 0.255.255.255 area 0.0.0.0

network xxx.xxx.240.0 0.0.15.255 area 0.0.0.0

 

 

 

На 3750G подключен DHCP сервер, на котором подняты все существующие

клиентские VLAN'ы , чтобы каждый смотрел напрямую в свой. Сделано было

для того, что у клиентов некоторые

старые роутеры не работали с DHCP релеем.

 

С тех VLAN'ов, интерфейсы которых подняты на 3560G откуда идут DHCP запросы, каждые 30

секунд в логах на ДРУГОЙ СИСКЕ 3750G появляются вот такие записи ниже.

 

Странно то, что:

sa: 0024.f9f5.2f45 это MAC Interface Vlan100 который поднят на 3560G

sa: 0024.f9f5.2f44 это MAC Interface Vlan104 который поднят на 3560G

 

 

047529: Nov 20 21:24:58: %DHCP_SNOOPING-5-DHCP_SNOOPING_MATCH_MAC_FAIL: DHCP_SNOOPING drop message because the chaddr doesn't match source mac, message type:

DHCPREQUEST, chaddr: 001e.e58c.d955, MAC sa: 0024.f9f5.2f45

 

047530: Nov 20 21:25:29: %DHCP_SNOOPING-5-DHCP_SNOOPING_MATCH_MAC_FAIL: DHCP_SNOOPING drop message because the chaddr doesn't match source mac, message type:

DHCPREQUEST, chaddr: 0013.8f4c.bed3, MAC sa: 0024.f9f5.2f45

 

047531: Nov 20 21:25:59: %DHCP_SNOOPING-5-DHCP_SNOOPING_MATCH_MAC_FAIL: DHCP_SNOOPING drop message because the chaddr doesn't match source mac, message type:

DHCPREQUEST, chaddr: 0018.39c0.68b5, MAC sa: 0024.f9f5.2f44

 

047532: Nov 20 21:26:29: %DHCP_SNOOPING-5-DHCP_SNOOPING_MATCH_MAC_FAIL: DHCP_SNOOPING drop message because the chaddr doesn't match source mac, message type:

DHCPREQUEST, chaddr: 001e.4c64.38fe, MAC sa: 0024.f9f5.2f44

 

047533: Nov 20 21:26:59: %DHCP_SNOOPING-5-DHCP_SNOOPING_MATCH_MAC_FAIL: DHCP_SNOOPING drop message because the chaddr doesn't match source mac, message type:

DHCPREQUEST, chaddr: 001d.0949.457e, MAC sa: 0024.f9f5.2f45

 

047534: Nov 20 21:27:29: %DHCP_SNOOPING-5-DHCP_SNOOPING_MATCH_MAC_FAIL: DHCP_SNOOPING drop message because the chaddr doesn't match source mac, message type:

DHCPREQUEST, chaddr: 0004.619b.17c5, MAC sa: 0024.f9f5.2f45

 

047535: Nov 20 21:28:01: %DHCP_SNOOPING-5-DHCP_SNOOPING_MATCH_MAC_FAIL: DHCP_SNOOPING drop message because the chaddr doesn't match source mac, message type:

DHCPREQUEST, chaddr: 0019.db31.f970, MAC sa: 0024.f9f5.2f45

 

 

Причём не все пакеты корёжатся.

Клиенты IP получают свои.

 

Никто не может подсказать почему такое?!

 

Такое стало после поднятие роутинга на второй сиске 3560G.

 

 

Если клиент запрашивает по DHCP и сам клиент допустим с 104 VLAN

(3560G), то и сервер(висящий на 3750G) ему отвечает в 104 VLAN.

 

Почему такое происходит, что периодически идёт замена MAC в пакете, не

понятно.

 

 

Кто сталкивался, как лечится. Одни списывают на баг в IOS.

 

Сисики и их IOS

WS-C3560G-24TS 12.2(52)SE C3560-IPSERVICES-M

WS-C3750G-24T 12.2(52)SE C3750-IPSERVICES-M

 

Share this post


Link to post
Share on other sites

Неужели никто не может помочь?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this