Jump to content
Калькуляторы

cisco 3550 + multicast вещание в два vlan-a

есть циска 3550 , есть стриммер который вещает в дефолтный влан, как заставить внутри циски что бы мультикасты вещаемые на гигабитный порт в деволтном влане параллельно вещались в какой нить другой влан например 50 ?

Edited by anclbob

Share this post


Link to post
Share on other sites
mvr не подойдет?

ммм... а где почитать? или как может подскажите?

Share this post


Link to post
Share on other sites

с английским плохо но вроде понял, поправьте если не так.

У меня есть циска , на ней два гигабитных порта один порт в первом дефолтном влане gi 0/2 в него воткнут стриммер , и другой порт в транке смотрит во всю остальную сеть gi 0/1 .

Задача: транслировать мультикаст не только в дефолтный влан, но и в vlan 50

пишу.

conf t

vlan 50

name iptv

int vlan 50

ip address 10.90.90.10 netmask 255.255.255.0

 

end

 

mvr (включил)

mvr vlan 50

mvr mode dynamic (незнаю зачем)

end

 

ip igmp snooping vlan 50 mrouter interface gigabitethernet0/1

ip igmp snooping vlan 50 querier address 10.90.90.10

 

 

а дальше немного не пойму

где какой порт указывать

 

==================================

пример

Switch(config)# mvr

 

Switch(config)# interface gigabitethernet0/2

 

Switch(config-if)# mvr type receiver

 

Switch(config-if)# mvr vlan 50 group 228.1.23.4

 

Switch(config-if)# mvr immediate

 

Switch(config)# end

==========================================

 

подскажите?

Edited by anclbob

Share this post


Link to post
Share on other sites

МВР вам не подойдет.

 

Из документа:

Receiver ports cannot be trunk ports. Receiver ports on a switch can be in different VLANs, but should not belong to the multicast VLAN.

 

В кратце о том что приемные порты не могут быть транковые.

А потому настраивайте мультикаст роутинг.

Share this post


Link to post
Share on other sites

проблема в следующем

 

ip multicast-routing (понимает)

!

interface gi 0/2 (понимает)

description Multicast Source (понимает)

ip address 10.0.0.1 255.255.255.0 (не понимает)

ip pim sparse-mode (не понимает)

!

 

причем если я пишу вместо какого либо интерфейса vlan 50 например, то он понимает или любой другой влан кроме дефолтного. дефолтны тоже не понимает ip pim

 

Версия прошивки

Cisco IOS Software, C3550 Software (C3550-IPSERVICESK9-M), Version 12.2(44)SE2, RELEASE SOFTWARE (fc2)

Copyright © 1986-2008 by Cisco Systems, Inc.

Compiled Thu 01-May-08 16:14 by antonino

Image text-base: 0x00003000, data-base: 0x012A7044

 

ROM: Bootstrap program is C3550 boot loader

 

Switch uptime is 9 weeks, 5 days, 5 hours, 34 minutes

System returned to ROM by power-on

System image file is "flash:/c3550-ipservicesk9-mz.122-44.SE2"

 

но вот нашел

Model number: WS-C3550-48-SMI

тут написано SMI это прошивка не поменялась, или на эту модель вообще нельзя поставить EMI.

Edited by anclbob

Share this post


Link to post
Share on other sites
тут написано SMI это прошивка не поменялась, или на эту модель вообще нельзя поставить EMI.
c3550-ipbase - SMI

c3550-ipservices - EMI

 

разница между ними - кастрированный l3 в SMI или полный L3 в EMI

 

Если не ошибаюсь - последняя прошивка это c3550-ipservices-tar.122-50.SE3, там были какие-то фиксы с IGMP

Share this post


Link to post
Share on other sites
interface gi 0/2 (понимает)

ip address 10.0.0.1 255.255.255.0 (не понимает)

interface gi 0/2
no switchport
ip address 10.0.0.1 255.255.255.0

Share this post


Link to post
Share on other sites

Подскажите а есть ли у данной циски функция ISM vlan ?

Share this post


Link to post
Share on other sites

ИМХО, ISM vlan (DLINK) = MVR (CISCO)

Но в данном конкретном случае MVR не поможет, нужен multicast routing

Edited by BuHast

Share this post


Link to post
Share on other sites

В данном понял что не поможет, роутинг тоже не получилось настроить

 

А если такая ситуация, стримером я щас вещаю в два влана (с мультикаст роутингом не получилось). Человек подключен на этой же циске в другом порту скажем в 10м влане, как мне сделать этот порт member что просто на него скинуть мультикаст с 50 влана который приходит на gi 0/2 (аналог dlink овского ISM)

Edited by anclbob

Share this post


Link to post
Share on other sites

Порт клиента - как мембер в MVR

Порт стриммера - как соурс в MVR.

Только я вот не помню, tagged or untagged должен быть соурс порт.

Share this post


Link to post
Share on other sites

Сурс порт вроде по барабану, ресивер должен быть акцесным.

Share this post


Link to post
Share on other sites

а с синтаксисом не подскажите?

Share this post


Link to post
Share on other sites

не верьте документации :)

приемные порты могут быть транковыми.

проверено на 2950/2960/3550.

просто надо сделать финт ушами - вот например 3550-T12:

#sh mvr interface
Gi0/6           RECEIVER    Access      416     ACTIVE/UP      DISABLED
Gi0/9           SOURCE      Trunk       2       ACTIVE/UP      DISABLED       
Gi0/10          SOURCE      Trunk       2       ACTIVE/UP      DISABLED       
Gi0/11          SOURCE      Trunk       2       ACTIVE/UP      DISABLED       
Gi0/12          SOURCE      Trunk       2       ACTIVE/UP      DISABLED

она с Gi0/11 и Gi0/12 ловит входящий видео-поток в 2-м VLAN-е, далее локально раздает в 416-й акцесом (смотрим через VLC в офисе :)

и далее по портам 9 и 10 кидает на другие циски(2960), с которых идет на другие VLANы.

 

крайне неочевидная фишка в том что порты должны быть объявлены как MVR TYPE SOURCE.

далее, обязательно MVR-ный влан должен быть в бд вланов (sh vlan), просто одного объявления "mvr vlan NN" недостаточно.

далее, мультикаст роутер не нужен. а нужен ip igmp snooping querier, именно такой командой он включается на 3550/2960(LANBASE!).

 

а вот "ip igmp snooping vlan 50 querier address 10.90.90.10" надо убрать

 

если в gi 0/2 воткнут _только_ стример исключительно для вещания, то конфиг будет примерно такой:

(пусть MVR vlan будет также 2-й, например)

 

!
no ip igmp snooping vlan 50 mrouter interface gigabitethernet0/1
no ip igmp snooping vlan 50 querier address 10.90.90.10

!
ip igmp snooping querier
!
mvr
mvr vlan 2
mvr group 228.1.23.4 # убедитесь что именно на этот мультикаст-адрес идет трафик!
!
interface GigabitEthernet0/2
switchport mode access
switchport access vlan 2
mvr type source
!
interface Fa0/2
description это "Человек подключен на этой же циске в другом порту скажем в 10м влане"
switchport mode access
switchport access vlan 10
mvr type receiver
!
vlan 2
!

Share this post


Link to post
Share on other sites

в документации всё правильно написано, читать надо просто уметь:

 

source—Configure uplink ports that receive and send multicast data as

source ports. Subscribers cannot be directly connected to source ports.

All source ports on a switch belong to the single multicast VLAN.

 

и это неочевидно только потому что мало кто внимательно читает.

Share this post


Link to post
Share on other sites

zed_0xff

 

дело в то м что у меня порт gi 0/2 тегированный в двух вланах в 1м и 50м, телек валится и туда и туда. А могу например сделать так?

 

interface GigabitEthernet0/2

description Multic Source

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,50

switchport mode trunk

mvr type source

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

в gi0/2 только ресивер или что-то еще воткнуто?

Share this post


Link to post
Share on other sites
в gi0/2 только ресивер или что-то еще воткнуто?
только он... стриммер. Вещание идет на интерфейс eth0 (дефолтный влан) и на интерфейс eth0.50

 

еще не совем понимаю что это за адрес

mvr group 228.1.23.4 ?

 

у меня каналы идут на разных мультикаст адресах

от 224.0.200.1 до 224.0.200.50 порт 1234

Edited by anclbob

Share this post


Link to post
Share on other sites

мультикаст не может входить сразу в два влана. входит он всегда в один :)

а MVR позволяет ему выходить в два и более вланов.

 

т.е. gi0/2 делаем mode access; mvr type source; access vlan 2

а на интерфейсах на которых хотим ловить поток (которые у вас видимо в mode access для вланов 1 и 50) - делаем mvr type receiver

и все должно пойти

Share this post


Link to post
Share on other sites
мультикаст не может входить сразу в два влана. входит он всегда в один :)

а MVR позволяет ему выходить в два и более вланов.

 

т.е. gi0/2 делаем mode access; mvr type source; access vlan 2

а на интерфейсах на которых хотим ловить поток (которые у вас видимо в mode access для вланов 1 и 50) - делаем mvr type receiver

и все должно пойти

Я ж говорю mode access сделать не могу. Так как есть участок сети где все клиенты скажем в влане 5, а телек заходит в этот сегмет в влане 50. Соответственно на свитче включаю ISM влан (на длинк) и все у всех работает. А есть участок сети где клиенты в дефолтном влане, и оборудование не поддерживает функцию ISM влан. Вот поэтому временно пока не поменяется все оборудование не поддерживающее ISM влан, я вещаю и в 50й влан и в дефолтный.

 

mvr group 228.1.23.4 ? так что это за адрес?

у меня каналы идут на разных мультикаст адресах

от 224.0.200.1 до 224.0.200.50 порт 1234

Share this post


Link to post
Share on other sites

для каждого канала надо создать свой mvr group с соотвествующим адресом:

mvr group 224.0.200.1

mvr group 224.0.200.2

и т.д.

 

но в вашем случае получается что MVR вам скорее всего не подходит :(

можно сделать так:

между ресивером и 3550 воткнуть слабенькую машинку на freebsd, которая будет с одной стороны ловить поток с ресивера, а с другой дублировать его в 2 влана(5 и 50) и отправлять в транк на gi0/2.

тогда все mvr нафиг отключаем, а на длинковских access-ах уже рулим либо через ISM где есть, либо без ISM-а т.к. в этом влане уже будет копия потока

Share this post


Link to post
Share on other sites

на длинках все именно так и происходит. И без фрибсд машинки стриммер умеет одновременно в два влана вещать. Щас задача стоит направить мультикаст на другой порт тойже самой 3550 в влане 10 например.

Share this post


Link to post
Share on other sites

а в три влана он не умеет одновременно вещать? :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this