Jump to content
Калькуляторы

Не загружается новый IOS Catalyst 6500 sup2/msfc2

Всем привет.

Подскажите пожалуйста, что я не так делаю.

Есть Catalyst 6500 с SUP2/MSFC2, flash 32M

Сейчас стоит IOS: c6sup22-jk2o3sv-mz.121-26.E9.bin, он уместился на sup-bootflash

Есть необходимость сменить его на s222-adventerprisek9_wan-mz.122-18.SXF14.bin, но его размер 50М и он не войдет на flash, но есть PCMCI карточка на 256М.

Все хорошо, через tftp положил прошивку на эту карточку (disk0), прописал на bootvar

 

# sh bootvar 
BOOT variable = disk0:s222-adventerprisek9_wan-mz.122-18.SXF14.bin,1
CONFIG_FILE variable = 
BOOTLDR variable = bootflash:c6msfc2-boot-mz.121-27b.E.bin
Configuration register is 0x2102

 

Но каталист не хочет грузиться с него - говорит не валидный имидж. В чем может быть проблема? Что я не так делаю?

Share this post


Link to post
Share on other sites
Всем привет.

Подскажите пожалуйста, что я не так делаю.

Есть Catalyst 6500 с SUP2/MSFC2, flash 32M

Сейчас стоит IOS: c6sup22-jk2o3sv-mz.121-26.E9.bin, он уместился на sup-bootflash

Есть необходимость сменить его на s222-adventerprisek9_wan-mz.122-18.SXF14.bin, но его размер 50М и он не войдет на flash, но есть PCMCI карточка на 256М.

бутром перешивать надо, скорее всего

 

Share this post


Link to post
Share on other sites
Всем привет.

Подскажите пожалуйста, что я не так делаю.

Есть Catalyst 6500 с SUP2/MSFC2, flash 32M

Сейчас стоит IOS: c6sup22-jk2o3sv-mz.121-26.E9.bin, он уместился на sup-bootflash

Есть необходимость сменить его на s222-adventerprisek9_wan-mz.122-18.SXF14.bin, но его размер 50М и он не войдет на flash, но есть PCMCI карточка на 256М.

бутром перешивать надо, скорее всего

Т.е. текущий бутром не видит disk0? Или бутрому может еще и не нравиться прошивка по какой-то причине?

А не подскажите где почитать как это делается?

Edited by kostas

Share this post


Link to post
Share on other sites
Всем привет.

Подскажите пожалуйста, что я не так делаю.

Есть Catalyst 6500 с SUP2/MSFC2, flash 32M

Сейчас стоит IOS: c6sup22-jk2o3sv-mz.121-26.E9.bin, он уместился на sup-bootflash

Есть необходимость сменить его на s222-adventerprisek9_wan-mz.122-18.SXF14.bin, но его размер 50М и он не войдет на flash, но есть PCMCI карточка на 256М.

бутром перешивать надо, скорее всего

Т.е. текущий бутром не видит disk0? Или бутрому может еще и не нравиться прошивка по какой-то причине?

А не подскажите где почитать как это делается?

текущий при загрузке, скорее всего, не видит флешку - такое уже проходили мы на суп2

как делается -

 

Перешивка на примере. Сначала перешиваем ROMMON:

 

upgrade rom-monitor slot 1 sp file tftp://10.59.3.10/ios/cat6000-sup2-rm2.7-1-1.srec

write

reload

 

Вываливаемся в монитор, в нем пишем boot. По пути получаем rommon upgrade successful. Теперь вторая прошивка, для MSFC (bootstrap):

 

upgrade rom-monitor slot 1 rp file tftp://10.59.3.10/ios/c6msfc2-rm2.srec.122-17r.S5

write

reload

 

Теперь появляется возможность загружать систему с disk0:

 

conf t

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF13.bin

exit

write

reload

 

Вот такой кусок конфига позволяет правильно загрузить 12.2 с внешней флешки как на холодном старте, так и на релоаде:

 

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF13.bin

boot system sup-bootflash:c6sup22-jk2o3sv-mz.121-26.E9.bin

boot bootldr bootflash:c6msfc2-boot-mz.121-13.E15.bin

 

Share this post


Link to post
Share on other sites

из ИОСа

rem com sw sh ver

чтобы посмотреть версию ромона в самом супервизоре. если версия отличается от 7.1.1 - то надо апгрейдить. апгрейд роммона самой мсфц не обязателен.

 

еще надо учесть 1 момент: в самом супервизоре для 12.2SX ИОСа должно быть не менее 256Мб памяти. Иначе не загрузится система.

А в осталном Кирилл все правильно написал.

Edited by D^2

Share this post


Link to post
Share on other sites

Ребят, спасибо за помощь! Выручаете неимоверно!

 

Осталось разобраться - какая версия rommon на супервизоре. Вот что выдает - 7.1(1). Оно? Все в порядке или надо все таки новый заливать?

 

#remote command switch sh ver
Cisco Internetwork Operating System Software 
IOS (tm) c6sup2_sp Software (c6sup2_sp-SPV-M), Version 12.1(26)E9, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by cisco Systems, Inc.
Compiled Fri 10-Aug-07 17:46 by hqluong
Image text-base: 0x40020F90, data-base: 0x409B6000

ROM: System Bootstrap, Version 7.1(1)
BOOTLDR: c6sup2_sp Software (c6sup2_sp-SPV-M), Version 12.1(26)E9, RELEASE SOFTWARE (fc1)

Core uptime is 13 hours, 4 minutes
Time since Core switched to active is 13 hours, 5 minutes
System returned to ROM by power-on
System restarted at 21:42:38 MSK Wed Jan 21 2009
System image file is "bootflash:c6sup22-jk2o3sv-mz.121-26.E9.bin"

cisco WS-C6506 (R7000) processor (revision 2.0) with 227328K/34816K bytes of memory.
Processor board ID TBA05040254
R7000 CPU at 250Mhz, Implementation 39, Rev 2.1, 256KB L2, 1024KB L3 Cache
Last reset from power-on
X.25 software, Version 3.0.0.
34 Gigabit Ethernet/IEEE 802.3 interface(s)
381K bytes of non-volatile configuration memory.

32768K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

 

С наличием 256М памяти для новой прошивки тоже не совсем понятно. В фич менеджере обратил внимания что SX все хотят 265/64 памяти, но я в этих модулях совсем запутался - на одном одно, на другом другое. К примеру из IOS:

 

#sh ver

isco WS-C6506 (R7000) processor (revision 2.0) with 458752K/65536K bytes of memory.
Processor board ID TBA05040254
R7000 CPU at 300Mhz, Implementation 39, Rev 3.3, 256KB L2, 1024KB L3 Cache
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
13 Virtual Ethernet/IEEE 802.3  interface(s)
34 Gigabit Ethernet/IEEE 802.3 interface(s)
381K bytes of non-volatile configuration memory.

32768K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

 

Показывает 458752K/65536K bytes of memory, в тоже время в прошлом листинге фигурировала цифра 227328K/34816K bytes of memory.

 

Не хватает, надо еще и оперативки добивать?

 

Share this post


Link to post
Share on other sites

все хватает. 256 на самом супервизоре и 512 на мсфц.

с версией ромона тоже все впорядке. осталось прописать нормально путь загрузки как написал Кирилл.

 

зы. стп победили?

Edited by D^2

Share this post


Link to post
Share on other sites

Ага, спасибо, сегодня будем пробовать - сейчас народ сидит.

Прописал

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF14.bin
boot system sup-bootflash:c6sup22-jk2o3sv-mz.121-26.E9.bin
boot bootldr bootflash:c6msfc2-boot-mz.121-27b.E.bin

 

Было

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF14.bin
boot bootldr bootflash:c6msfc2-boot-mz.121-27b.E.bin

 

Отсутствует только sup-bootflash. Т.е. загрузка получается проходит в такой последовательности?

1. bootflash msfc

2. Затем грузится sup

3. Затем уже, когда sup видит disk0 на своем борту, грузится IOS

 

Похоже стоит почитать доки по процессу загрузки - как-то все запутанно выглядит :)

 

PS: STP буду ковырять на новой прошивке. Благо теперь и железка есть и прошивку надеюсь с вашей помощью все таки сегодня запустим.

 

Еще раз, огромное вам с Кириллом спасибо!!!

 

Share this post


Link to post
Share on other sites
Ага, спасибо, сегодня будем пробовать - сейчас народ сидит.

Прописал

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF14.bin
boot system sup-bootflash:c6sup22-jk2o3sv-mz.121-26.E9.bin
boot bootldr bootflash:c6msfc2-boot-mz.121-27b.E.bin

Это означает: попытаться загрузить систему с внешней флэшки, если не удалось, то со встроенной флешки на SUP2

boot bootldr не нужен, это для гибридной загрузки CatOS на SUP'е и IOS на MSFC.

 

Было

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF14.bin
boot bootldr bootflash:c6msfc2-boot-mz.121-27b.E.bin

 

 

Отсутствует только sup-bootflash. Т.е. загрузка получается проходит в такой последовательности?

1. bootflash msfc

2. Затем грузится sup

3. Затем уже, когда sup видит disk0 на своем борту, грузится IOS

 

Похоже стоит почитать доки по процессу загрузки - как-то все запутанно выглядит :)

1. rommon грузит в память ios и передает управление SUP'у

2. Грузится SUP

3. SUP передает управление MSFC

4. Грузится MSFC

 

Share this post


Link to post
Share on other sites

Почему же тогда в прошлый раз он не смог загрузится с внешней влешки?

 

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF14.bin
boot bootldr bootflash:c6msfc2-boot-mz.121-27b.E.bin

Share this post


Link to post
Share on other sites
Почему же тогда в прошлый раз он не смог загрузится с внешней влешки?

 

boot system flash disk0:s222-adventerprisek9_wan-mz.122-18.SXF14.bin
boot bootldr bootflash:c6msfc2-boot-mz.121-27b.E.bin

А ты уверен, что у тебя загружен именно s222-adventerprisek9_wan-mz.122-18.SXF14.bin ?

 

Share this post


Link to post
Share on other sites

да, конечно.

 

Но сейчас возникла другая проблема. Пол дня уже маюсь.

После замены IOS свалился NAT. При чем хитро свалился - транслящию адресов по sh ip nat вижу, dns по udp опрашиваю снутри наружу без проблем, пингую, но наружу на какой либо другой сервис (80,25,22) попасть не могу.

По дебагу вот такая лажа:

02:08:37: NAT: translation failed (A), dropping packet s=10.6.0.4 d=89.111.176.137
02:08:37: NAT: translation failed (A), dropping packet s=10.6.0.3 d=77.88.21.3
02:08:37: NAT: translation failed (A), dropping packet s=10.6.0.3 d=81.19.88.11
02:08:37: NAT: translation failed (A), dropping packet s=10.6.0.4 d=89.111.176.137
02:08:37: NAT*: s=10.0.0.5->82.20.132.74, d=81.20.76.98 [46227]
02:08:37: NAT*: s=10.0.0.5->82.20.132.74, d=81.20.76.98 [46228]

 

В тоже время PAT работает без каких либо проблем.

 

Еще интересный момент. Зайдя на каталист и попытавшись стукнуться ssh на один из внутренних адресов, просто получаю обрыв своей ssh сессии с каталистом.

 

Сразу скажу что все ACL поотключал. NAT настроет следующим образом.

 

!
interface Vlan2
ip address 82.20.132.74 255.255.255.252
ip access-group inet in
no ip unreachables
ip nat outside
ip wccp web-cache redirect out
ip route-cache flow
ip route-cache policy
ip policy route-map NETUP_MAP
!
interface Vlan4
ip address 10.4.0.1 255.255.255.0
ip nat inside
ip route-cache flow
ip route-cache policy
!
ip nat inside source list NAT-ACCESS interface Vlan2 overload
!
ip access-list standard NAT-ACCESS
permit 10.0.0.0 0.255.255.255
!

 

Не пойму, что могло такое случиться - поменялся только IOS.

 

Share this post


Link to post
Share on other sites

А у тебя стоит FSM модуль?

Или ты NAT процессором на MSFC пытаешься делать?

Share this post


Link to post
Share on other sites

Ммм, вот этого не знаю. Стоит Супервизор2 с MSFC2+PFC2. На счет FSM модуля не в курсе, но с предыдущей прошивкой все работало, была 12.1

Share this post


Link to post
Share on other sites
Ммм, вот этого не знаю. Стоит Супервизор2 с MSFC2+PFC2. На счет FSM модуля не в курсе, но с предыдущей прошивкой все работало, была 12.1

По sh mod должно быть видно, что стоит.

Если нет Firewall Services Module, то лучше пускай оно и не работает: убьете процик на MSFC, он и так не ахти какой быстрый, всего 300МГц.

 

Share this post


Link to post
Share on other sites

Народу пока планируется не более 500. Неужели даже на таком количестве загнется?

Можно конечно натить на отдельном сервере, а там заодно и инет шейпить, потому как на sup2 я так понимаю шейпить не получится?

Share this post


Link to post
Share on other sites

Ребят, ну так чего посоветуете? Почему может трансляция обламываться?

Share this post


Link to post
Share on other sites
Ребят, ну так чего посоветуете? Почему может трансляция обламываться?

Не должно оно было работать. То что работало - это баг :-)

Выноси nat на отдельный тазик с линуксом

 

Share this post


Link to post
Share on other sites
Ребят, ну так чего посоветуете? Почему может трансляция обламываться?

Не должно оно было работать. То что работало - это баг :-)

Выноси nat на отдельный тазик с линуксом

А почему не должно работать? В фич менеджере есть NAT, настраиваю по инструкции. Чета фигня какая-то.

ИМХО если написано - должно работать.

 

Может прошивку поменять. 15ю ревизию к примеру или наоборот чуть старше? Может бага какая?

Share this post


Link to post
Share on other sites

Очень интересно, возможно это натолкнет местных гуру на корень проблемы?

Это лог debug ip nat detailed при попытке стукнуться наружу из-за НАТа.

 

01:53:42: NAT: Error in Allocating port: 82.20.132.74, 50028!
01:53:42: NAT: New Inside Entry: couldn't allocate port 50028 for 82.20.132.74 Protocol: 6
01:53:42: NAT: translation failed (A), dropping packet s=10.4.0.3 d=64.12.161.185

Edited by kostas

Share this post


Link to post
Share on other sites

Похоже замена прошивки на s222-adventerprisek9_wan-mz.122-18.SXF8.bin решила проблему. До этого стояла s222-adventerprisek9_wan-mz.122-18.SXF14.bin

Что это было - баг или еще что, так и не понял.

 

Всем спасибо за помощь!

Share this post


Link to post
Share on other sites
Похоже замена прошивки на s222-adventerprisek9_wan-mz.122-18.SXF8.bin решила проблему. До этого стояла s222-adventerprisek9_wan-mz.122-18.SXF14.bin

Что это было - баг или еще что, так и не понял.

 

Всем спасибо за помощь!

Проблема осталась - я ошибся. Попробовал уже несколько прошивок 12.2(18) -- все одно и тоже.

Может кто нибудь провести мастер-класс по настройке NAT на этом IOS? :)

Share this post


Link to post
Share on other sites

С ошибка трансляции NAT как-то хитро получается.

Выяснилось вот что. Если прописать NAT и проброс порта внутрь через статик, то получаем ошибку трансляции, которая была выше.

 

ip nat inside source list NAT-ACCESS interface Vlan2 overload
ip nat inside source static tcp 10.0.0.2 1234 interface Vlan2 1234

 

Если static на проброс порта убрать, то ошибки само сабой нет и NAT работает замечательно.

 

Попробовал сделать так:

 

ip nat pool poolHTTP 10.0.0.2 10.0.0.2 netmask 255.255.255.0 type rotary
!
ip nat inside destination list aclHTTP pool poolHTTP
!         
ip access-list extended aclHTTP
permit tcp any host 80.24.132.74 eq www

 

В таком варианте ошибок NAT не наблюдается.

 

Почему не работает static?

Share this post


Link to post
Share on other sites

Подниму таки старую тему на счет загрузки IOS на данном железе.

 

После очередного отключения электроэнергии, перестал грузиться Catalyst 6500 c SUP2 (этот же девайс который был в начале топика).

Девайс просто вываливается в ROMMON без каких либо дополнительных сообщений. Если пнуть boot disk0: то он нормально загружает ios и работает.

Прошивки все на месте. Конфиг не менялся.

 

Что могло отломаться?

 

Core#sh bootvar
BOOT variable = disk0:s222-ipservicesk9_wan-mz.122-18.SXF15a.bin,1;
CONFIG_FILE variable = disk0:startup-config
BOOTLDR variable = bootflash:c6msfc2-boot-mz.121-27b.E.bin
Configuration register is 0x2102

Standby is not present.

Core#dir disk0:s222-ipservicesk9_wan-mz.122-18.SXF15a.bin
Directory of disk0:/s222-ipservicesk9_wan-mz.122-18.SXF15a.bin

   1  -rw-    51312644   Feb 1 2009 14:05:18 +03:00  s222-ipservicesk9_wan-mz.122-18.SXF15a.bin

255799296 bytes total (202764288 bytes free)

Core#dir bootflash:c6msfc2-boot-mz.121-27b.E.bin
Directory of bootflash:/c6msfc2-boot-mz.121-27b.E.bin

   1  -rw-     1863540   Dec 2 2008 06:07:12 +03:00  c6msfc2-boot-mz.121-27b.E.bin

31981568 bytes total (16557648 bytes free)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this