Jump to content
Калькуляторы

BDCOM GP3600-16 настройка мультикаста

Коллеги, устал биться головой о стену, прошу помочь кто разбирается!

 

Пытаюсь настроить BDCOM GP3600-16. DHCP поборол, абонент при подключении ОНУ получает настройки и, соответственно, доступ в интернет. А вот с подачей абоненту сервиса IPTV всё застряло.

Схема такая - абонент подключается к единственному порту ОНУ обычным домашним роутером-мыльницей и с этого порта должен получить как доступ в интернет, так и мультикаст (IPTV). То есть, на порту доступа ОНУ нужен аналог MVR/ISM как на свичах. Ниже приведён мой конфиг (убрано то, что явно работает и не касается темы). Ткните носом пожалуйста, что не так и чего не хватает. Влан 35 - интернет-трафик абонента, влан 200 - мультикаст, вланы 15 и 30 - служебные.

 

!version 10.3.0D build 52548
!
!
!
gpon profile onu-tcont tcont-default id 1
 gpon-profile tcont-type 3 pir 1244160 cir 9728
!
gpon profile onu-tcont INTERNET id 2
 gpon-profile tcont-type 3 pir 1244160 cir 9728
!
gpon profile onu-tcont IPTV id 3
 gpon-profile tcont-type 2 cir 9728
!
gpon profile onu-rate-limit ratelimit-default id 1
 gpon-profile pir 1244160 cir 1244160
!
gpon profile onu-virtual-port virtual-port-default id 1
 gpon-profile encryption disable
 gpon-profile upstream queue 8
 gpon-profile upstream rate-limit-profile ratelimit-default
 gpon-profile downstream queue 8
!
gpon profile onu-tcont-virtual-port-bind tvbind-default id 1
 gpon-profile virtual-port 1 profile virtual-port-default tcont 1 profile tcont-default
!
gpon profile onu-tcont-virtual-port-bind UPLINK id 2
 gpon-profile virtual-port 1 profile virtual-port-default tcont 2 profile INTERNET
 gpon-profile virtual-port 2 profile virtual-port-default tcont 3 profile IPTV
!
gpon profile onu-flow-mapping flow-mapping-default id 1
 gpon-profile entry 1 uni type eth-uni all
 gpon-profile entry 1 virtual-port 1
!
gpon profile onu-flow-mapping flow-mapping-default-hgu id 2
 gpon-profile entry 1 uni type veip all
 gpon-profile entry 1 virtual-port 1
!
gpon profile onu-flow-mapping DHCP9 id 4
 gpon-profile entry 1 uni type eth-uni all
 gpon-profile entry 1 vlan 35
 gpon-profile entry 1 virtual-port 1
 gpon-profile entry 2 uni type eth-uni all
 gpon-profile entry 2 vlan 200
 gpon-profile entry 2 virtual-port 2
!
gpon profile onu-vlan DHCP9 id 3
 gpon-profile vlan mode tag
 gpon-profile vlan pvid 35 0
!
gpon profile onu-mcst-oper IPTV id 2
 gpon-profile fast-leave-mode enable
 gpon-profile upstream-igmp-tag add 200 4
 gpon-profile downstream-mcst-tag strip
!
gpon profile onu-mcst-dynamic-group MINIMAL id 2
 gpon-profile entry 1 multicast-gemport 4093
 gpon-profile entry 1 multicast-vlan-id 200
 gpon-profile entry 1 multicast-group-address-range 239.0.0.1 to 239.0.0.100
!
gpon onutype-template onutype-default-hgu
 gpon-onutype match ctc-onu-type HGU
 gpon-onutype config tcont-virtual-port-bind-profile tvbind-default
 gpon-onutype config flow-mapping-profile flow-mapping-default-hgu
!
gpon onutype-template onutype-default
 gpon-onutype config tcont-virtual-port-bind-profile tvbind-default
 gpon-onutype config flow-mapping-profile flow-mapping-default
!
gpon onu-config-template DHCP9
 cmd-sequence 001 gpon onu tcont-virtual-port-bind-profile UPLINK
 cmd-sequence 002 gpon onu flow-mapping-profile DHCP9
 cmd-sequence 003 gpon onu virtual-port 1 downstream rate-limit 1600
 cmd-sequence 004 gpon onu virtual-port 1 dynamic maximum 2
 cmd-sequence 005 gpon onu loopback-detect protocol private
 cmd-sequence 006 gpon onu uni 1 vlan-profile DHCP9
 cmd-sequence 007 gpon onu uni 1 mcst-oper-profile IPTV
 cmd-sequence 008 gpon onu uni 1 mcst-dynamic-group-profile MINIMAL
 cmd-sequence 009 gpon onu uni 1 loopback-detect enable
 cmd-sequence 010 gpon onu fec-tx
!
!
!!slot 0 1
interface GigaEthernet0/1
 description Control&IPTV
 switchport trunk vlan-allowed 15,30,200
 switchport trunk vlan-untagged none
 switchport mode dot1q-tunnel-uplink
 switchport pvid 200
  dhcp snooping trust
 keepalive
!
interface GigaEthernet0/2
 description Uplink_for_Internet
 filter dhcp
 switchport trunk vlan-allowed 35
 switchport trunk vlan-untagged none
 switchport mode dot1q-tunnel-uplink
  arp inspection trust
  ip-source trust
 keepalive
!
!
interface GPON0/1
 gpon pre-config-template DHCP9 bind-onuid 1-128
 gpon bind-onutype onutype-default-hgu precedence 127
 gpon bind-onutype onutype-default precedence 128
 gpon bind-onu sn 5A544547C0E1499B 1
 gpon fec-tx
 filter dhcp
 switchport trunk vlan-allowed 35,200
 switchport mode trunk
 storm-control broadcast threshold 1000
 storm-control multicast threshold 1000
 storm-control unicast threshold 1000
 switchport protected 1
!
interface GPON0/1:1
 gpon onu equipment-id F601V6.0 
 gpon onu tcont-virtual-port-bind-profile UPLINK
 gpon onu flow-mapping-profile DHCP9
 gpon onu virtual-port 1 gem-port 256
 gpon onu virtual-port 1 downstream rate-limit 1600
 gpon onu virtual-port 1 dynamic maximum 2
 gpon onu virtual-port 2 gem-port 257
 gpon onu loopback-detect protocol private
 gpon onu uni 1 vlan-profile DHCP9
 gpon onu uni 1 mcst-oper-profile IPTV
 gpon onu uni 1 mcst-dynamic-group-profile MINIMAL
 gpon onu uni 1 loopback-detect enable
 gpon onu fec-tx
!
!
!!slot end
!
interface VLAN15
 ip address 10.10.62.23 255.255.255.240
 no ip directed-broadcast
 no ip redirects
 no ip unreachables
!
interface VLAN30
 ip address 10.0.1.74 255.255.255.192
 no ip directed-broadcast
 no ip redirects
 no ip unreachables
!
interface VLAN35
 ip address XX.XX.XX.XX 255.255.254.0
 no ip directed-broadcast
 no ip redirects
 no ip unreachables
 ip helper-address 10.10.62.18
!
!
filter enable
!
vlan 15
 name DHCP_SERVER
!
vlan 30
 name CONTROL
!
vlan 35
 name USERS
!
vlan 200
 name IPTV
!
vlan 1,15,30,35,200
!
 loopback-detection
!
ip mcst enable
ip mcst proxy-vlan 200
ip mcst mrouter interface GigaEthernet0/1
ip mcst mc-vlan 200 range 239.0.0.1 - 239.0.0.199
!

 

Share this post


Link to post
Share on other sites

Я пробовал так, работало:

gpon profile onu-mcst-dynamic-group dynamic
 gpon-profile entry 1 multicast-gemport 4093
 gpon-profile entry 1 multicast-vlan-id 2
 gpon-profile entry 1 multicast-group-address-range start 225.0.0.1 stop
225.0.0.100
!
interface GPON0/1:2
 gpon onu tcont-virtual-port-bind-profile tvbind-default
 gpon onu flow-mapping-profile flow-mapping-default
 gpon onu virtual-port 1 gem-port 258
 gpon onu uni 1 mcst-dynamic-group-profile dynamic
!
ip mcst enable
ip mcst proxy-vlan 2
ip mcst querier enable
ip mcst mrouter interface GigaEthernet0/1

 

оригинал:

http://blog.files.dp.ua/multicast-bd-gp3616

 

возможно лишнее:

gpon-profile upstream-igmp-tag add 200 4
Edited by Maximfs79

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this