Jump to content
Калькуляторы

BDCOM p3608 DHCP не видит запросов

Всех приветствую, имеется OLT BDCOM 3608 DHCP сервер 192.168.0.250 не видит запросов от клиента в онушке на первом порту/

!
mirror session 1 destination interface g0/7
mirror session 1 source interface g0/8 both
!
!
epon onu-config-template Clients
 cmd-sequence 001 no epon onu port-protect
 cmd-sequence 002 epon onu all-port ctc vlan mode tag 216
 cmd-sequence 003 epon onu all-port ctc loopback detect
 cmd-sequence 004 epon onu all-port ctc notify loopback
!
!
!
interface GigaEthernet0/8
 description Uplink
 switchport trunk vlan-allowed 1,216
 switchport trunk vlan-untagged 1
 switchport mode trunk
  dhcp snooping trust
  arp inspection trust
  ip-source trust
!
!
interface EPON0/1
 epon pre-config-template Clients binded-onu-llid 1-64
 epon bind-onu mac 9845.622a.e9d3 1
 switchport trunk vlan-allowed 216
 switchport trunk vlan-untagged none
 switchport mode trunk
 no switchport protected
!
interface EPON0/1:1
  epon onu port 1 ctc vlan mode tag 216 priority 0
  epon onu port 1 ctc loopback detect
  epon onu port 1 ctc notify loopback
  no epon onu port-protect
!
!
interface VLAN1
 description Managment
 ip address 192.168.0.40 255.255.255.0
 no ip directed-broadcast
!
interface VLAN216
 description Clients
 ip address 172.20.0.216 255.255.255.0
 no ip directed-broadcast
 ip helper-address 192.168.0.250
!
!
!
vlan 1,216
!
!
!
ip dhcpd enable
!
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  216
ip dhcp-relay snooping information option format hn-type
ip dhcp-relay snooping log
!
!

 

Share this post


Link to post
Share on other sites

Та же проблема, OLT релаит запросы от клиента броадкастом, как заставить работать его юникастом ума не приложу(

Share this post


Link to post
Share on other sites

А на DHCP-сервере пинг на 172.20.0.216 идёт?

Share this post


Link to post
Share on other sites

@olafff 3608 не релеит DHCP запросы, она может только добавить в них опцию 82, а релеить придеться выше.

Share this post


Link to post
Share on other sites

Точно? У меня тогда, видимо, кучка бракованных 3608 попалась. Ибо очень даже релеят. На dhcp-сервер приходит юникастовый запрос от 3608 с src-ip, выставленным в оном на абонентском влане. Поэтому я выше и задал вопрос - корректно ли построена маршрутизация на dhcp-сервере.

Share this post


Link to post
Share on other sites

У нас релеило до 13/01/2019

 

С таким конфигом:

 

ip dhcp-relay snooping
ip dhcp-relay snooping vlan  x-x
ip dhcp-relay snooping information option format hn-type

 

///этого никогда не было

ip dhcpd enable
!
interface VLAN216
 description Clients
 ip address 172.20.0.216 255.255.255.0
 no ip directed-broadcast
 ip helper-address 192.168.0.250
!

 

Полгода работало) И опц82 была и запросы с ответами.

А вчера просто перестало. Абсолютно никаких изменений на сети и в конфигах. Просто проснулись утром, а там вот.

 

Проключеные транзитом коммутаторы работают. А сам BDCOM с его абонентами - нет.

Перепробовано множество вариантов, но пока так и не удалось его "починить".

 

Включал dhcpd, и интерфейс поднимал, и пинги везде ходят, и грузил я его раза три, и прошивку менял. Тишина.

Понимаю головой, что такого не бывает просто так. Обязана быть причина. Но ему на самом деле ничего не мешает работать. Я в ступоре.

 

== 

По дебагу если судить нашему и формату DHCP, то я такое видел 2 раза.

На коммутаторах длинк. Было ровно то же самое поведение. И так же причина не была обнаружен. Психанул, перезагрузил свич и все само заработало. Не знаю что это было.

Потом такая же штука случилась на GPON, но у другого вендора. Там еще прикольней было. Не было 82 опции и dhcp только с одной ONU. Точнее приходило криво. Конфиг унифицирован для всех, а не пашет одна онушка с куста. И вновь не понял причину не работы. Заменил терминал у абонента, сбросил конфиг порта и вернул копи-пастом обратно. Заработало.

 

В случае с BDCOM эти все манипуляции я сделал в первую очередь. Но в его случае не работает весь GPON-доступ, а не один терминал. Перезагрузкой не лечится и сбросом конфига тоже.

Share this post


Link to post
Share on other sites
On 2/13/2019 at 10:59 AM, nemo_lynx said:

А на DHCP-сервере пинг на 172.20.0.216 идёт?

 

А почему он должен идти на 172.20.0.216?

Разве ему не достаточно видеть 192.168.0.40 на "аплинк" порту?

Share this post


Link to post
Share on other sites
9 минут назад, olafff сказал:

А почему он должен идти на 172.20.0.216?

Разве ему не достаточно видеть 192.168.0.40 на "аплинк" порту?

Не достаточно. Я уже писал выше. Потому что в юникастовый реквест bdcom поставит src-ip именно 172.20.0.216. Почему так спросите у китайских товарищей.

Share this post


Link to post
Share on other sites
2 minutes ago, nemo_lynx said:

Не достаточно. Я уже писал выше. Потому что в юникастовый реквест bdcom поставит src-ip именно 172.20.0.216. Почему так спросите у китайских товарищей.

интересный момент, сейчас добавлю маршрутик.

отпишусь по результату, спасибо.

Share this post


Link to post
Share on other sites
2 hours ago, nemo_lynx said:

Не достаточно. Я уже писал выше. Потому что в юникастовый реквест bdcom поставит src-ip именно 172.20.0.216. Почему так спросите у китайских товарищей.

 

да, добавление роута решило этот вопрос, запросы посыпали на dhcpd сервер, спасибо за подсказку!)

 

 

Share this post


Link to post
Share on other sites
14 минут назад, olafff сказал:

 

да, добавление роута решило этот вопрос, запросы посыпали на dhcpd сервер, спасибо за подсказку!)

 

 

"Восток - дело тонкое" (с) Товарищ Сухов.

Share this post


Link to post
Share on other sites

Заработало у нас DHCP.

 

Помог НАГ. Спасибо им!)

 

Добавлена команда - epon local-mac forward

Никаких абонентских влан-интерфейсов, хэлперов и тд у нас никогда не было в конфиге.

Голый dhcp-relay snooping.

 

Он работал очень долго. Потом сам перестал.

В конфиге этой команды тоже никогда не было.

Так и не понял почему без нее столько времени отработало) Ну ладно, главное сейчас заработало как надо.

 

Еще раз спасибо НАГу. Вряд ли я бы до этой команды додумался.

В конфиг-гайдах о ней ни слова.

 

 

Share this post


Link to post
Share on other sites

@nemo_lynx хорошо поправлюсь, в классическом понимании 3608 не релеит запросы если у него нет svi в этом влане. К примеру vlan-per-user 3608 не отрелеит, а 3310С без проблем перехватывает dhcp пакеты и юникастом отправляет их на дхцп сервер со своего management ip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this