Jump to content
Калькуляторы

mikrotik несколько шлюзов в одной сети

приветствую Всех!

помогите разобраться, имеем маршрутизатор mikrotik к нему подключаем абонентов в основной VNP и PPPOE

адреса у абонентов 3х видов:

1. 192.168.88.0/24 (серая сетка)

2. 1.1.1.1/24 (прямая арендованная)

3. 2.2.2.2/24 (прямая арендованная 2ая)

не могу понять как правильно сделать следующее: надо направить абонентов в разные шлюзы в зависимости от того какой адрес им выдал шлюз, 

чтото типа: /ip route add disabled=no distance=20 gateway=192.168.0.1 pref-src=1.1.1.1/24

Share this post


Link to post
Share on other sites

Смотрите /IP ROUTE RULE.

Кроме того, должен быть корректно настроен маскарад для исходящих пакетов из серой подсети.

Share this post


Link to post
Share on other sites

даже если на этой машине нет ната? она просто должнапересылать серую сеть 1.1.1.1/24 на одну машину а 2.2.2.2/24 на 2ую... причём обе машины в одной сети с НАСом

Share this post


Link to post
Share on other sites
6 часов назад, newtomy сказал:

даже если на этой машине нет ната?

Да.  У Вас будут как минимум две таблицы маршрутизации содержащие разные исходящие маршруты. Одна таблица - через один шлюз, вторая - через другой. 
В route rule указываете, для какого src-ip (подсети) по какой таблице отправлять пакеты дальше.

Share this post


Link to post
Share on other sites

может быть есть примеры рабочей схемы, не совсем понятно как оно должно выглядеть в конечном результате...

 

исходное:

сеть 1: 1.1.1.1/24

сеть 2: 2.2.2.2/24

 

адрес навешивается абоненту из сети 1 или сети 2

 

у маршрутизатора на порту wan адрес 3.3.3.1

 

для сети 1: 1.1.1.1/24  -  шлюз 3.3.3.2

для сети 2: 2.2.2.2/24  -  шлюз 3.3.3.3

Share this post


Link to post
Share on other sites

@newtomy , чтобы вам ответить нужна ваша схема сети с адресацией. Потрудитесь нарисовать её, обозначив линки, интерфейсы, адреса на интерфейсах.

Share this post


Link to post
Share on other sites

O_o а я их и обозначил...

 

NAT1 - 3.3.3.2

NAT2 - 3.3.3.3

 

NAS (где авторизуются абоненты) 3.3.3.1

НАС видит нат в интерфейсе eth2 они в одной сети 3.3.3.0/24

 

абонентам выдаётся адреса из сетей:

 

сеть 1: 1.1.1.1/24

сеть 2: 2.2.2.2/24

 

для сети 1: 1.1.1.1/24  -  шлюз 3.3.3.2

для сети 2: 2.2.2.2/24  -  шлюз 3.3.3.3

Share this post


Link to post
Share on other sites
В 21.01.2018 в 16:34, newtomy сказал:

адреса у абонентов 3х видов:

1. 192.168.88.0/24 (серая сетка)

2. 1.1.1.1/24 (прямая арендованная)

3. 2.2.2.2/24 (прямая арендованная 2ая)

 

1 час назад, newtomy сказал:

абонентам выдаётся адреса из сетей:

 

сеть 1: 1.1.1.1/24

сеть 2: 2.2.2.2/24

 

для сети 1: 1.1.1.1/24  -  шлюз 3.3.3.2

для сети 2: 2.2.2.2/24  -  шлюз 3.3.3.3

Ваш поток сознания невозможно разобрать. Телепатический шлем на профилактике.

У Вас то три сети, то две.
1.1.1.1/24 и 2.2.2.2/24 это не адреса сетей
В сети 1.1.1.0/24  не может быть  шлюз 3.3.3.2
Еще раз повторяю: Потрудитесь корректно сформулировать вопрос  и нарисовать схему, обозначив линки, интерфейсы, адреса на интерфейсах.

Edited by nkusnetsov

Share this post


Link to post
Share on other sites

да... это я красиво написал... попробую исправиться:

 

 

NAT1 - 3.3.3.2 (NAS видит этот адрес через ETH2, сеть 3.3.3.0/24)

NAT2 - 3.3.3.3(NAS видит этот адрес через ETH2, сеть 3.3.3.0/24)

 

NAS 3.3.3.1 (НАС видит NAT'ы в интерфейсе eth2 они в одной сети 3.3.3.0/24)

 

NAS в сторону абонентов без адреса, там только служба PPPOE (eth1), абонентам выдаются адреса из сетей:

сеть 1: 1.1.1.0/24 (PPPOE)

сеть 2: 2.2.2.0/24 (PPPOE)

 

надо сделать на NASe правила для:

для сети 1: 1.1.1.0/24  -  шлюз 3.3.3.2

для сети 2: 2.2.2.0/24  -  шлюз 3.3.3.3

 

 

по моему так всё верно, ивените уж что сформулировал всё как-то не очень :)

Share this post


Link to post
Share on other sites

@newtomy , у вас адреса 3.3.3.1/24, 3.3.3.2/24 и 3.3.3.3/24 принадлежат одному и тому же устройству и висят все трое на интерфейсе eth2 ?
Это линк на провайдера?
У провайдера шлюз для всех один и тот же, например, 3.3.3.254 ?

Edited by nkusnetsov

Share this post


Link to post
Share on other sites

нет 

3.3.3.2   NAT1

3.3.3.3 - MAT2

 

3.3.3.1 NAS

 

3.3.3.0 - серая сеть

 

наты со стороны провайдера нужно распределить абонентов в разные направление

Share this post


Link to post
Share on other sites

@newtomy , создаете вторую таблицу маршрутизации. 
В основной (main) default route через 3.3.3.2

Во второй (table2) default route через 3.3.3.3.
Затем создаёте правило типа:
/ip ro ru add disabled=no src-address=2.2.2.0/24 table=table2

И весь трафик от сети 2.2.2.0/24 чудесным образом полетит через второй NAT

Edited by nkusnetsov

Share this post


Link to post
Share on other sites

не очень понял как должно выглядеть "создаете вторую таблицу маршрутизации"

 

завёл:
 

Цитата


[admin@NAS] /ip route rule> print 
Flags: X - disabled, I - inactive 
 0   src-address=1.1.1.0/24 action=lookup table=table2 

 1   src-address=2.2.2.0/24 action=lookup table=table2 
[admin@NAS] /ip route rule> 

 

что еще надо, как я понимаю какое-то правило в :

 

Цитата

[admin@NAS] /ip route> print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          3.3.3.2          20

 

 

или так сделать:

 

Цитата

 

[admin@NAS] /ip route rule> print 
Flags: X - disabled, I - inactive 
 0   src-address=1.1.1.0/24 dst-address=3.3.3.2/32 action=lookup table=table2 

 1   src-address=2.2.2.0/24 dst-address=3.3.3.3/32 action=lookup table=main 
[admin@NAS] /ip route rule> 

 

??
 

Share this post


Link to post
Share on other sites
8 часов назад, newtomy сказал:

что еще надо, как я понимаю какое-то правило в :

 

Цитата

[admin@NAS] /ip route> print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          3.3.3.2          20

Именно сюда. Но не правило, а альтернативный маршрут в отдельную таблицу.

Share this post


Link to post
Share on other sites

блин можете написать пример как это должно выглядеть? не могу понять

Share this post


Link to post
Share on other sites

толи я не туда смотрю толи не понимаю логики работы микротика

 

создаём 2 правила

 

Цитата

 

[admin@NAS] /ip route rule> print 
Flags: X - disabled, I - inactive 
 0   src-address=1.1.1.0/24 action=lookup table=table2 

 1   src-address=2.2.2.0/24 action=lookup table=table1
[admin@NAS] /ip route rule> 

 

где прописывается маршрут для них?

 

в ip\route можно задать только IP начальный и IP конечный

Цитата


[admin@NAS] /ip route> print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          3.3.3.2          20


 

 

не могу понять как задать что для "table2" основной шлюз другой?

Share this post


Link to post
Share on other sites
В 29.01.2018 в 20:25, nkusnetsov сказал:

Затем создаёте правило типа:
/ip ro ru add disabled=no src-address=2.2.2.0/24 table=table2

 

 

3 часа назад, newtomy сказал:

где прописывается маршрут для них?

 

Share this post


Link to post
Share on other sites

стоп т.е. я делаю:


 

Цитата

 

[admin@NAS] /ip route rule> print 
Flags: X - disabled, I - inactive 
 0   src-address=1.1.1.0/24 dst-address=3.3.3.2/32 action=lookup table=table2 

 1   src-address=2.2.2.0/24 dst-address=3.3.3.3/32 action=lookup table=main
[admin@NAS] /ip route rule> 

 

 

и не надо (в ip\route пусто нет  0 A S  0.0.0.0/0                          3.3.3.2          20):

 

Цитата

[admin@NAS] /ip route> print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE

 


 

Edited by newtomy

Share this post


Link to post
Share on other sites

@newtomy , надо добавить дефолтный маршрут через 3.3.3.2 во вторую таблицу
/ip route add gateway=3.3.3.2 routing-mark=table2

В таблице main должен существовать маршрут через 3.3.3.3 
/ip route add gateway=3.3.3.3 

Edited by nkusnetsov

Share this post


Link to post
Share on other sites

блин, спасибо вам (всем!!) огромное! никак не мог понять куда глядеть

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now