Jump to content
Калькуляторы

туннель между офисом и складом

Появилась задача прокинуть туннель между офисом (10.255.255.1) и складом (10.255.255.2).

Но вот не задача. С маршрутизатора находящегося в офисе вижу сервера и компьютеры склада,

а вот с маршрутизатора находящегося на складе нет доступа ни к серверам ни к компьютерам офиса.

 

С маршрутизатора на складе пробую пингануть:

 

ping 10.255.255.1  <---------- адрес туннеля офисного маршрутизатора
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.255.255.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

ping 192.168.20.222  <---------- адрес локалки офисного маршрутизатора
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.222, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

А вот если выполнить пинг сервера находящегося за маршрутизатором, то в ответ тишина:

ping 192.168.20.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.100, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

 

Маршрутизатор находящийся в офисе (DMVPN HUB):

 

#sh run

Building configuration...

 

Current configuration : 2052 bytes

!

! Last configuration change at 10:41:02 MSK Mon Aug 14 2017 by

! NVRAM config last updated at 10:41:03 MSK Mon Aug 14 2017 by

!

version 15.2

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 7XXX

!

boot-start-marker

boot-end-marker

!

!

!

aaa new-model

!

!

aaa authentication login default local

!

!

!

!

!

aaa session-id common

clock timezone MSK 3 0

clock calendar-valid

!

!

!

!

!

!

no ip domain lookup

ip domain name 7XXX.local

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

memory-size iomem 256

!

!

!

!

!

ip ssh version 2

!

!

!

!

!

!

!

!

!

interface Tunnel0

ip address 10.255.255.1 255.255.255.0

no ip redirects

ip nhrp map multicast dynamic

ip nhrp network-id 1

ip ospf network broadcast

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

!

interface FastEthernet0/0

no ip address

shutdown

speed auto

duplex auto

!

interface GigabitEthernet0/0

ip address dhcp

media-type rj45

speed auto

duplex auto

negotiation auto

!

interface GigabitEthernet0/1

ip address 192.168.20.222 255.255.255.0

media-type rj45

speed auto

duplex auto

negotiation auto

!

interface GigabitEthernet0/2

no ip address

shutdown

speed auto

duplex auto

negotiation auto

!

interface GigabitEthernet0/3

no ip address

shutdown

speed auto

duplex auto

negotiation auto

!

router ospf 1

router-id 10.255.255.1

passive-interface default

no passive-interface Tunnel0

network 10.255.255.0 0.0.0.255 area 0

network 192.168.0.0 0.0.255.255 area 0

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

line con 0

exec-timeout 60 0

logging synchronous

stopbits 1

line aux 0

no exec

transport output none

stopbits 1

line vty 0 4

exec-timeout 60 0

privilege level 15

logging synchronous

transport input ssh

!

!

end

 

 

 

Маршрутизатор находящийся на складе (DMVPN SITE):

 

#sh run

Building configuration...

 

 

Current configuration : 3115 bytes

!

! Last configuration change at 15:59:32 MSK Mon Jan 2 2006

! NVRAM config last updated at 15:59:34 MSK Mon Jan 2 2006

version 15.1

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service sequence-numbers

!

hostname 28XX

!

boot-start-marker

boot system flash:c2800nm-adventerprisek9-mz.151-4.M12a.bin

boot-end-marker

!

!

! card type command needed for slot/vwic-slot 0/1

!

aaa new-model

!

!

aaa authentication login default local

!

!

!

!

!

aaa session-id common

!

clock timezone MSK 3 0

clock calendar-valid

!

dot11 syslog

ip source-route

!

!

ip cef

!

ip dhcp excluded-address 192.168.1.150 192.168.1.254

ip dhcp excluded-address 192.168.1.1 192.168.1.10

!

ip dhcp pool DHCP_POOL

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.254

dns-server 8.8.8.8

domain-name Sklad.local

lease 7

!

!

no ip domain lookup

ip domain name 28XX_Sklad.local

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

redundancy

!

!

ip tcp timestamp

ip ssh version 2

!

!

!

!

!

!

!

!

interface Tunnel0

ip address 10.255.255.2 255.255.255.0

no ip redirects

ip nhrp map 10.255.255.1 213.141.130.178

ip nhrp map multicast 213.141.130.178

ip nhrp network-id 1

ip nhrp nhs 10.255.255.1

ip ospf network broadcast

ip ospf priority 0

tunnel source Dialer1

tunnel mode gre multipoint

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

ntp disable

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface GigabitEthernet0/1

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/0/0

no ip address

!

interface FastEthernet0/0/1

no ip address

!

interface FastEthernet0/0/2

no ip address

!

interface FastEthernet0/0/3

no ip address

!

interface Vlan1

no ip address

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp eap refuse

ppp chap hostname 327945

ppp chap password 7 03510E5E

!

router ospf 1

router-id 10.255.255.2

passive-interface default

no passive-interface Tunnel0

network 10.255.255.0 0.0.0.255 area 0

network 192.168.0.0 0.0.255.255 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip nat inside source list 10 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 10 permit 192.168.1.0 0.0.0.255

!

!

!

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

!

line con 0

exec-timeout 60 0

logging synchronous

line aux 0

no exec

transport output none

line vty 0 4

exec-timeout 60 0

privilege level 15

logging synchronous

transport input ssh

!

scheduler allocate 20000 1000

end

 

 

Edited by Jora_Cornev

Share this post


Link to post
Share on other sites

Также пробовал с маршрутизатора находящегося на складе:

traceroute 192.168.20.100
Type escape sequence to abort.
Tracing the route to 192.168.20.100
VRF info: (vrf in name/id, vrf out name/id)
 1 10.255.255.1 4 msec 4 msec 4 msec
 2  *  *  *
 3  *  *  *
 4  *  *  *

Жизнь пакета почему-то обрывается на туннельном интерфейсе (tunnel 0) маршрутизатора находящегося в офисе.

Edited by Jora_Cornev

Share this post


Link to post
Share on other sites

Похоже Вы настраиваете не просто туннель , а DMVPN и если да, то вот мои настройки:

На хабе касательно туннеля

interface Tunnel2
ip address 10.10.11.199 255.255.255.0
no ip redirects
ip mtu 1440   <------Это константа вычисляется исходя из накладных расходов на тунель
ip nhrp authentication some_password
ip nhrp map multicast dynamic
ip nhrp network-id 998
ip tcp adjust-mss 1360  <----------------Подбиралось
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 998

На споках

interface Tunnel0
ip address 10.10.11.200 255.255.255.0
no ip redirects
ip mtu 1440
ip nhrp authentication some_password
ip nhrp map multicast 91.91.91.91  <---------- реальный ip адрес хаба
ip nhrp map 10.10.11.199 91.91.91.91 <-------|
ip nhrp network-id 998
ip nhrp nhs 10.10.11.199
ip nhrp registration no-unique
ip tcp adjust-mss 1360
tunnel source Dialer1
tunnel destination 91.91.91.91 <---------- реальный ip адрес хаба
tunnel key 998

Share this post


Link to post
Share on other sites

sunrise333, да это туннель DMVPN.

К нему вопросом вроде нет.

Т.к. трафик через туннель ходит и адреса туннельных интерфейсов видны по обе стороны маршрутизаторов.

Тут вопрос в том, что со стороны офисного маршрутизатора видны все ресурсы склада, а вот со складского маршрутизатора нет доступа к ресурсам офиса.

Share this post


Link to post
Share on other sites

Если у кого-то есть желание подзаработать на чужом горе, обращайтесь в ЛС.

С вас настройка, с меня деньги...

Share this post


Link to post
Share on other sites

А вот если выполнить пинг сервера находящегося за маршрутизатором, то в ответ тишина:

ping 192.168.20.100

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.20.100, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

[А вдруг]

У устройства 192.168.20.100 маршрут то покуда идёт?

[/А вдруг]

Share this post


Link to post
Share on other sites

Так этим делом вроде OSPF занят?

 

router ospf 1
router-id 10.255.255.1
passive-interface default
no passive-interface Tunnel0
network 10.255.255.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0

Share this post


Link to post
Share on other sites

Нет там сейчас другая железка пыхтит.

Её я как раз хочу поменять на циску.

Адрес у нее 20.254. Т.е. в данной подсети шлюз у всех устройств 192.168.20.254.

 

А вот если выполнить пинг сервера находящегося за маршрутизатором, то в ответ тишина:

ping 192.168.20.100

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.20.100, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

[А вдруг]

У устройства 192.168.20.100 маршрут то покуда идёт?

[/А вдруг]

Адрес - 192.168.20.100

Маска - 255.255.255.0

Шлюз - 192.168.20.254

 

 

 

Интерфейс GI0/1 у циски находящейся в офисе в том же диапазоне.

По логике, маршрут в одноранговой сети нах не нужен...

Поправьте если я ошибаюсь?

Share this post


Link to post
Share on other sites

У вас на пк нет маршрута до сети склада. Вот и все. Поэтому ответ и не приходит.

Share this post


Link to post
Share on other sites

ПК не причём.

Всё запросы делаю прямо с самих маршрутизаторов.

 

У вас на пк нет маршрута до сети склада. Вот и все. Поэтому ответ и не приходит.

 

zhenya, тут обратная ситуация, что с маршрутизатора находящегося в офисе, я прекрасно вижу все ресурсы расположенные за маршрутизатором находящемся на складе.

Но вот в обратном порядке, склад-офис, не чего не видно, кроме интерфейсов маршрутизатора находящегося в офисе.

Share this post


Link to post
Share on other sites

ПК не причём.

Всё запросы делаю прямо с самих маршрутизаторов.

 

У вас на пк нет маршрута до сети склада. Вот и все. Поэтому ответ и не приходит.

 

zhenya, тут обратная ситуация, что с маршрутизатора находящегося в офисе, я прекрасно вижу все ресурсы расположенные за маршрутизатором находящемся на складе.

 

Ну наверное там нету шлюза по умолчанию

Но вот в обратном порядке, склад-офис, не чего не видно, кроме интерфейсов маршрутизатора находящегося в офисе.

Share this post


Link to post
Share on other sites

все правильно. сеть маршрутизатора офиса у тебя connected относительно маршрутизатора склада.

 

пк склада -> маршрутизатор склада -> маршрутизатор офиса. все чисто и правильно.

также как и обратный пинг.

А вот когда ты делаешь трасерт до пк в офисе. у тебя пакет доходит до пк в офисе. но ответ уходит по маршруту по умолчанию, а у тебя там шлюз другой.

 

 

Вот если бы в офисе у тебя трафик проходил через эту циску с впном, то все было бы ок.

Share this post


Link to post
Share on other sites

Ок, попробую тогда сейчас на ПК поменять шлюз.

Очень бы хотелось, чтоб проблема была в этом.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this