Jump to content
Калькуляторы

Проблема с S2980G-24T трабла с аксесом

Всех приветствую. Обращаюсь за помощью с такой проблемой. Имеется вышеуказанный коммутатор, проблема вот в чем, есть 2 провайдера, схема "роутер на палочке". Так вот есть 3 порта на коммутаторе:

Interface Ethernet1/25
media-type copper
description -=Uplink-to-cisco-2911=-
switchport mode trunk
switchport trunk allowed vlan 111;135-137;238;250 
switchport trunk native vlan 99
!
Interface Ethernet1/26
speed-duplex force100-full
description -=Up-to-PV2=-
switchport access vlan 238

Interface Ethernet1/27
description -=Up-to-PV1=-
switchport access vlan 111

на роутере соттвественно есть 2 саб интерфейса для PV1 и PV2 могу их привести если нужно, но не думаю что проблема в сабах. Так вот, провайдер 1 работает нормально, а вот провайдер 2 никак не хочет работать. Пинг есть только до шлюза и все... Уже всю голову поломал себе... И тут я заметил особенность (не знаю то ли у этих коммутаторов такая особенность, то ли я дурак...) при выводе команды sh ver он показывает вот что:

Switch Device, Compiled on Apr 10 09:07:41 2015
 sysLocation Earth
 CPU Mac 00:03:0f:2b:7d:31
 Vlan MAC 00:03:0f:2b:7d:30
 SoftWare Version 7.0.3.5(B0221.0043)
 BootRom Version 7.0.24
 HardWare Version 2.0
 CPLD Version N/A
 Serial No.:SW026110D312790224
 Copyright (C) 2001-2012 by Vendor
 All rights reserved
 Last reboot is warm reset.
 Uptime is 0 weeks, 0 days, 1 hours, 27 minutes

То есть модель не пишется почему то, а какой то switch device? я не грешу что в этом проблема, но все же хочется какого то порядка чтоли. Обновлял данный коммутатор вот этим ПО:

S2980G-8-24-48T_7.0.3.5(B0221.0055).zip

 

потом попробовал вот этой:

S2980G-8-24-48T_7.0.3.5(B0221.0043).zip

 

результат 1, второй провайдер так и не завелся... Хотя, если воткнуть этот кабель напрямую в циску или ПК, то все ок, все работает. Вывод сам по себе напрашивается, где то затык в коммутаторе. Весь конфиг коммутатора ниже:

sysLocation Earth
sysContact 800-xxx-xxxx
!
authentication logging enable
!
!
authentication line console login local
authorization line console exec local
authorization line vty exec local
authorization line web exec local
aaa authorization config-commands
authorization line vty command 15 local
!
!
!
clock timezone VLAT add 10 0
!
!
ssh-server enable
ssh-server timeout 600
!
no telnet-server enable
!
!
!
!
!
!
!
mtu 2030
!
!
vlan 1 
!
vlan 99
name Native_vlan
!         
vlan 111
name p1
!
vlan 135
name -=LOCALNET=-
!
vlan 136
name manage
!
vlan 137
name -=ppp1=-
!
vlan 238
name -=P2=-
!
Interface Ethernet1/1
description -=Uplink-to-S2980-2=-
switchport mode trunk
switchport trunk allowed vlan 135-136 
switchport trunk native vlan 99
!
Interface Ethernet1/2
description -=Uplink-to-S2980-3=-
switchport mode trunk
switchport trunk allowed vlan 135-136 
switchport trunk native vlan 99
!
Interface Ethernet1/3
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/4
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/5
description -=LOCALNET=-
switchport access vlan 135
!         
Interface Ethernet1/6
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/7
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/8
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/9
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/10
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/11
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/12
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/13
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/14
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/15
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/16
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/17
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/18
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/19
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/20
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/21
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/22
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/23
description -=LOCALNET=-
switchport access vlan 135
!
Interface Ethernet1/24
description -=UP-to-ppp1=-
switchport access vlan 137
!
Interface Ethernet1/25
media-type copper
description -=Uplink-to-cisco-2911=-
switchport mode trunk
switchport trunk allowed vlan 111;135-137;238;250 
switchport trunk native vlan 99
!
Interface Ethernet1/26
description -=Up-to-P2-
speed-duplex force100-full
switchport access vlan 238
!
Interface Ethernet1/27
description -=Up-to-P1=-
switchport access vlan 111
!
Interface Ethernet1/28
!
interface Vlan1
shutdown
!
interface Vlan136
ip address 192.168.9.50 255.255.255.240
!
ip route 0.0.0.0/0 192.168.9.49
!
ntp enable
ntp server 192.168.10.1
!
!
no login
!
end

Share this post


Link to post
Share on other sites

kolka88, приветствую!

Отсутствие информации о модели коммутатора говорит о том, что были повреждены конфигурационные файлы. Для его восстановления откройте обращение в support и приложите к нему модель и вывод `sh ver`.

 

Описанная же проблема со вторым провайдером с этим не связана. Коммутатор в данном случае просто коммутирует кадры по MAC-адресам в пределах конкретного vlan, а тот факт, что пинг до шлюза проходит, говорит об отсутствии проблем с коммутацией.

Имеет смысл проверить настройки саб-интерфейсов и маршрутизации.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this