Jump to content
Калькуляторы

IPv6 и VRF vrf lite

Всем добрый день.

 

По ряду причин в локальной сети использую цискин vrf lite в ipv4. Условно vpn_20 для связи между маршрутизаторами и vpn_что-то для прочих сетей. Маршруты успешно проливаются с помощью bgp.

На тестовой железке миграция с ip vrf к vrf definition прошла успешно, но никак не могу завести в этом address-family ipv6 - маршруты протекать не хотят.

 

У кого-то есть опыт настройки этого?

 

Рабочая часть конфига для ipv4 ниже, нужен аналог для ipv6. Железо Cisco 3650, ipservices, 16.3.2.

 

vrf definition vpn_20
rd 100:20
route-target export 100:20
route-target import 100:12
!
address-family ipv4
exit-address-family
!
vrf definition vpn_guest
rd 100:12
route-target export 100:12
route-target import 100:20
!
address-family ipv4
exit-address-family
interface Vlan20
description Routing
vrf forwarding vpn_20
ip address 192.168.20.9 255.255.255.0
!
interface Vlan86
description Test
vrf forwarding vpn_guest
ip address 192.168.86.1 255.255.255.0
!
router bgp 65535
bgp log-neighbor-changes
!
address-family ipv4 vrf vpn_20
 redistribute connected
exit-address-family
!
address-family ipv4 vrf vpn_guest
 redistribute connected
exit-address-family

Share this post


Link to post
Share on other sites

На других свитчах на 15й IOS настраивалось копипастом настроек VRF и BGP (как раз того что вы привели) с заменой "ipv4" на "ipv6" и "ip address ..." на "ipv6 address ...", маршруты нормально перетекали.

Share this post


Link to post
Share on other sites

На других свитчах на 15й IOS настраивалось копипастом настроек VRF и BGP (как раз того что вы привели) с заменой "ipv4" на "ipv6" и "ip address ..." на "ipv6 address ...", маршруты нормально перетекали.

 

Из посторонних команд только ipv6 unicast-routing? Странное ощущение, что я не нашёл какой-то волшебной команды вроде mls ipv6 vrf (её нет на этом свиче).

Share this post


Link to post
Share on other sites

Настраивал на 49х цисках, там mls нету.

Проверьте правильно ли настроен SDM template, включен ли ipv6 cef, и дальше стандартная диагностика:

- есть ли маршрут в rib vpn_20?

- есть ли маршрут в bgp vrf vpn_20?

- перетек ли маршрут в bgp vrf vpn_guest?

- добавился ли маршрут в rib vrf vpn_guest?

И аналогично в обратном направлении из vpn_guest в vpn_20.

Share this post


Link to post
Share on other sites

Стандартную диагностику гну третий день, но, кажется, нашёл рабочий способ. Спасибо за участие :)

 

Маршруты Connected между vrf проливались, но маршрут по умолчанию со шлюзом в другом vrf не появлялся. Покажу состояние "до решения":

 

ip route vrf vpn_guest 0.0.0.0 0.0.0.0 192.168.20.12
ipv6 route vrf vpn_guest ::/0 fc00:20::12

test-cat# show ipv6 route vrf vpn_guest
B   fc00:20::/64 [20/0]
    via Vlan20%vpn_20, directly connected
C   fc00:86::/64 [0/0]
    via Vlan86, directly connected
L   fc00:86::1/128 [0/0]
    via Vlan86, receive
L   FF00::/8 [0/0]
    via Null0, receive

test-cat# show ip route vrf vpn_guest
S*    0.0.0.0/0 [1/0] via 192.168.20.12
     192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
B        192.168.20.0/24 is directly connected, 1d23h, Vlan20
L        192.168.20.9/32 is directly connected, Vlan20
     192.168.86.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.86.0/24 is directly connected, Vlan86
L        192.168.86.1/32 is directly connected, Vlan86
S     192.168.101.0/24 is directly connected, Null0

 

Т.е. в ipv4 статический маршрут добавился, а в ipv6 железо почему-то решило, что next-hop неизвестно где.

Решил так:

 

no ipv6 route vrf vpn_guest ::/0 fc00:20::12
ipv6 route vrf vpn_guest ::/0 fc00:20::12 nexthop-vrf vpn_20
test-cat#show ipv6 route vrf vpn_guest
S   ::/0 [1/0]
    via fc00:20::253%vpn_20
B   fc00:20::/64 [20/0]
    via Vlan20%vpn_20, directly connected

 

Пойду посмотрю, где ещё сюрпризы есть...

Share this post


Link to post
Share on other sites

ipv6 route vrf vpn_guest ::/0 fc00:20::12

Не уверен что это срабатывает когда fc00:20::12 перелит из другого vrf, sh ipv6 cef vrf vpn_guest fc00:20::12 может прояснить детали.

Если надо получить default в vrf то я бы и переливал туда default.

 

Похоже в IOS логика переливания ipv4 и ipv6 разная, для ipv4 например есть route-replicate, для ipv6 такой фичи нету.

Share this post


Link to post
Share on other sites

Похоже в IOS логика переливания ipv4 и ipv6 разная, для ipv4 например есть route-replicate, для ipv6 такой фичи нету.

Полностью согласен.

 

Если надо получить default в vrf то я бы и переливал туда default.

Не получится, в vpn_20 нет маршрута по умолчанию. Более того, в каждом другом vrf (клиентский) шлюз разный.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this