Jump to content
Калькуляторы

Настройка QinQ между S2985G-48T и S2960-24G

Добрый вечер!

Помогите пожалуйста, по приведенному примеру на сайте производителя не получается настроить QinQ

 

Есть головное оборудование (S2985G-48T) к которому подключаются (S2960-24G) не напрямую, а через провайдера (провайдер предоставляет локалку до удаленных адресов).

 

Есть Vlan 10-20

 

S2985G-48T - порты с разными vlan для каждого адреса

S2960-24G - нужно настроить 1 Uplink и все остальные порты клиенские

Share this post


Link to post
Share on other sites

Добрый, sd166!

Добавление дополнительной метки 802.1q возможно только для входящего на порт трафика, а его снятие соответственно только для исходящего.

Например, при такой настройке:

interface ethernet 1/0/1
dot1q-tunnel enable
switchport access vlan 10

..ко всем кадрам, поступающим на порт e1/0/1, будут добавляться метки с тегом влана 10, а отправляться в него будет только трафик в 10 влане, при этом верхняя метка (с тегом влана 10) будет снята.

 

В вашем случае для добавления/снятия второй метки придется добавить еще пару коммутаторов, либо задействовать дополнительные порты на имеющихся.

Например, на S2960-24G можно замкнуть 2 порта патч-кордом и настроить так:

interface ethernet 1/25
switchport mode trunk
switchport trunk allowed vlan 101

interface ethernet 1/26
dot1q-tunnel enable
switchport access vlan 10

interface ethernet 1/28
switchport mode trunk
switchport trunk allowed vlan 10

..здесь 25 и 26 порты соединены между собой, а 28 подключен к транизтному оператору.

Клиентский трафик с портов доступа будет отправляться в 25 порт и поступать на 26 порт, получая дополнительную метку, а затем отправляться в сеть транзитного оператора. Входящий трафик аналогичным образом будет отправляться в 26 порт, метка при этом будет снята, и кадр, поступив на 25 порт, окажется в клиентском влане.

 

На S2985G-48T придется, например, организовать подобную петлю, либо добавлять/снимать метки на порту подключения вышестоящего коммутатора/маршртуизатора.

Share this post


Link to post
Share on other sites

Добрый, sd166!

Добавление дополнительной метки 802.1q возможно только для входящего на порт трафика, а его снятие соответственно только для исходящего.

Например, при такой настройке:

interface ethernet 1/0/1
dot1q-tunnel enable
switchport access vlan 10

..ко всем кадрам, поступающим на порт e1/0/1, будут добавляться метки с тегом влана 10, а отправляться в него будет только трафик в 10 влане, при этом верхняя метка (с тегом влана 10) будет снята.

 

В вашем случае для добавления/снятия второй метки придется добавить еще пару коммутаторов, либо задействовать дополнительные порты на имеющихся.

Например, на S2960-24G можно замкнуть 2 порта патч-кордом и настроить так:

interface ethernet 1/25
switchport mode trunk
switchport trunk allowed vlan 101

interface ethernet 1/26
dot1q-tunnel enable
switchport access vlan 10

interface ethernet 1/28
switchport mode trunk
switchport trunk allowed vlan 10

..здесь 25 и 26 порты соединены между собой, а 28 подключен к транизтному оператору.

Клиентский трафик с портов доступа будет отправляться в 25 порт и поступать на 26 порт, получая дополнительную метку, а затем отправляться в сеть транзитного оператора. Входящий трафик аналогичным образом будет отправляться в 26 порт, метка при этом будет снята, и кадр, поступив на 25 порт, окажется в клиентском влане.

 

На S2985G-48T придется, например, организовать подобную петлю, либо добавлять/снимать метки на порту подключения вышестоящего коммутатора/маршртуизатора.

 

 

 

а если использовать selectiv? или выход только с перемычкой?

Share this post


Link to post
Share on other sites

sd166, selective qinq работает по тому же принципу, поэтому с ним так же придется использовать дополнительный коммутатор, либо петлю.

Share this post


Link to post
Share on other sites

sd166, selective qinq работает по тому же принципу, поэтому с ним так же придется использовать дополнительный коммутатор, либо петлю.

Ок.

 

Я накидал примерно схему как должно быть, можете подсказать пожалуйста.

Untitled Diagram (1).pdf

Edited by sd166

Share this post


Link to post
Share on other sites

sd166, провайдер предоставляет вам один транзитный влан на все коммутаторы или несколько?

Share this post


Link to post
Share on other sites

sd166, провайдер предоставляет вам один транзитный влан на все коммутаторы или несколько?

 

Насколько я понял провайдера, наш трафик гуляет в одном ихнем VLAn. MTU больше 1500.

Share this post


Link to post
Share on other sites

sd166, в таком случае вполне достаточно описанной выше схемы - на всех S2960-24G и S2985G-48T сформировать перемычки для добавления/снятия дополнительной метки к трафику клиентов и управления.

 

При этом нужно учесть 2 нюанса:

1) При расширении канала до удаленной сети придется расширять и перемычку;

2) Клиентский broadcast и unknown-unicast будут распространяться в сети транзитного оператора широковещательно, засоряя таким образом порты коммутаторов, которым он не предназначен.

Edited by victor.tkachenko

Share this post


Link to post
Share on other sites

sd166, в таком случае вполне достаточно описанной выше схемы - на всех S2960-24G и S2985G-48T сформировать перемычки для добавления/снятия дополнительной метки к трафику клиентов и управления.

 

При этом нужно учесть 2 нюанса:

1) При расширении канала до удаленной сети придется расширять и перемычку;

2) Клиентский broadcast и unknown-unicast будут распространяться в сети транзитного оператора широковещательно, засоряя таким образом порты коммутаторов, которым он не предназначен.

 

Если есть возможность более подробно написать, пробовал как написано выше не получилось.

 

1) у меня на удаленные адреса, только один порт, а разветвление уже у провайдера.

2) Это не кретично, у провайдера используется оборудование отдельно под нас.

 

если смотреть на схему, должно получиться:

 

Есть GW на котором крутятся шлюзы в разных Vlan. От него идет кабель в SNR S2985-48T в 48 порт, на нем мы принимаем все Vlan транком.

Дальше есть оптика с удаленными адресами которая включается в 50 порт. В 50 порт нужно засунуть Vlan 10;20;30 и т.д.

 

А на адресах уже S2960-24G так же приходит оптика и т.д. и нужно на каждом адресе принять свой Vlan например 10

 

При этом для каждого Vlan нужно настроить DHCP-RELAY.

 

как то так.

Share this post


Link to post
Share on other sites

Если есть возможность более подробно написать, пробовал как написано выше не получилось.

 

1) формируете петли (с одной стороны транком принимаете вланы клиентов/управления, с другой dot1q-tunnel и влан опретора аксесом);

2) в порту подключения оператора с обеих сторон принимаете влан оператора (транк или аксес зависит о самого оператора).

 

Если есть какие-то дополнительные вопросы по схеме или что-то не получается, уточните, пожалуйста, конкретно.

 

1) у меня на удаленные адреса, только один порт, а разветвление уже у провайдера.

2) Это не кретично, у провайдера используется оборудование отдельно под нас.

 

1) я это понял, заметка на перспективу;

2) имею в виду, что на ваши S2960-24G также будет попадать левый трафик.

 

При этом для каждого Vlan нужно настроить DHCP-RELAY.

 

DHCP-RELAY настраивайте также, как если бы не было транзитного оператора.

Share this post


Link to post
Share on other sites

Добрый день!
Подскажите, а вслучае, если транзитный оператор предоставляет разные транзитные вланы на удаленные коммутаторы каким образом будет выглядеть конфигурация портов?
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this