Jump to content
Калькуляторы

Связка Mikrotik openvpn as client and Linux with quagga

Может кто сможет подсказать, чуть скатился в сторону от сетей и не могу с первого подхода запустить.

Есть сервер с OpenVPN,

 

local 
port 8091
proto tcp-server
dev tun8091
tun-mtu 1420
mssfix 1420
ca /etc/openvpn/keys/ca.crt
cert /etc/openvpn/keys/server.crt
key /etc/openvpn/keys/server.key
dh /etc/openvpn/keys/dh2048.pem

server 10.91.0.0 255.255.255.0
mode server
client-config-dir ccd
client-to-client
keepalive 5 15
cipher AES-256-CBC   # AES
max-clients 100
user nobody
group nogroup
persist-key
persist-tun
log-append  /var/log/openvpn/server.log
verb 0
auth SHA1

 

На Mikrotik поднял клиента openvpn, подключено, все пингается.

Дальше хочу завести ospf.

 

На сервере где стоит openvpn server уже была quagga, просто добавил

 

router ospf
ospf router-id 192.168.99.1
redistribute connected route-map dst-nets
network 10.91.0.0/24 area 0.0.0.0
neighbor 10.91.0.6

 

 

Вот выхлоп tcpdump:

 

tcpdump -nei tun8091
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on tun8091, link-type RAW (Raw IP), capture size 65535 bytes
02:13:07.103529 ip: 10.91.0.1 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:13.409409 ip: 10.91.0.6 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:17.104381 ip: 10.91.0.1 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:22.022899 ip: 10.91.0.6.47432 > 255.255.255.255.5678: UDP, length 109
02:13:23.411681 ip: 10.91.0.6 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:27.104485 ip: 10.91.0.1 > 224.0.0.5: OSPFv2, Hello, length 44

 

 

Вот не пойму чего ему не хватает чтобы установить отношения.

Share this post


Link to post
Share on other sites

Может кто сможет подсказать, чуть скатился в сторону от сетей и не могу с первого подхода запустить.

Есть сервер с OpenVPN,

 

local 
port 8091
proto tcp-server
dev tun8091
tun-mtu 1420
mssfix 1420
ca /etc/openvpn/keys/ca.crt
cert /etc/openvpn/keys/server.crt
key /etc/openvpn/keys/server.key
dh /etc/openvpn/keys/dh2048.pem

server 10.91.0.0 255.255.255.0
mode server
client-config-dir ccd
client-to-client
keepalive 5 15
cipher AES-256-CBC   # AES
max-clients 100
user nobody
group nogroup
persist-key
persist-tun
log-append  /var/log/openvpn/server.log
verb 0
auth SHA1

 

На Mikrotik поднял клиента openvpn, подключено, все пингается.

Дальше хочу завести ospf.

 

На сервере где стоит openvpn server уже была quagga, просто добавил

 

router ospf
ospf router-id 192.168.99.1
redistribute connected route-map dst-nets
network 10.91.0.0/24 area 0.0.0.0
neighbor 10.91.0.6

 

 

Вот выхлоп tcpdump:

 

tcpdump -nei tun8091
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on tun8091, link-type RAW (Raw IP), capture size 65535 bytes
02:13:07.103529 ip: 10.91.0.1 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:13.409409 ip: 10.91.0.6 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:17.104381 ip: 10.91.0.1 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:22.022899 ip: 10.91.0.6.47432 > 255.255.255.255.5678: UDP, length 109
02:13:23.411681 ip: 10.91.0.6 > 224.0.0.5: OSPFv2, Hello, length 44
02:13:27.104485 ip: 10.91.0.1 > 224.0.0.5: OSPFv2, Hello, length 44

 

 

Вот не пойму чего ему не хватает чтобы установить отношения.

 

Ospf хочет одинаковое мту у соседей. На микроте тоже 1420?

Share this post


Link to post
Share on other sites

Да, mtu уже выровнял.

Переключил на tap и все завелось. Но как-то все время использовал для point to point связку через static.key, но вот микротик похоже не умеет такое.

Ну конечно отдельная тема что меняется c L3 на L2 тунели.

 

Интересно как народ строит такие связки.

Share this post


Link to post
Share on other sites

Вы же видите, что OSPF общается мультикатсом с соседями. А мультикаст по роутингу не ходит. Нужна прямая видимость между...

Share this post


Link to post
Share on other sites

Сейчас смотрю, роутер почему-то находится в backup, поднят всего один peer.

 

cs(config-router)# do sh ip ospf  neighbor  

   Neighbor ID Pri State           Dead Time Address         Interface            RXmtL RqstL DBsmL
192.168.7.251    10 Full/Backup        7.734s 10.91.0.2       tap0:10.91.0.1           0     0     0
cs(config-router)#

 

Не могу понять почему он в backup находится.

Share this post


Link to post
Share on other sites

А что в show ip ospf interface?

Share this post


Link to post
Share on other sites
tap0 is up
 ifindex 1612, MTU 1420 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
 Internet Address 10.91.0.1/24, Broadcast 10.91.0.255, Area 0.0.0.0
 MTU mismatch detection:enabled
 Router ID EXT_IP, Network Type BROADCAST, Cost: 50
 Transmit Delay is 1 sec, State DR, Priority 1
 Designated Router (ID) EXT_IP, Interface Address 10.91.0.1
 Backup Designated Router (ID) 192.168.7.251, Interface Address 10.91.0.2
 Saved Network-LSA sequence number 0x8000001c
 Multicast group memberships: OSPFAllRouters OSPFDesignatedRouters
 Timer intervals configured, Hello 4s, Dead 8s, Wait 8s, Retransmit 4
   Hello due in 2.978s
 Neighbor Count is 1, Adjacent neighbor count is 1

Share this post


Link to post
Share on other sites

Network Type BROADCAST

 

Один сосед у вас DR, другой BDR (Backup в Quagga?)

 

Все норм

Edited by infery

Share this post


Link to post
Share on other sites

У вас туннель L2 или L3?

Что бы нормально работало нужно изменить тип интерфейсов OSPF на point to point при наличии адресов без маски подсети, или point to multi point, если нужно обмениваться данными между 2 и более IP адресов с масками подсети.

Share this post


Link to post
Share on other sites

а если в конфиг openvpn сервера добавить

topology subnet

и вернуть на tun?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this