Jump to content
Калькуляторы

QinQ между двумя 2990G 24 FX QinQ

Добрый день. Есть такая задача сделать QinQ влан между коммутаторами в разных городах. Есть один влан от оператора осуществляющего весь транспорт от одного до другого свитча.. в него надо завернуть несколько вланов своих . Не могли бы как можно подробнее подсказать ..проиллюстрировать данную настройку на обоих свитчах, как на первом заворачивать эти вланы а на втором принимать ??? Спасибо.

Share this post


Link to post
Share on other sites

Уточните у оператора он через свою сеть пропустит дважды тегированные кадры.

Если да, то как правило на своём пограничном оборудовании провайдер делает настройки, что бы завернуть все Ваши вланы в один свой. Этот один он гонит по своей сети, и в другой точке эту внешнюю метку он снимает.

И тому и другому такая схема наиболее удобная.

Если провайдер не хочет этим заморачиваться, то Вам надо ставить ещё 1 коммутатор, который будет на входящие кадры навешивать ещё 1 влан. Именно на входящие.

На исходящие кадры насколько я знаю это не возможно.

Share this post


Link to post
Share on other sites

У меня постройкой QinQ занимается специально обученная 3650G

 

 

interface GigabitEthernet0/1

description xxx_QinQLoop1_trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 108,545,555,556,2000

switchport mode trunk

no cdp enable

!

interface GigabitEthernet0/2

description xxx_QinQLoop1_dot1tunnel

switchport access vlan 1904

switchport trunk encapsulation dot1q

switchport trunk allowed vlan none

switchport mode dot1q-tunnel

no cdp enable

!

interface GigabitEthernet0/3

description xxx_QinQLoop2_trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 108,110,255,256,258,273-276,370,411,545,700,701

switchport trunk allowed vlan add 710,714,716-718,922,923,999,1608,2000

switchport mode trunk

no cdp enable

!

interface GigabitEthernet0/4

description xxx_QinQLoop2_dot1tunnel

switchport access vlan 955

switchport trunk encapsulation dot1q

switchport trunk allowed vlan none

switchport mode dot1q-tunnel

no cdp enable

!

interface GigabitEthernet0/5

description xxx_QinQLoop3_trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 109,161,163,167,171,173,177,179,902-910,914,917

switchport trunk allowed vlan add 962,964,968,969,972,974,976,978,980,982,984

switchport trunk allowed vlan add 990

switchport mode trunk

!

interface GigabitEthernet0/6

description xxx_Feo_QinQLoop3_dot1tunnel

switchport access vlan 1910

switchport trunk encapsulation dot1q

switchport trunk allowed vlan none

switchport mode dot1q-tunnel

no cdp enable

!

interface GigabitEthernet0/7

description xxx_QinQLoop4_trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 255,256,258,273-276,701,940,967,1950,1971,1972

switchport mode trunk

!

interface GigabitEthernet0/8

description description xxx_QinQLoop4_dot1tunnel

switchport access vlan 699

switchport trunk encapsulation dot1q

switchport trunk allowed vlan none

switchport mode dot1q-tunnel

no cdp enable

!

interface GigabitEthernet0/9

description xxx_QinQLoop5_trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 109,169,171,906,972,974,984

switchport mode trunk

!

interface GigabitEthernet0/10

description xxx_QinQLoop5_dot1tunnel

switchport access vlan 1973

switchport trunk encapsulation dot1q

switchport trunk allowed vlan none

switchport mode dot1q-tunnel

no cdp enable

!

interface GigabitEthernet0/11

description Rezerv_QinQLoop6_trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3453,3454

switchport mode trunk

!

interface GigabitEthernet0/12

description Rezerv_QinQLoop6_dot1tunnel

switchport access vlan 3353

switchport trunk encapsulation dot1q

switchport trunk allowed vlan none

switchport mode dot1q-tunnel

no cdp enable

!

interface GigabitEthernet0/13

description Rezerv_QinQLoop7_trunk

!

interface GigabitEthernet0/14

description Rezerv_QinQLoop7_dot1tunnel

!

interface GigabitEthernet0/15

description Rezerv_QinQLoop8_trunk

!

interface GigabitEthernet0/16

description Rezerv_QinQLoop8_dot1tunnel

!

interface GigabitEthernet0/17

description Rezerv_QinQLoop9_trunk

!

interface GigabitEthernet0/18

description Rezerv_QinQLoop9_dot1tunnel

!

interface GigabitEthernet0/19

description Rezerv_QinQLoop10_trunk

!

interface GigabitEthernet0/20

description Rezerv_QinQLoop10_dot1tunnel

!

interface GigabitEthernet0/21

description Rezerv_QinQLoop11_trunk

!

interface GigabitEthernet0/22

description Rezerv_QinQLoop11_dot1tunnel

!

interface GigabitEthernet0/23

description Rezerv_QinQLoop12_trunk

!

interface GigabitEthernet0/24

description Rezerv_QinQLoop12_dot1tunnel

!

interface GigabitEthernet0/25

switchport access vlan 400

switchport mode access

!

interface GigabitEthernet0/26

switchport access vlan 401

!

interface GigabitEthernet0/27

description dot1q_toCore21

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,108-110,161,163,167,169,171,173,175,177,179

switchport trunk allowed vlan add 255,256,258,273-276,370,411,545,555,556,700

switchport trunk allowed vlan add 701,710,714,716-718,902-910,914,917,922,923

switchport trunk allowed vlan add 940,959,962,964,967-969,972,974,976,978,980

switchport trunk allowed vlan add 982,984,990,999,1608,1950,1971,1972,2000

switchport trunk allowed vlan add 3433,3443,3453

switchport mode trunk

!

interface GigabitEthernet0/28

description dot1ad_toCore22

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 699,955,958,1073,1904,1910,1973,3333,3343,3353

switchport mode trunk

 

 

 

Если нужен всего 1 qinq тракт можно обойтись без петель. Qinq - древняя и отработанная технология, на всех вендорах где заводил работает одиннаково, просто синтаксис чуть разный. Ну и не забудьте выключить stp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.