Jump to content
Калькуляторы

PPPOE + TCPIP на одном порту - нужна помощь

Добрый вечер всем! Подскажите пожалуйста по моей проблеме, есть сеть (10.10.0.0/16 шлюз 10.10.12.1, в сети есть PPPOE сервер с Интернетом), dhcp сервер в этой сети находится очень далеко и часто отваливается, аренда всего на 12 часов, локальный DNS также, в результате то сетевые принтеры не работают, то сетевые приложения вылетают. Я решил ̶о̶т̶к̶р̶ы̶т̶ь̶ ̶с̶в̶о̶й̶ ̶л̶у̶н̶о̶п̶а̶р̶к̶ выделить свою сеть с помощью MikroTik RouterBOARD 750 со своим dhcp, а к первой сети подключать Микротик с выпрошенным статическим IP. Ок, настройка по дефолту мне всё сделала. В ether1 воткнут кабель от сети 10.10.0.0/16, в ether2 воткнут коммутатор к которому подключены пользователи. Интернет через PPPOE через ether1. Теперь мне нужно как-то попасть из моей подсети в сеть 10.10.0.0/16, я считаю нужно добавить строку в таблицу маршрутизации что-то вида

10.10.0.0 mask 255.255.0.0 10.10.12.1

. Вот тут помогите пожалуйста это сделать, не могу сам разобраться - ведь в моей конфигурации Микротик ничего не знает о сети 10.10.0.0/16, ether1 у него без TCPIP, сразу PPPOE.

 

Спасибо откликнувшимся!

 

 

# oct/14/2015 21:54:53 by RouterOS 6.32.2

# software id = DBRK-F894

#

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether2 ] name=ether2-master-local

set [ find default-name=ether3 ] master-port=ether2-master-local name=\

ether3-slave-local

set [ find default-name=ether4 ] master-port=ether2-master-local name=\

ether4-slave-local

set [ find default-name=ether5 ] master-port=ether2-master-local name=\

ether5-slave-local

/interface pppoe-client

add ac-name=IdecoICS add-default-route=yes default-route-distance=1 disabled=no \

interface=ether1-gateway max-mru=1480 max-mtu=1480 name=pppoe-out1 \

password=******** service-name=IdecoICS use-peer-dns=yes user=pppoeuser

/ip neighbor discovery

set ether1-gateway discover=no

/ip hotspot profile

set [ find default=yes ] html-directory=flash/hotspot

/ip ipsec proposal

set [ find default=yes ] enc-algorithms=aes-128-cbc

/ip pool

add name=dhcp ranges=192.168.88.100-192.168.88.254

/ip dhcp-server

add address-pool=dhcp disabled=no interface=ether2-master-local name=default

/ip address

add address=192.168.88.1/24 comment="default configuration" interface=\

ether2-master-local network=192.168.88.0

/ip dhcp-client

add comment="default configuration" dhcp-options=hostname,clientid interface=\

ether1-gateway

/ip dhcp-server network

add address=192.168.88.0/24 comment="default configuration" dns-server=\

8.8.8.8,4.2.2.4 gateway=192.168.88.1

/ip dns

set allow-remote-requests=yes servers=8.8.8.8,4.2.2.4

/ip dns static

add address=192.168.88.1 name=router

/ip firewall filter

add chain=input comment="default configuration" protocol=icmp

add chain=input comment="default configuration" connection-state=\

established,related

add action=drop chain=input comment="default configuration" in-interface=\

ether1-gateway

add chain=forward comment="default configuration" connection-state=\

established,related

add action=drop chain=forward comment="default configuration" connection-state=\

invalid

add action=drop chain=forward comment="default configuration" \

connection-nat-state=!dstnat connection-state=new in-interface=\

ether1-gateway

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=pppoe-out1

/system clock

set time-zone-autodetect=no

/system clock manual

set time-zone=+03:00

/system ntp client

set enabled=yes primary-ntp=91.226.136.138

/system routerboard settings

# Firmware upgraded successfully, please reboot for changes to take effect!

set cpu-frequency=850MHz protected-routerboot=disabled

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this