Jump to content
Калькуляторы

ipip-туннель MikroTik-linux

Подскажите, кто-нибудь настраивал туннель ipip между MikroTik и linux?

У меня, что-то никак не получается...

Помогите, пожалуйста.

 

Дано:

 

MikroTik 750UP:

1.) Создал туннель tun111 с внешнего адреса yyy.yyy.yyy.yyy на внешний адрес linux xxx.xxx.xxx.xxx:

/interface ipip

add !keepalive local-address=yyy.yyy.yyy.yyy name=tun111 remote-address=xxx.xxx.xxx.xxx

2.) Повесил локальный ip на туннель:

/ip address

add address=10.108.108.1/30 interface=tun111 network=10.108.108.0

 

Linux (пакет etcnet):

1.) Создал туннель:

# mkdir /etc/net/ifaces/tun111

# cat > /etc/net/ifaces/tun111/options

TYPE=iptun

TUNTYPE=ipip

TUNLOCAL=xxx.xxx.xxx.xxx

TUNREMOTE=yyy.yyy.yyy.yyy

TUNOPTIONS='ttl 64'

HOST=eth0

2.) Повесил на туннель ip:

# cat > /etc/net/ifaces/tun111/ipv4address

10.108.108.1 peer 10.108.108.0/32

3.) Поднял туннель:

ifup tun111

 

В итоге пинг не идёт ни с 10.108.108.0 на 10.108.108.1, ни в обратную сторону.

При этом виден траффик на туннеле с обоих концов.

Torch и Packet Sniffer показывают, что пакеты ходят.

В iptables (с обеих сторон) я уже разрешил полный траффик между 10.108.108.0 и 10.108.108.1, а также xxx.xxx.xxx.xxx и yyy.yyy.yyy.yyy.

 

Я ничего не понимаю.

Почему траффик ходит, а отклика нет?

Share this post


Link to post
Share on other sites

2.) Повесил локальный ip на туннель:

/ip address

add address=10.108.108.1/30 interface=tun111 network=10.108.108.0

2.) Повесил на туннель ip:

# cat > /etc/net/ifaces/tun111/ipv4address

10.108.108.1 peer 10.108.108.0/32

Теорию по ip-адресации почитайте, бред написали, в .0/30 подсети рабочие адреса .1 и .2, адрес сети .0 пиром быть не может, с обоих сторон .1 указан локальным... такое в пятницу писать не гуманно, уставший разум пожалейте.

Share this post


Link to post
Share on other sites

2.) Повесил локальный ip на туннель:

/ip address

add address=10.108.108.1/30 interface=tun111 network=10.108.108.0

2.) Повесил на туннель ip:

# cat > /etc/net/ifaces/tun111/ipv4address

10.108.108.1 peer 10.108.108.0/32

Теорию по ip-адресации почитайте, бред написали, в .0/30 подсети рабочие адреса .1 и .2, адрес сети .0 пиром быть не может, с обоих сторон .1 указан локальным... такое в пятницу писать не гуманно, уставший разум пожалейте.

Блииинн, вот это я лажанул.... Простите меня. Вот что, вечер пятницы с человеком делает...

Стыдно...

Спасибо, что макнули.

 

И да, всё работает после прописывания корректных адресов.

 

Ещё раз спасибо.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this