Jump to content
Калькуляторы

Пропадает пинг на микротик 941

Я вас категорически приветствую, форумчане.

Посетил мой микротик крайне странный недуг. Обо всем по порядку...

Задача. Получить удаленный доступ на микротик для его настройки через Winbox.

Имеется: с одной стороны миктротик Sextant(без белого адреса), на котором ранее был живой удаленный доступ, но на данный момент его нет. Пока он был успел создать L2TP клиент на свой белый айпишник, на который и надо теперь сделать удаленку. Возможности физического доступа к сетанту нет. С другой стороны RB941 (конфиг приложен), который используется как домашний маршрутизатор и имеет белый айпишник на апе.

Проблема выявляется следующая:

(для тестов используется другой 941 тик, который находится за двумя натами)

Если просто пропинговать белый адрес моего 941 извне, то все ок (до запуска сервера), но как только запускается любой удаленный сервер, сразу пропадает пинг. При этом клиент удаленного сервера регистрируется как подключенный, бросает пару пакетов и тишина. Через 30-180 сек. туннель падает и цепляется заново.

 

Не знаю как сделать свернутый текст, поэтому вот ссылка на конфиг https://www.dropbox.com/s/t7zpxgtu9trzkmk/config_1.rsc?dl=0

Edited by ZloRiK

Share this post


Link to post
Share on other sites

ZloRiK, меньше Пучкова смотрите, коллега.

Схему бы набросал красивую, указал где у тебя что. Читать многа букаф вместо одной понятной схемы категорически не интересно.

Share this post


Link to post
Share on other sites

проблема которая беспокоила меня изначально уже решена. Прописывая пользователя в секретах для l2tp туннеля я указывал в качестве Local adress свой белый айпишник на rb941 из-за этого возникал конфликт и все вешалось.

В итоге у меня получился такой конфиг ррр:

 

# aug/17/2015 13:13:52 by RouterOS 6.30.2

# software id = 7EAY-U5S5

#

/ppp profile

add change-tcp-mss=no local-address=192.168.1.1 name=test remote-address=\

192.168.1.11

add change-tcp-mss=no local-address=192.168.88.1 name=ZloRiK remote-address=\

192.168.88.10

/ppp secret

add name=ZRK password=********* profile=ZloRiK service=l2tp

add name=ZRK2 password=y******** profile=test service=l2tp

 

 

Сама задача вот в чем:

Мне требуется из RB941 сделать сервер l2tp таким образом чтобы я имел возможность подключаться к двум секстантам и одному омнитику для конфигурации.

для этого планируется использовать туннель до первого секстанта, на котором сделан проброс портов таким образом чтобы по одному адресу но разными портам можно было достучаться до всех устройств

Чтобы это было возможно не только из внутренней сети rb941 я пытаюсь сделать на нем проброс.

Проблема теперь следующая:

Не получается сделать проброс на RB941. Подключение не производится ни по запросу хх.ххх.ххх.3:6001 ни по запросу 192.168.88.10. При этом если пропинговать с 941 на 192.168.88.10, то все окей, пинг идет

 

конфиг firewall RB941

 

# aug/17/2015 13:13:28 by RouterOS 6.30.2

# software id = 7EAY-U5S5

#

/ip firewall filter

 

Все фильтры отключены

 

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=ether1-gateway

add action=dst-nat chain=dstnat comment=BS_SEXTANT_winbox dst-port=6001 \

in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.10 \

to-ports=8291

add action=dst-nat chain=dstnat dst-port=8091 in-interface=ether1-gateway \

protocol=tcp to-addresses=192.168.88.10 to-ports=80

add action=dst-nat chain=dstnat comment=SEXTANT2_winbox dst-port=6002 \

in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.10 \

to-ports=8291

add action=dst-nat chain=dstnat dst-port=8092 in-interface=ether1-gateway \

protocol=tcp to-addresses=192.168.88.10 to-ports=80

add action=dst-nat chain=dstnat comment=OMNITIK_winbox dst-port=6003 \

in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.10 \

to-ports=8291

add action=dst-nat chain=dstnat dst-port=8093 in-interface=ether1-gateway \

protocol=tcp to-addresses=192.168.88.10 to-ports=80

 

 

конфиг firewall на sextant base

 

# aug/17/2015 13:31:54 by RouterOS 5.26

# software id = 8K3P-S650

#

/ip firewall connection tracking

set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \

tcp-close-wait-timeout=10s tcp-established-timeout=1d \

tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \

tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \

tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s

/ip firewall nat

add action=masquerade chain=srcnat disabled=no out-interface=ether1

add action=dst-nat chain=dstnat comment=winbox_to_cl_sextant disabled=no \

dst-port=7002 in-interface=l2tp-out1 protocol=tcp to-addresses=\

192.168.98.2 to-ports=8291

add action=dst-nat chain=dstnat comment=winbox_to_BS_omnitik disabled=no \

dst-port=7003 in-interface=l2tp-out1 protocol=tcp to-addresses=\

192.168.98.3 to-ports=8291

add action=dst-nat chain=dstnat comment=web_to_cl_sextant disabled=no \

dst-port=8082 in-interface=l2tp-out1 protocol=tcp to-addresses=\

192.168.98.2 to-ports=80

add action=dst-nat chain=dstnat comment=web_to_BS_omnitik disabled=no \

dst-port=8083 in-interface=l2tp-out1 protocol=tcp to-addresses=\

192.168.98.3 to-ports=80

add action=dst-nat chain=dstnat comment=to_cl_sextant disabled=no dst-port=\

6002 in-interface=l2tp-out2 protocol=tcp to-addresses=192.168.98.2 \

to-ports=8291

add action=dst-nat chain=dstnat disabled=no dst-port=8092 in-interface=\

l2tp-out2 protocol=tcp to-addresses=192.168.98.2 to-ports=80

add action=dst-nat chain=dstnat comment=to_base_omnitik disabled=no dst-port=\

6003 in-interface=l2tp-out2 protocol=tcp to-addresses=192.168.98.3 \

to-ports=8291

add action=dst-nat chain=dstnat disabled=no dst-port=8092 in-interface=\

l2tp-out2 protocol=tcp to-addresses=192.168.98.3 to-ports=80

/ip firewall service-port

set ftp disabled=no ports=21

set tftp disabled=no ports=69

set irc disabled=no ports=6667

set h323 disabled=no

set sip disabled=no ports=5060,5061 sip-direct-media=yes

set pptp disabled=no

 

 

все тоже самое (на мой взгляд) уже существует и работает на эих же самых устройствах но для другого белого адреса (собственно просто другой сервер l2tp, но тоже микротик). Я пытаюсь продублировать эти настройки, но ничего не запускается и я не могу даже понять где теперь искать дальше

 

Прилагаю схему

post-129163-002188900 1439801454_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this