Jump to content

Шейпинг на Микротике работает как полисинг

Настроен queue tree на pcq. Запускаю торрент, скорость скачивания доходит до max-limit=90 и обрубается до 60, потом снова по кругу. Получается пилообразный график как работает полисинг. Пробовал менять размер очередей, не подобрал. ПАМАГИТЕ

 

/ip firewall mangle

add action=mark-packet chain=forward disabled=yes dst-address-list=Clients \

new-packet-mark=down-Clients passthrough=no

add action=mark-packet chain=forward disabled=yes new-packet-mark=up-Clients \

passthrough=no src-address-list=Clients

add action=mark-connection chain=forward dst-address-list=Clients \

new-connection-mark=down-cClients

add action=mark-connection chain=forward new-connection-mark=up-cClients \

src-address-list=Clients

add action=mark-packet chain=forward connection-mark=down-cClients \

new-packet-mark=down-Clients

add action=mark-packet chain=forward connection-mark=up-cClients \

new-packet-mark=up-Clients

/queue type

add kind=pcq name=down pcq-classifier=src-address,dst-address \

pcq-dst-address6-mask=64 pcq-limit=120 pcq-src-address6-mask=64 \

pcq-total-limit=9000

add kind=pcq name=up pcq-classifier=src-address pcq-dst-address6-mask=64 \

pcq-src-address6-mask=64 pcq-total-limit=10000

add kind=pcq name=queue1 pcq-classifier=dst-address pcq-dst-address6-mask=64 \

pcq-rate=1M pcq-src-address6-mask=64

add kind=pcq name=queue2 pcq-classifier=src-address pcq-dst-address6-mask=64 \

pcq-rate=1M pcq-src-address6-mask=64

/queue tree

add limit-at=8M max-limit=96M name=Bolshaya_down packet-mark=down-Bolshaya \

parent=global queue=down

add limit-at=8M max-limit=80M name=Bolshaya_up packet-mark=up-Bolshaya parent=\

global queue=up

Share this post


Link to post
Share on other sites

В меню шейпера, где вы создавали правила, укажите побольше буфера пакетов, тогда все заработает без проблем.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.