Jump to content
Калькуляторы

Шейпинг на микротик queues tree режет скорость

Помогите знаниями.

Настроил на микротике 2011 шейпинг. В итоге когда запускаю торрент, максимальная скорость ~70Мбит/с. Когда отключаю queue tree

скорость возрастает до 95 Мбит/с.

 

/queue type

add kind=pcq name=down pcq-classifier=dst-address pcq-dst-address6-mask=64 \

pcq-src-address6-mask=64 pcq-total-limit=10000

add kind=pcq name=up pcq-classifier=src-address pcq-dst-address6-mask=64 \

pcq-src-address6-mask=64 pcq-total-limit=10000

/queue tree

add disabled=yes limit-at=8M max-limit=90M name=Bolshaya_down packet-mark=\

down-Bolshaya parent=global queue=down

add limit-at=8M max-limit=100M name=Bolshaya_up packet-mark=up-Bolshaya parent=\

global queue=up

...

/ip firewall mangle

add action=mark-packet chain=forward dst-address-list=Bolshaya new-packet-ma

down-Bolshaya

add action=mark-packet chain=forward new-packet-mark=up-Bolshaya \

src-address-list=Bolshaya

/ip firewall nat

Edited by atihomirov

Share this post


Link to post
Share on other sites

А "Profile" что показывает-то? Если там вообще idle нет, то файрвол поди надо оптимизировать?

 

Я бы попробовал mangle на conntrack использовать, чтобы каждый раз пакеты не матчить на address list, плюс passthrough выключать. Что-то вроде:

 

/ip firewall mangle
add action=mark-packet chain=forward connection-mark=up-Bolshaya new-packet-mark=up-Bolshaya passthrough=no
add action=mark-packet chain=forward connection-mark=down-Bolshaya new-packet-mark=down-Bolshaya passthrough=no
add action=mark-connection chain=forward connection-state=new src-address-list=Bolshaya new-connection-mark=up-Bolshaya
add action=mark-connection chain=forward connection-state=new dst-address-list=Bolshaya new-connection-mark=down-Bolshaya

 

(Где-то на микротиковской вики это описано)

Edited by shipilev

Share this post


Link to post
Share on other sites

Idle в среднем показывает 25-40. Изначально маркировал соединения, потом пакеты (как рекомендуют), при таком варианте исходящий и входящий трафик попадает только в Queue Bolshaya_up. Потом попробовал маркировать только пакеты, и шейпинг заработал только наблюдается проблема с урезанием скорости. Версия Router OS 6..

Edited by atihomirov

Share this post


Link to post
Share on other sites

Saab95 сталкивался.

Ищите его.

Он оказывает бесплатный суппорт Микротика.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this