Jump to content
Калькуляторы

Cisco 6509 Sup 32 service-policy input не работает

Добрый день!

Имеется цыска 6509 с 32 супом.

Конфиг:

class-map match-all INTERNET
 match access-group name INTERNET
class-map match-all VOICE
 match access-group name VOICE

ip access-list extended INTERNET
permit ip 85.202.0.0 0.0.15.255 any
permit ip any 85.202.0.0 0.0.15.255
deny   ip any any
ip access-list extended VOICE
permit ip 10.9.0.0 0.0.255.255 any
permit ip any 10.9.0.0 0.0.255.255
deny   ip any any

policy-map 10M-out
 class INTERNET
  police 10240000 1920000 3840000    conform-action transmit     exceed-action drop     violate-action drop
 class VOICE
policy-map 10M-in
 class INTERNET
  police 10240000 1920000 3840000    conform-action transmit     exceed-action drop     violate-action drop
 class VOICE

interface Vlan314
ip address 85.202.5.221 255.255.255.252
ip access-group 100 in
ip access-group 100 out
ip verify unicast source reachable-via rx allow-self-ping
no ip redirects
no ip proxy-arp
service-policy input 10M-in
service-policy output 10M-out
hold-queue 4096 in
hold-queue 4096 out

При этом на интерфейсе наблюдается вот такая картина:

 

#sh int vlan 314

Vlan314 is up, line protocol is up

Hardware is EtherSVI, address is 0008.e2d4.c900 (bia 0008.e2d4.c900)

Internet address is 85.202.5.221/30

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 20/255

Encapsulation ARPA, loopback not set

Keepalive not supported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 02:49:11, output 02:49:11, output hang never

Last clearing of "show interface" counters never

Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/4096 (size/max)

5 minute input rate 81021000 bits/sec, 10694 packets/sec

5 minute output rate 896000 bits/sec, 121 packets/sec

L2 Switched: ucast: 874230 pkt, 81796681 bytes - mcast: 24347 pkt, 1583296 bytes

L3 in Switched: ucast: 51409719321 pkt, 35479787533735 bytes - mcast: 0 pkt, 0 bytes mcast

L3 out Switched: ucast: 3402959194 pkt, 2465065759014 bytes mcast: 0 pkt, 0 bytes

51410590628 packets input, 35479857650171 bytes, 0 no buffer

Received 8165 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

3403168727 packets output, 2464786987224 bytes, 0 underruns

0 output errors, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

 

При этом видно что полиси не срабатывает почемуто:

sh policy-map interface vlan 314

Vlan314

 Service-policy input: 10M-in

   class-map: INTERNET (match-all)
     Match: access-group name INTERNET
     police :
       10240000 bps 1920000 limit 1920000 extended limit
     Earl in slot 7 :
       0 bytes
       5 minute offered rate 0 bps
       aggregate-forwarded 0 bytes action: transmit
       exceeded 0 bytes action: drop
       aggregate-forward 0 bps exceed 0 bps

   Class-map: VOICE (match-all)
     0 packets, 0 bytes
     5 minute offered rate 0000 bps
     Match: access-group name VOICE

   Class-map: class-default (match-any)
     0 packets, 0 bytes
     5 minute offered rate 0000 bps, drop rate 0000 bps
     Match: any
       0 packets, 0 bytes
       5 minute rate 0 bps

 Service-policy output: 10M-out

   class-map: INTERNET (match-all)
     Match: access-group name INTERNET
     police :
       10240000 bps 1920000 limit 1920000 extended limit
     Earl in slot 7 :
       4823838 bytes
       5 minute offered rate 124144 bps
       aggregate-forwarded 4823838 bytes action: transmit
       exceeded 0 bytes action: drop
       aggregate-forward 963592 bps exceed 0 bps

   Class-map: VOICE (match-all)
     0 packets, 0 bytes
     5 minute offered rate 0000 bps
     Match: access-group name VOICE

   Class-map: class-default (match-any)
     0 packets, 0 bytes
     5 minute offered rate 0000 bps, drop rate 0000 bps
     Match: any
       0 packets, 0 bytes
       5 minute rate 0 bps

Тоесть нагрузка 80 мегабит в место 10, подскажите плиз что делаю не так?

Share this post


Link to post
Share on other sites

Возможно я чего путаю, но policy input для SVI работает не на всех линейных картах.

Share this post


Link to post
Share on other sites

Возможно я чего путаю, но policy input для SVI работает не на всех линейных картах.

а есть пруф линк?

Share this post


Link to post
Share on other sites

Полиси отрабатывает PFC в недрах супа. От линейной карты не зависит.

 

глобально mls qos включен?

 

mls qos vlan-based на ФИЗИЧЕСКОМ порту, через который приходит эта 314 вилана имеется?

 

И, да. Полиси будут работать только на вход. На выход - нед.

Share this post


Link to post
Share on other sites

Полиси отрабатывает PFC в недрах супа. От линейной карты не зависит.

 

глобально mls qos включен?

да

mls qos vlan-based на ФИЗИЧЕСКОМ порту, через который приходит эта 314 вилана имеется?

нет

И, да. Полиси будут работать только на вход. На выход - нед.

А есть ссылка на доку цыскину где это написано?

Плюс у меня проблема как раз со входящим трафиком!

Share this post


Link to post
Share on other sites

так напишите mls qos vlan-based

И фсё поедет.

 

Сылки нет. На моей памяти так было ВСЕГДА. Все фильтры, политики и прочий шаманизм работает на вход. Иначе, мы придём к тому, что трафик надо вначале скоммутировать/смаршрутизировать, а потом дропнуть.

Share this post


Link to post
Share on other sites

Чего, и выходные полиси заработали?!?

Share this post


Link to post
Share on other sites

да хорош уже :-)

policing только на input

на output работает queueing and shaping

 

а вот на каких картах и в каких позах - в доке почитать есть

Share this post


Link to post
Share on other sites

Чего, и выходные полиси заработали?!?

 

Т.е. у вас конструкция вида:

 

interface Vlan314
service-policy output 10M-out

 

не работает? Здесь речь идет не о физическом интерфейсе.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this