Jump to content
Калькуляторы

SNR-S2960-24G igmp snooping Проброс мультикаста через коммутатор

Здравствуйте

 

Имеем SNR-S2960-24G на котором настроен multicast-vlan и включен igmp snooping. В такой конфигурации в принципе всё работало. Но появилась новая задача добавить на коммутатор ещё один vlan (не multicast-vlan) и сделать так чтобы по нему тоже ходил multicast, но не как в vlan 100.

В ходе экспериментов выяснили что если сказать no ip igmp snooping, то в новом vlan всё начинает работать, но естественно перестает работать то что вещалось в vlan 100 и наоборот.

 

Вопрос как отключить ip igmp snooping на конкретных портах (или vlan)?

 

 

Настройки без нового vlan

vlan 100
name v100
multicast-vlan
multicast-vlan mode dynamic
!
Interface Ethernet1/1-24
storm-control broadcast 63
igmp snooping drop query
switchport access vlan 21
switchport association multicast-vlan 100
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/25-28
storm-control broadcast 63
switchport mode hybrid
switchport hybrid allowed vlan 100;1000 tag
switchport hybrid allowed vlan 21 untag
switchport hybrid native vlan 21
!

!
ip igmp snooping
ip igmp snooping vlan 100
ip igmp snooping vlan 100 immediately-leave
ip igmp snooping vlan 100 report source-address 10.100.3.55
ip igmp snooping vlan 100 mrouter-port interface ethernet 1/28

Share this post


Link to post
Share on other sites
snr(config)#no ip igmp snooping vlan ?
 <1-4094>  configuration of vlan id

Share this post


Link to post
Share on other sites

Не понятно что вы имеете в виду, можно немного более развёрнуто.

Share this post


Link to post
Share on other sites

Я с топикстартером из одной песочницы. Вместе разбираем этот случай.

 

клиентский влан в котором надо передать мульткаст 1545

 

влан для тв (мультикаст_влан) 100

 

у нас сейчас такая конфигурация:

 

interface Vlan100
!
interface Vlan1545
!
ip igmp snooping
ip igmp snooping vlan 100

 

Соответственно no ip igmp snooping vlan 1545 ничего не даст.

а нам надо чтобы телевизионный мультикаст_влан был сам по себе, клиентский сам по себе.

Edited by lacost

Share this post


Link to post
Share on other sites

Представители SNR.

 

Вы можете как-то помочь в решении нашей задачи?

Share this post


Link to post
Share on other sites

добрый день,

 

у Вас в vlan 1545 отдельный мультикаст ходит, не как не связанный с vlan 100 ? Или Вы хотите мультикаст из vlan 100 в vlan 1545 поместить ?

покажите так-же вывод "sh ver" с коммутатора и настройки клиентского порта с 1545 вланом

Share this post


Link to post
Share on other sites

SNR-S2960-24G#sh ver
 SNR-S2960-24G Device, Compiled on Mar 17 14:59:40 2014
 sysLocation 
 CPU Mac f8:f0:82:10:64:f7
 Vlan MAC f8:f0:82:10:64:f6
 SoftWare Version 7.0.3.5(R0217.0002)
 BootRom Version 7.1.3
 HardWare Version 1.0.2
 CPLD Version 1.2
 Serial No.:SW011510D726790054
 Copyright (C) 2014 NAG LLC
 All rights reserved
 Last reboot is warm reset.
 Uptime is 0 weeks, 1 days, 21 hours, 48 minutes

 

В 100 - свой мультикаст, в 1545 - свой. никак не пересекающиеся

 

1-й клиентский порт, 28 - аплинк

 

Interface Ethernet1/1
storm-control broadcast 63
switchport access vlan 1545
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
igmp snooping drop query


Interface Ethernet1/28
storm-control broadcast 63
switchport mode hybrid
switchport hybrid allowed vlan 100;1001;1545 tag
switchport hybrid allowed vlan 21 untag
switchport hybrid native vlan 21

Share this post


Link to post
Share on other sites

включите igmp snooping в vlan 1545

пропишите 28 порт как mrouter

ip igmp snooping vlan 100

ip igmp snooping vlan 100 mrouter-port interface ethernet 1/28

 

или второй вариант - на порту ethernet1/1 сделайте команду switchport flood-forwarding mcast

Share this post


Link to post
Share on other sites

по специфике клиента (одна рассылка во всем влане) нам не нужно отслеживать и отключать не запрашиваемые группы.

 

switchport flood-forwarding mcast - заработал.

 

 

Огромное спасибо!

Share this post


Link to post
Share on other sites

Здравствуйте. Дабы не дублировать тему пишу здесь. Коммутатор такой же SNR-S2960-24G. Мультикаст не ходит. В сегменте где есть PIM все работает, а в сегменте мультикаст идет отдельным вланом и должен подмешиваться на SNR не работает. Возможно что-то я делаю неправильно.

Схема следующая: Источник мультикаста- D-link dgs3620-28- D-link dgs3420-26- SNR-S2960-24G - юзер

 

Приведу пример конфига

 

!
vlan 333
name tv_serv
multicast-vlan
!
multicast destination-control
!
Interface Ethernet1/1
spanning-tree portfast bpduguard recovery 30
switchport access vlan 13
switchport association multicast-vlan 333
switchport flood-forwarding mcast
loopback-detection control shutdown
igmp snooping drop query
!
Interface Ethernet1/25
switchport mode hybrid
switchport hybrid allowed vlan 13;333 tag
switchport hybrid native vlan 13
switchport flood-forwarding mcast
!
interface Vlan333
ip address 10.128.21.253 255.255.255.0
!
ip igmp snooping
ip igmp snooping vlan 333
ip igmp snooping vlan 333 immediately-leave
ip igmp snooping vlan 333 mrouter-port interface Ethernet1/25
ip igmp snooping vlan 333 report source-address 10.128.21.253

При попытке посмотреть подписки получаю следующее

 

show ip igmp snooping vlan 333
Igmp snooping information for vlan 333

Igmp snooping L2 general querier                  :NO
Igmp snooping query-interval                      :125(s)
Igmp snooping max response time                   :10(s)
Igmp snooping specific-query max response time    :1(s)
Igmp snooping robustness                          :2
Igmp snooping mrouter port keep-alive time        :255(s)

IGMP Snooping Connect Group Membership 
Note:*-All Source, (S)- Include Source, [s]-Exclude Source
Groups          Sources             Ports               Exptime  SrcMac              System Level
231.0.0.3       *                   Ethernet1/1         00:04:18 C8:3A:35:4E:8F:60   V2          

Igmp snooping vlan 333 mrouter port
Note:"!"-static mrouter port
!Ethernet1/25    

 

Тоесть на первом порту подписка есть. На 25 ничего нет. Выше стоит 2 Д-линка, через них просто протянут влан с мультикастом. В итоге на машине на первом порту мультикаста нет

Share this post


Link to post
Share on other sites

1. Обновите прошивку коммутатора на последнюю - http://data.nag.ru/SNR%20Switches/Firmware/SNR-S2960-24G/S2960-24G_7.0.3.5%28R0217.0142%29.zip

2. При подписке на вышестоящем длинке igmp группа создается ?

Share this post


Link to post
Share on other sites

Да, подписка есть.

Спасибо. После обновления прошивки всё завелось сразу.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this