Jump to content
Калькуляторы

проблема с 10G линком между 7600 и 4500X

Есть страный глюк. Настройки схемы элементарные.

имеем cisco 7600 с tengigabitethernet с одной стороны с cisco 4500X с таким же интерфейсом с другой стороны.

подключаем их вместе через транковый порт по 1G все отлично доступно. подключаем по 10G есть - только icmp и все

 

с cisco 7600

#p 10.1.0.14

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.0.14, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/8 ms

#10.1.0.14

Trying 10.1.0.14 ... Open

 

User Access Verification

 

Username:

% Username: timeout expired!

[Connection to 10.1.0.14 closed by foreign host]

 

в этот момент не реагирует на клавиатуру и выпадает по таймауту.

 

настройки портов:

на cisco 7600

interface TenGigabitEthernet2/22

switchport

switchport trunk allowed vlan 409

switchport mode trunk

 

interface Vlan409

ip address 10.1.0.21 255.255.252.0

 

тестовый, через который работает:

interface GigabitEthernet4/16

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 409

 

на cisco 4500X

interface TenGigabitEthernet1/1

switchport trunk allowed vlan 409

switchport mode trunk

 

interface Vlan409

ip address 10.1.0.14 255.255.252.0

 

вопрос, что надо прикрутить на TenGigabitEthernet2/22 что бы заработало?

Share this post


Link to post
Share on other sites

вопрос, что надо прикрутить на TenGigabitEthernet2/22 что бы заработало?

физику, с двух сторон. вплоть до замены трансиверов/патчкордов.

с двух сторон пускаем встречный ping X size 1500 df-bit

и наблюдаем за sh int te2/22 и sh int te1/1 на предмет crc error, runts и overrun.

Share this post


Link to post
Share on other sites

меняли модули, ставили SNR и CISCO одно у двух волоконые, пачкорды меняли синева зелень, порты, ios, результат один, работает только на 1G модулях.

ошибок на портах нет.

Edited by silencess

Share this post


Link to post
Share on other sites

У меня 4500x в связке c 7600 поднимается как на родных так и на китайских LR без проблем.

показывайте sh int и sh idprom int с двух сторон.

Share this post


Link to post
Share on other sites

на cisco 7600

 

 

IDPROM for transceiver TenGigabitEthernet2/22:

Description = XFP optics (type 6)

Transceiver Type: = OC192 + 10GBASE-L (97)

Product Identifier (PID) = XFP-10GLR-OC192SR

Vendor Part Number = XFP-LR

Vendor Revision = A

Serial Number (SN) = XA9F150012

Vendor Name = OEM

Vendor OUI (IEEE company ID) = 00.00.00 (0)

CLEI code = WMOTBEVAAB

Cisco part number = 10-1989-02

Device State = Enabled.

Date code (yy/mm/dd) = 10/09/15

Connector type = LC.

Encoding = 64B/66B

8B10B

SONET Scrambled

NRZ

Minimum bit rate = 9900 Mbits/s

Maximum bit rate = 11100 Mbits/s

Power dissipation class = Pwr Level 2 (2.5 W max pwr dissipation).

cdr function = supported.

Tx Reference clock = not Required.

Max link length for SMF fiber = 10 km

Max link length for EBW 50/125um fiber = not supported

Max link length for 0/125um fiber = not supported

Max link length for 62.5/125um fiber = not supported

Max link length for copper = not supported

Tx device technology = 1550 nm DFB

Wavelength control technology = no wavelength control

Transceiver cooling technology = un-cooled transmitter device

Detector type = PIN detector

Transmitter tuning = transmitter not tunable

Supported CDR rates = 9.95 Gb/s

10.3 Gb/s

10.5 Gb/s

10.7 Gb/s

11.1 Gb/s

XFI Loopback Mode

Nominal laser wavelength = 1310 nm

Wavelength tolerance w.r.t. nominal = (+/-) 20 nm

Maximum case temperature = 70 degrees C.

Maximum power dissipation = 2500 mW

Power dissipation in power-down mode = 1500 mW

Maximum current required for +5V supply = 0 mA

Maximum current required for +3.3V supply = 800 mA

Maximum current required for +1.8V supply = 0 mA

Maximum current required for -5.2V supply = 0 mA

Diagnostic capabilities = FEC BER not supported.

average Rx power measured.

Enhanced functions = Soft TX disable supported

Soft Power-down supported

Aux A/D input 1 = +3.3V Supply Voltage

Aux A/D input 2 = not implemented

Transceiver temperature operating range = -5 C to 75 C (commercial)

High temperature alarm threshold = +100.000 C

High temperature warning threshold = +95.000 C

Low temperature warning threshold = -20.000 C

Low temperature alarm threshold = -25.000 C

High laser bias current alarm threshold = 115.000 mAmps

High laser bias current warning threshold = 110.000 mAmps

Low laser bias current warning threshold = 10.000 mAmps

Low laser bias current alarm threshold = 5.000 mAmps

High transmit power alarm threshold = 2.0 mWatts

High transmit power warning threshold = 1.5848 mWatts

Low transmit power warning threshold = 0.2511 mWatts

Low transmit power alarm threshold = 0.1995 mWatts

High receive power alarm threshold = 1.7783 mWatts

High receive power warning threshold = 1.4125 mWatts

Low receive power warning threshold = 0.158 mWatts

Low receive power alarm threshold = 0.125 mWatts

 

TenGigabitEthernet2/22 is up, line protocol is up (connected)

Hardware is X40G 10Gb 802.3, address is (bia )

Description: link to main swich

MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 10Gb/s, clock source internal

Transport mode LAN (10GBASE-R, 10.3125Gb/s)

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:22, output 00:00:44, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 1000 bits/sec, 2 packets/sec

411650 packets input, 89618851 bytes, 0 no buffer

Received 346336 broadcasts (346143 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

18336147 packets output, 1794925005 bytes, 0 underruns

0 output errors, 0 collisions, 18 interface resets

0 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

 

 

 

на cisco 4500X

 

 

FP+ Serial EEPROM Contents:

Common Block:

Identifier = SFP+ [0x3]

Connector = LC Connector [0x7]

Transceiver

Type = SFP+ 10G-LR

Vendor name = OEM

Vendor OUI = 0

Vendor Part No. = SFP+ LR

Vendor Part Rev. = A

Vendor Serial No. = SA6P1801

Diag monitoring = Implemented

Calibration type = Internal

 

SEEPROM contents (hex) size 256:

0x0000 03 04 07 20 00 00 00 12 00 01 55 03 67 00 0A 64 ... ......U.g..d

0x0010 00 00 00 00 4F 45 4D 20 20 20 20 20 20 20 20 20 ....OEM

0x0020 20 20 20 20 00 00 00 00 53 46 50 2B 20 4C 52 20 ....SFP+ LR

0x0030 20 20 20 20 20 20 20 20 41 20 20 20 05 1E 00 A5 A ....

0x0040 00 1A 00 00 53 41 36 50 31 38 30 31 30 36 20 20 ....SA6P1801

0x0050 20 20 20 20 31 30 30 37 30 31 20 20 68 B0 01 A6 100701 h0..

0x0060 00 00 08 67 16 7B 7D 17 66 F7 C5 07 71 AC 92 48 ...g.{}.fw..q,^RH

0x0070 3E E5 06 00 00 00 00 00 00 00 00 00 C7 97 06 F0 >...........G..p

0x0080 57 44 55 49 41 41 44 42 41 41 31 30 2D 32 32 39 WDUIAADBAA10-229

0x0090 33 2D 30 31 56 30 31 20 CA D8 55 00 00 00 00 7D 3-01V01 JXU....}

0x00A0 00 00 00 00 00 00 00 00 0D 95 19 80 28 00 3E B9 ...........^@(.>9

0x00B0 62 62 80 DC 1C 94 0E 29 0B 02 0F 7D 00 00 AA AA bb^@\.^T.)...}..**

0x00C0 53 46 50 2D 31 30 47 2D 4C 52 20 20 20 20 20 20 SFP-10G-LR

0x00D0 20 20 20 20 00 00 00 00 00 00 00 00 00 00 00 C9 ...........I

0x00E0 5A 00 E7 00 55 00 EC 00 90 88 71 48 8C A0 75 30 Z.g.U.l.^qH. u0

0x00F0 AF C8 03 E8 9C 40 05 DC 45 77 09 D0 37 2D 0C 5A .H.h^\@.\Ew.P7-.Z

 

TenGigabitEthernet1/1 is up, line protocol is up (connected)

Hardware is Ten Gigabit Ethernet Port, address is (bia )

Description: uplink to cisco 7600 Te2/22

MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 10Gb/s, link type is auto, media type is 10GBase-LR

input flow-control is on, output flow-control is on

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1000 bits/sec, 1 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

23507 packets input, 15763533 bytes, 0 no buffer

Received 9105 broadcasts (2224 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

14647 packets output, 14066571 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

 

 

Share this post


Link to post
Share on other sites

Если порты в режиме L3 такая же ситуация?

Share this post


Link to post
Share on other sites

Transceiver Type: = OC192 + 10GBASE-L (97)

Product Identifier (PID) = XFP-10GLR-OC192SR

 

ой какая прелесть...

на 7600 взлетит после такого извращения:

conf t

int te2/22

shut

transport-mode wan

no shut

shut

transport-mode lan

no shut

exit

reload

 

такие модули без геморроя в lan-mode взлетают разве что на asr1k/asr9k, на 7600 и me3600-24cx они станут вашим ночным кошмаром.

Share this post


Link to post
Share on other sites

ок, отпишусь... уже только 25 марта, перегружать 7600 нет возможности сейчас - в продакшене.

менять модуль как понимаю уже бесполезно без перезагрузки, порт на 7600 повело окончательно?

Share this post


Link to post
Share on other sites

нет, если воткнуть XFP без OC192, например любой китайский LR, все заведется.

Share this post


Link to post
Share on other sites

Te2/22 это действительно плата на 22+ десятки или опечатка?

 

По факту, я бы посмотрел MTU vlan interface ов, и mtu на физике

Share this post


Link to post
Share on other sites

76-ES+XC-40G3C плата, не опечатка

меняли на snr не заводится. фото модулей приложил.

 

fd5d55ac025e.jpg

6343fa5579b7.jpg

 

 

на vlan

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec

на Te

MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec

бандвидж разный, может в этом проблема?

Edited by silencess

Share this post


Link to post
Share on other sites

silencess, спасибо

Share this post


Link to post
Share on other sites

В соседнем интерфейсе кстати стоит аналогичный модуль, к нему сервер подключен, там все нормально.

 

 

 

IDPROM for transceiver TenGigabitEthernet2/21:

Description = XFP optics (type 6)

Transceiver Type: = OC192 + 10GBASE-L (97)

Product Identifier (PID) = XFP-10GLR-OC192SR

Vendor Part Number = SFCT-7081Z

Vendor Revision = 01

Serial Number (SN) = AGA1527NB

Vendor Name = CISCO-AVAGO

Vendor OUI (IEEE company ID) = 00.17.6A (5994)

CLEI code = WMOTCUXAAA

Cisco part number = 10-1989-03

Device State = Enabled.

Date code (yy/mm/dd) = 11/07/10

Connector type = LC.

Encoding = 64B/66B

SONET Scrambled

NRZ

Minimum bit rate = 9900 Mbits/s

Maximum bit rate = 11100 Mbits/s

Power dissipation class = Pwr Level 2 (2.5 W max pwr dissipation).

cdr function = supported.

Tx Reference clock = not Required.

Max link length for SMF fiber = 10 km

Max link length for EBW 50/125um fiber = not supported

Max link length for 0/125um fiber = not supported

Max link length for 62.5/125um fiber = not supported

Max link length for copper = not supported

Tx device technology = 1550 nm DFB

Wavelength control technology = no wavelength control

Transceiver cooling technology = un-cooled transmitter device

Detector type = PIN detector

Transmitter tuning = transmitter not tunable

Supported CDR rates = 9.95 Gb/s

10.3 Gb/s

10.5 Gb/s

10.7 Gb/s

11.1 Gb/s

XFI Loopback Mode

Nominal laser wavelength = 1310 nm

Wavelength tolerance w.r.t. nominal = (+/-) 20 nm

Maximum case temperature = 70 degrees C.

Maximum power dissipation = 2500 mW

Power dissipation in power-down mode = 300 mW

Maximum current required for +5V supply = 0 mA

Maximum current required for +3.3V supply = 600 mA

Maximum current required for +1.8V supply = 0 mA

Maximum current required for -5.2V supply = 0 mA

Diagnostic capabilities = FEC BER not supported.

average Rx power measured.

Enhanced functions = Soft TX disable supported

Soft Power-down supported

Aux A/D input 1 = Laser Temperature

Aux A/D input 2 =

Transceiver temperature operating range = -5 C to 75 C (commercial)

High temperature alarm threshold = +78.000 C

High temperature warning threshold = +73.000 C

Low temperature warning threshold = +5.000 C

Low temperature alarm threshold = 0.000 C

High laser bias current alarm threshold = 100.000 mAmps

High laser bias current warning threshold = 85.000 mAmps

Low laser bias current warning threshold = 15.000 mAmps

Low laser bias current alarm threshold = 5.000 mAmps

High transmit power alarm threshold = 2.2387 mWatts

High transmit power warning threshold = 1.1220 mWatts

Low transmit power warning threshold = 0.1513 mWatts

Low transmit power alarm threshold = 0.758 mWatts

High receive power alarm threshold = 2.2387 mWatts

High receive power warning threshold = 1.1220 mWatts

Low receive power warning threshold = 0.363 mWatts

Low receive power alarm threshold = 0.181 mWatts

 

 

Edited by silencess

Share this post


Link to post
Share on other sites

оказалось что наговские тоже OC192, получается только перезагрузка 7600 поможет, а так же получается что менять модули OC192 без перезагрузки бесполезно, не будут работать - я правильно понимаю?

Share this post


Link to post
Share on other sites

помогла перезагрузка cisco 7600. линк поднялся, как и должно быть.

Share this post


Link to post
Share on other sites

приключения с линком продолжаются. теперь объявились проблемы с скоростью. имею lacp 20G - два линка по 10G

настройки опять же элементарные

cisco 7600

interface Port-channel40
description link 4500x
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 409
switchport mode trunk
mtu 9198
ip dhcp snooping trust

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
40     Po40(SU)        LACP      Te2/21(P)   Te2/22(P)   

interface TenGigabitEthernet2/21
description link 4500 channel 1
switchport
switchport trunk allowed vlan 409
switchport mode trunk
mtu 9198
channel-group 40 mode active

interface TenGigabitEthernet2/22
description link 4500 channel 2
switchport
switchport trunk allowed vlan 409
switchport mode trunk
mtu 9198
channel-group 40 mode active

cisco 4500-x

interface Port-channel40
description link to cisco 7600
switchport
switchport trunk allowed vlan 409
switchport mode trunk
mtu 9198

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
40     Po40(SU)        LACP      Te1/1(P)    Te1/2(P)  

interface TenGigabitEthernet1/1
description link to cisco 7600 channel1
switchport trunk allowed vlan 409
switchport mode trunk
mtu 9198
channel-group 40 mode passive
spanning-tree portfast

interface TenGigabitEthernet1/2
description link to cisco 7600 channel2
switchport trunk allowed vlan 409
switchport mode trunk
mtu 9198
channel-group 40 mode passive
spanning-tree portfast

в итоге скорость по исходящему трафику не более

см. скрин

post-83166-072237600 1459595692_thumb.png

Share this post


Link to post
Share on other sites

может переподписка? нет? смотреть модели плат и мануалы по ним.

Share this post


Link to post
Share on other sites

плата стоит - ES+ 2xTGE XFP 20xGE SFP 7600-ES+40C

sh li?

li-slot line link link-protection

про лицензии железка ничего не знает, по спекам пишут что 20G

 

по утилизации смотрю максимум на слоте 45%

Edited by silencess

Share this post


Link to post
Share on other sites
show platform hardware capacity
System Resources
 PFC operating mode: PFC3C
 Supervisor redundancy mode: administratively sso, operationally sso
 Switching resources: Module   Part number               Series      CEF mode
                      1        RSP720-3CXL-GE        supervisor           CEF
                      2        76-ES+XC-40G3C           dCEF720          dCEF
                      3        WS-X6748-GE-TX            CEF720           CEF
                      4        76-ES+XC-40G3C           dCEF720          dCEF

Power Resources
 Power supply redundancy mode: administratively redundant
                               operationally redundant
 System power: 2669W, 0W (0%) inline, 1478W (55%) total allocated
 Powered devices: 0 total, 0 Class3, 0 Class2, 0 Class1, 0 Class0, 0 Cisco

Flash/NVRAM Resources
 Usage: Module Device               Bytes:      Total          Used     %Used
        1  SP  disk0:                       512090112     285245440       56%
        1  SP  sup-bootdisk:                512090112     196673536       38%
        1  SP  const_nvram:                    127212          3376        3%
        1  SP  hidden-nvram:                  4059328         39768        1%
        1  RP  nvram:                         4059328         39768        1%
        1  RP  bootdisk:                    512090112     163635200       32%
        2      dfc#2-bootdisk:             1024557056       1048576        1%
        3      dfc#3-bootflash:              15990784             0        0%
        4      dfc#4-bootdisk:             1024557056        966656        1%

CPU Resources
 CPU utilization: Module             5 seconds       1 minute       5 minutes
                  1  RP              35% / 33%            35%             34%
                  1  SP              10% /  0%            10%             10%
                  2                   5% /  0%            15%             15%
                  3                   2% /  1%             1%              1%
                  4                  27% / 15%            21%             19%
 Processor memory: Module   Bytes:       Total           Used           %Used
                   1  RP            1683998144      192179588             11%
                   1  SP             653300100      242301588             37%
                   2                 692172776      466729836             67%
                   3                 188182800       59682636             32%
                   4                 692172776      467233764             68%
 I/O memory: Module         Bytes:       Total           Used           %Used
             1  RP                   134217728       50315036             37%
             1  SP                    67108864       43819612             65%
             2                        67108864       29253608             44%
             4                        67108864       29253608             44%

EOBC Resources
 Module                     Packets/sec     Total packets     Dropped packets
 1  RP      Rx:                      38           7915770                   0
            Tx:                      34           7216814                   0
 1  SP      Rx:                      13           4039042                   0
            Tx:                      19           5103919                   0
 2          Rx:                      18           3699619                   0
            Tx:                      13           2702126                   0
 3          Rx:                      22          15902273                   0
            Tx:                      16           2528875                   0
 4          Rx:                      16           3632704                   0
            Tx:                      12           2592584                   0

VLAN Resources
 VLANs: 4094 total, 52 VTP, 8 extended, 27 internal, 4007 free

L2 Forwarding Resources
          MAC Table usage:   Module  Collisions  Total       Used       %Used
                             1                0  98304       2343          2%
                             2                0  98304       2060          2%
                             4                0  98304        327          1%

            VPN CAM usage:                       Total       Used       %Used
                                                   512          0          0%
L3 Forwarding Resources
Module              FIB TCAM usage:                     Total        Used     %Used
  1                     72 bits (IPv4, MPLS, EoM)      196608        5818      3%
                       144 bits (IP mcast, IPv6)       32768            9      1%

                    detail:      Protocol                    Used       %Used
                                 IPv4                        3769          2%
                                 MPLS                        2049          1%
                                 EoM                            0          0%

                                 IPv6                           2          1%
                                 IPv4 mcast                     4          1%
                                 IPv6 mcast                     3          1%

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this