Jump to content
Калькуляторы

проброс портов на web сервера проброс портов на web сервера

Есть микротик с белым IP (178.168.x.x) адресом, за ним стоят два web сервера xxx.ru 192.168.1.10 и yyy.ru 192.168.1.11

 

Возможно ли настроить микротик так, что бы при обращении на xxx.md он перенаправлял на 192.168.1.10 и соответственно если на yyy.md то 192.168.1.11 т.е. ловил доменное имя и перенаправлял на соответствующий адрес сервера по 80 порту.

Share this post


Link to post
Share on other sites

Можно попробовать в L7 ловить пакеты, затем маркировать соединение и перенаправлять куда надо. Так себе вариант.

 

Гораздо удобнее поднять на каждом сервере ngnix, как проксик для этих доменов.

конфиг примерно такой - апач перенести на порт 8080, в настройках ngnix 2 домена первый проксируется на локалхост второй на другой сервер. На втором аналогично.

на микротике сделать проброс 50% на 50% .

Правда тогда при падении одного сервера половина клиентов второго тоже потеряются.

Можно настроить на серверах по 2 vrrp интерфейса. на первом vrp1 -master vrp2 - backup< на втором vrp2 - master vrp1 - backup.

и трафик на микротике заворачивать уже не на реальные адреса а на адреса vrrp.

Тогда при падении сервера, второй подхватит его адрес и 100% трафика будет приходит на него. Живой домен будет работать как обычно, а для другого будет выдаваться нормальное сообщение о профилактических работах.

Edited by eugenesch

Share this post


Link to post
Share on other sites

Можно попробовать в L7 ловить пакеты, затем маркировать соединение и перенаправлять куда надо. Так себе вариант.

 

Гораздо удобнее поднять на каждом сервере ngnix, как проксик для этих доменов.

конфиг примерно такой - апач перенести на порт 8080, в настройках ngnix 2 домена первый проксируется на локалхост второй на другой сервер. На втором аналогично.

на микротике сделать проброс 50% на 50% .

Правда тогда при падении одного сервера половина клиентов второго тоже потеряются.

Можно настроить на серверах по 2 vrrp интерфейса. на первом vrp1 -master vrp2 - backup< на втором vrp2 - master vrp1 - backup.

и трафик на микротике заворачивать уже не на реальные адреса а на адреса vrrp.

Тогда при падении сервера, второй подхватит его адрес и 100% трафика будет приходит на него. Живой домен будет работать как обычно, а для другого будет выдаваться нормальное сообщение о профилактических работах.

 

Можно первый вариант по подробнее, и почему он Так себе вариант ???

Share this post


Link to post
Share on other sites

эксперементировать надо примерно так

/ip firewall layer7-protocol add name=srv1 regexp="(GET xxx.ru)"
add name=srv2 regexp="(GET yyy.ru)"

 

Затем

/ip firewall mangle
add action=mark-connection chain=forward comment=srv1  layer7-protocol=srv1 new-connection-mark=srv1
add action=mark-connection chain=forward comment=srv2  layer7-protocol=srv2 new-connection-mark=srv2

ну и натить потом по этим меткам

проблемы:

Https - пролетит мимо

можно чтото левое зацепить

ну и ресурсы роутера это будет жрать не по детски

 

Share this post


Link to post
Share on other sites

эксперементировать надо примерно так

/ip firewall layer7-protocol add name=srv1 regexp="(GET xxx.ru)"
add name=srv2 regexp="(GET yyy.ru)"

 

Затем

/ip firewall mangle
add action=mark-connection chain=forward comment=srv1  layer7-protocol=srv1 new-connection-mark=srv1
add action=mark-connection chain=forward comment=srv2  layer7-protocol=srv2 new-connection-mark=srv2

ну и натить потом по этим меткам

проблемы:

Https - пролетит мимо

можно чтото левое зацепить

ну и ресурсы роутера это будет жрать не по детски

 

не работает !!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this