Jump to content
Калькуляторы

Проблема со скриптом

Есть скрип который записывает в файл информацию о клиентах с низким уровнем сигнала. Проблема в том, что я не знаю как дописывать в файл переменную с новой строки.

 

:local disconnectlevel -70

:local idenity [/system identity get name]

:put "disconnectlevel= $disconnectlevel"

/interface wireless registration-table;

:foreach reg in=[find] do={

:local signalch1 [get $reg tx-signal-strength-ch0];

:local signalch3 [get $reg tx-signal-strength-ch1];

:local txccq [get $reg tx-ccq];

:local rxccq [get $reg rx-ccq];

:local signal [get $reg signal-strength];

:local name [get $reg radio-name];

:local ip [get $reg last-ip];

:local distance [get $reg distance];

:if ($signalch1 <= $disconnectlevel or $signalch3 <= $disconnectlevel) do={

:put ("$idenity $name $ip Signal=$signalch1/$signalch3 $distance km CCQ(TX/RX)=$txccq%/$rxccq% ");

/file print file=Svirsk1MT;

/file set Svirsk1MT.txt contents="$idenity $name $ip Signal=$signalch1/$signalch3 $distance km CCQ(TX/RX)=$txccq%/$rxccq% ";

/tool fetch address=192.168.102.250 mode=ftp dst-path=Mikrotik/lowlevel/Svirsk1MT.txt src-path=Svirsk1MT.txt upload=yes;

}

}

 

 

Таким образом отправляется информация только об 1 абоненте. Есть у кого какие мысли по этому поводу?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this