Jump to content
Калькуляторы

OpenVPN на 951G-2HnD. Сбрасывает соединения каждый час. MikroTik сбрасывает соединения каждый час.

Настроил OVPN сервер на 951G-2HnD. Версия прошивки 6.19.

Тестирую на двух клиентах - один на винде (v2.3.3), второй на linux (v2.3.4).

Микротик держит соединения ровно час и затем сбрасывает их. Куда копать?

Конфиг клиентов:

 

remote address port
dev tap
proto tcp-client
tls-client
ca ca.crt
auth-user-pass
pull
nobind
persist-key
resolv-retry infinite
script-security 2 system
auth-nocache
auth-user-pass auth.cfg
ping 10
remote-cert-tls server
verb 9
log-append openvpn-client.log
route-method exe
route-delay 2
redirect-gateway def1

 

Настройки на MikroTik:

 

[admin@tik] > /ppp profile print where name="ovpn"
Flags: * - default
0   name="ovpn" local-address=10.10.10.1 remote-address=ovpn_pool use-mpls=default use-compression=default
    use-vj-compression=default use-encryption=default only-one=default change-tcp-mss=default
    address-list=""

[admin@tik] > /interface ovpn-server server print
                    enabled: yes
                       port: 1194
                       mode: ethernet
                    netmask: 24
                mac-address: FE:05:DF:70:59:A7
                    max-mtu: 1500
          keepalive-timeout: disabled
            default-profile: ovpn
                certificate: cert_1
 require-client-certificate: no
                       auth: sha1,md5
                     cipher: blowfish128,aes128,aes192,aes256

[admin@tik] > /ppp active print
Flags: R - radius
#   NAME         SERVICE CALLER-ID         ADDRESS         UPTIME   ENCODING
0   u2           ovpn    x.x.x.x     10.10.10.10     45m36s   BF-128-CBC/SHA1
1   cbtruck      ovpn    y.y.y.y     10.10.10.12     3m50s    BF-128-CBC/SHA1

 

Share this post


Link to post
Share on other sites

Может кому пригодится.

Для того, чтобы не было дисконнектов каждый час, необходимо на клиенты добавить опцию

--reneg-sec 0

Объяснение опции:

--reneg-sec n : Renegotiate data chan. key after n seconds (default=3600)

 

P.S. Не получилось вставить красиво ссылку с использованием тега http://

Вся переписка по данной проблеме здесь: forum.mikrotik.com/viewtopic.php?f=1&t=89142

Edited by etcnix

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this