Jump to content
Калькуляторы

SNR и мультикаст

Добрый день

Схема следующая

Стример (от нетапа, гонит мультикаст, порядка 180 мегабит) ------ приставка mag-250

 

все работает хорошо

 

собираем следующую схему:

Стример ----- SNR2950-24 ------ приставка mag-250 (24 штуки, в каждый порт)

 

каналы начинают пропадать, такое ощущение что пакеты бьются

 

конфиг коммутатора

 

SNR-S2950-24G#sh ru

!

no service password-encryption

!

hostname SNR-S2950-24G

sysLocation Ak.Vonsovskogo str. 1-118, Ekaterinburg, Russia

sysContact support@nag.ru

!

username admin privilege 15 password 0 admin

!

!

!

web language english

!

snmp-server enable

snmp-server securityip 10.110.212.212

snmp-server securityip 10.110.101.195

snmp-server community ro 0 public

snmp-server community rw 0 private

!

!

!

!

!

!

sflow version 0

!

!

vlan 1;110;4094

!

vlan 770

multicast-vlan

multicast-vlan mode dynamic

multicast-vlan association 4094

!

multicast destination-control

!

Interface Ethernet1/1

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/2

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/3

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/4

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/5

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/6

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/7

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/8

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/9

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/10

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/11

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/12

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/13

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/14

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/15

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/16

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/17

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/18

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/19

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/20

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/21

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/22

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/23

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/24

switchport access vlan 4094

switchport association multicast-vlan 770

!

Interface Ethernet1/25

switchport mode trunk

switchport trunk allowed vlan 110;4094

!

Interface Ethernet1/26

media-type copper

switchport access vlan 770

!

interface Vlan110

ip address 10.110.10.24 255.255.0.0

!

ip igmp snooping

ip igmp snooping vlan 770

!

!

no login

!

end

 

 

 

110 вилан - управление

4094 вилан - для приставок

770 вилан - мультикастовый вилан

 

в чем может быть проблема? почему затыкаются каналы?

Share this post


Link to post
Share on other sites

Здравствуйте.

 

У вас есть IGMP querier?

 

в этой связке нет

Share this post


Link to post
Share on other sites

Здравствуйте.

В такой связке нужен querier, иначе подписка будет пропадать по таймауту. Можно поднять querier на самом коммутаторе доступа.

Share this post


Link to post
Share on other sites

Здравствуйте.

В такой связке нужен querier, иначе подписка будет пропадать по таймауту. Можно поднять querier на самом коммутаторе доступа.

 

как это сделать?

Share this post


Link to post
Share on other sites

Здравствуйте,

 

чтобы коммутатор стал querier в vlan, нужно ввести комманду

ip igmp snooping vlan 770 l2-general-querier

можно ещё указать версию IGMP, так как по дефолту будет использоваться IGMPv3, которая не поддерживается старым оборудованием,

ip igmp snooping vlan 770 l2-general-querier-version 2

и source для IGMP пакетов

ip igmp snooping vlan 770 l2-general-querier-source x.x.x.x

Share this post


Link to post
Share on other sites

еще нужно указать mrouter порт, к которому подключен стример

ip igmp snooping vlan 770 mrouter-port interface eth1/xx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this