Jump to content
Калькуляторы

Mikrotik ipsec dlink dfl-210, 260E Соединить по ipsec микротик с длинком

Добрый день, подскажите пожалуйста, в чем может быть проблема, или ткните пожалуйста в инструкцию по настройке ipsec между микротиком и длинком. Туннель поднимается, пинги проходят между устройствами, на вебинтерфейсы по внутренним адресам подключиться получается, а компьютеры по разные стороны друг друга не пингуют. Может быть у кого-нибудь есть рабочий конфиг длинка и микротика?

 

Хотели перейти в центральном офисе на микротик, а филиалы пока оставить на длинках, т.к. нет возможности сейчас сразу заменить все устройства.

 

Собрал тестовый стенд, соединил длинк с микротиком патчкордом WAN порты, подключил ноутбук в LAN микротика. На микротике локальная сеть 192.168.88.0/24, внешний 10.90.90.91, а на длинке 192.168.80.0/24, внешний 10.90.90.90.

 

 

# jan/02/1970 01:03:29 by RouterOS 6.11
# software id = BSH7-T4HC
#
/interface bridge
add admin-mac=00:00:00:00:00:00 auto-mac=no l2mtu=1598 name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether6 ] name=ether6-master-local
set [ find default-name=ether7 ] master-port=ether6-master-local name=\
   ether7-slave-local
set [ find default-name=ether8 ] master-port=ether6-master-local name=\
   ether8-slave-local
set [ find default-name=ether9 ] master-port=ether6-master-local name=\
   ether9-slave-local
set [ find default-name=ether10 ] master-port=ether6-master-local name=\
   ether10-slave-local
/ip neighbor discovery
set WAN1 discover=no
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=md5,sha1 enc-algorithms=des,3des
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge-local lease-time=10m name=\
   default
/interface bridge port
add bridge=bridge-local interface=ether2
add bridge=bridge-local interface=ether3
add bridge=bridge-local interface=ether4
add bridge=bridge-local interface=ether5
add bridge=bridge-local interface=ether6-master-local
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=ether2 \
   network=192.168.88.0
add address=10.90.90.91/8 interface=WAN1 network=10.0.0.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid interface=\
   WAN1
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=\
   192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" disabled=yes \
   in-interface=WAN1
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=\
   invalid disabled=yes
/ip firewall nat
add chain=srcnat dst-address=192.168.80.0/24 src-address=192.168.88.0/24
add action=masquerade chain=srcnat comment="default configuration" \
   out-interface=WAN1
/ip ipsec peer
add address=10.90.90.90/32 dpd-interval=disable-dpd dpd-maximum-failures=1 \
   enc-algorithm=des hash-algorithm=md5 policy-group=default secret=test
/ip ipsec policy
add dst-address=192.168.80.0/24 sa-dst-address=10.90.90.90 sa-src-address=\
   10.90.90.91 src-address=192.168.88.0/24 tunnel=yes
/ip route
add distance=1 gateway=10.90.90.94
/ip upnp
set allow-disable-external-interface=no
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2
add interface=ether3
add interface=ether4
add interface=ether5
add interface=ether6-master-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2
add interface=ether3
add interface=ether4
add interface=ether5
add interface=ether6-master-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=bridge-local

Share this post


Link to post
Share on other sites

А что длинк? Как настроен, что кажет?

Share this post


Link to post
Share on other sites

А что длинк? Как настроен, что кажет?

 

Длинк настраивал по старой проверенной схеме по инструкции с сайта, не знаю просто как с него конфиг слить и показать(кроме как бинарный). Взял накатил конфигурацию рабочую, поменял там только настройки шифрования в ipsec, остальные правила не менялись, в микротике отключил все запрещающие правила и тогда смог подключиться по внутреннему адресу к вебинтерфейсу, но компютеры не видят друг-друга, хотя с такими же настройками микротик-микротик работают. Единственно, что сейчас попробую, на WAN интерфейсе микротика у меня шлюз прописан 10.90.90.94, а на длинке прописан 0.0.0.0. Может в этом ошибка? (повторюсь, длинк с микротиком соединены простым патчкордом WAN порты)

Share this post


Link to post
Share on other sites

Посыпаю голову пеплом, гребанная win 7 ввела меня в заблуждение, на пинги не отвечала, подключил компьютер с win xp, оказывается она пингуется!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this