Перейти к содержимому
Калькуляторы

ip unnambered + dhcp на cisco 2600

Добрый день. Хотелось бы узнать у гуру: возможно ли на cisco 2600 IOS 12.4 настроить dhcp сервер с привязкой к ip unnambered интерфейсам?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В принципе получилось, работает. но эти relay HEX ключи вытаскивать из дебага DHCP - гемор еще тот.

напишу для потомков. Вдруг кто будет интересоваться этим функционалом в гугле.

 

###################################################

 

!

ip dhcp smart-relay

ip dhcp relay information option

ip dhcp relay information trust-all

no ip dhcp use vrf connected

!

ip dhcp pool fake

network 10.0.3.0 255.255.255.0

class 3004

address range 10.0.3.4 10.0.3.4

class 3002

address range 10.0.3.2 10.0.3.2

class 3003

address range 10.0.3.3 10.0.3.3

!

!

ip dhcp class 3004

relay agent information

relay-information hex 020c020a00000a00030101000bbc0608766c616e33303034

!

ip dhcp class 3002

relay agent information

relay-information hex 020c020a00000a00030101000bba0608766c616e33303032

!

ip dhcp class 3003

relay agent information

relay-information hex 020c020a00000a00030101000bbb0608766c616e33303033

!

 

#############################

 

Интерфейсы:

 

#############################

interface Loopback1

ip address 10.0.3.1 255.255.255.0

!

interface FastEthernet0/0

description ISP

ip address 83.69.44.82 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

description komilink

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 2601

ip address 62.183.9.230 255.255.255.252

ip nat outside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/1.3002

encapsulation dot1Q 3002

ip dhcp relay information option subscriber-id vlan3002

ip unnumbered Loopback1

ip helper-address 10.0.3.1

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/1.3003

encapsulation dot1Q 3003

ip dhcp relay information option subscriber-id vlan3003

ip unnumbered Loopback1

ip helper-address 10.0.3.1

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/1.3004

encapsulation dot1Q 3004

ip dhcp relay information option subscriber-id vlan3004

ip unnumbered Loopback1

ip helper-address 10.0.3.1

no ip proxy-arp

ip nat inside

ip virtual-reassembly

interface Loopback1

ip address 10.0.3.1 255.255.255.0

!

interface FastEthernet0/0

description ISP

ip address 83.69.4.82 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

description komilink

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 2601

ip address 62.182.29.230 255.255.255.252

ip nat outside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/1.3002

encapsulation dot1Q 3002

ip dhcp relay information option subscriber-id vlan3002

ip unnumbered Loopback1

ip helper-address 10.0.3.1

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/1.3003

encapsulation dot1Q 3003

ip dhcp relay information option subscriber-id vlan3003

ip unnumbered Loopback1

ip helper-address 10.0.3.1

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/1.3004

encapsulation dot1Q 3004

ip dhcp relay information option subscriber-id vlan3004

ip unnumbered Loopback1

ip helper-address 10.0.3.1

no ip proxy-arp

ip nat inside

ip virtual-reassembly

!

!

ip default-gateway 83.69.66.81

ip forward-protocol nd

ip route 10.0.3.2 255.255.255.255 FastEthernet0/1.3002

ip route 10.0.3.3 255.255.255.255 FastEthernet0/1.3003

ip route 10.0.3.4 255.255.255.255 FastEthernet0/1.3004

!

!

 

#######################################

 

Строчка дебага выглядит вот так:

Feb 21 13:54:29.135: DHCPD: input pattern 'relay-information 020c020a00000a00030101000bba0608766c616e33303032' matches class 3002

 

Этот хекс и вставляем в нужный класс.

Изменено пользователем Fancar

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Очень полезная инфа, спасибо! Попробую сделать на 3750.

Вопрос: в какой момент сообщение появляется в дебаге?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Прошу помощи...

не получается вытащить из дебага хекс.

 

Делаю:

terminal monitor

debug ip dhcp server class

debug ip dhcp server events

debug ip dhcp server linkage

debug ip dhcp server packet

debug ip dhcp server redundancy

 

Пишу все по примеру. Ни во время конфигурации, ни во время запроса адреса хекс не вижу...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

поздно заметил, но лучше поздно чем никогда, может кому пригодиться.

 

Для начала нужно вставить какой-нибудь несуществующий хекс, иначе если класс будет без hex, то он будет выдаваться кому попало без оглядки на vlan

ip dhcp class 317

relay agent information

relay-information hex 020c020a00000a0003010100013e0603333137

 

дальше включаем дебаг:

 

undebag all

debug dhcp

debug ip dhcp server class

clear log

sh log

 

ищем наш АСК DHCPD: Searching for a match to 'relay-information ТУТ ХЕКС

 

копируем в буфер обмена и вставляем в нужный класс вместо заглушки

ip dhcp class 317

relay agent information

relay-information hex --> сюда <--

 

 

Дальше вытащив несколько хексов подряд без труда проследит меняющиеся разряды и продолжить без поисков в дебаге.

 

незабудьте

undebug all

 

Ж)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Гость
Ответить в тему...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 смайлов.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.