Jump to content
Калькуляторы

Mikrotik RB2011 Вопрос по VLANу

Прани, подскажите кто сталкивался с таким:

Имею RB2011, В порт 1 приходит провайдер с Juniper SRX210, по влану 1, порт 3-10 в бридже для локалки (айпи в бридже 192.168.) в порт 2 подключен свитч, вот на него нужно прокинуть прямой влан 1 который дает провайдер, в влане 1 адресация 10.0.0.0.

Все остальные фичи микротика работают нормально, с ними разобрался, а вот с вланами пока не могу разобраться.

Share this post


Link to post
Share on other sites

Ну, например, вот так попробовать:

/interface vlan
add name=vlan-1 interface=ether1 vlan-id=1
/interface bridge
add name=bridge-vlan-1
/interface bridge port
add bridge=bridge-vlan-1 interface=vlan-1
add bridge=bridge-vlan-1 interface=ether2

Второй порт, насколько я понимаю, уже не мастер для остальных, - с этим проблем быть не должно

Share this post


Link to post
Share on other sites

Спасибо, но не работает. Ума не приложу почему.

Share this post


Link to post
Share on other sites

Прани, подскажите кто сталкивался с таким:

Имею RB2011, В порт 1 приходит провайдер с Juniper SRX210, по влану 1, порт 3-10 в бридже для локалки (айпи в бридже 192.168.) в порт 2 подключен свитч, вот на него нужно прокинуть прямой влан 1 который дает провайдер, в влане 1 адресация 10.0.0.0.

Все остальные фичи микротика работают нормально, с ними разобрался, а вот с вланами пока не могу разобраться.

вам нужно снять ТЕГ на МТ?

Share this post


Link to post
Share on other sites

Прани, подскажите кто сталкивался с таким:

Имею RB2011, В порт 1 приходит провайдер с Juniper SRX210, по влану 1, порт 3-10 в бридже для локалки (айпи в бридже 192.168.) в порт 2 подключен свитч, вот на него нужно прокинуть прямой влан 1 который дает провайдер, в влане 1 адресация 10.0.0.0.

Все остальные фичи микротика работают нормально, с ними разобрался, а вот с вланами пока не могу разобраться.

вам нужно снять ТЕГ на МТ?

Да, просто на МТ не совсем понятно как оно работает, тут нет такого, тегированный, не тегированный. Просто превык к другому железу, где для меня это более понятно, таггет, унтаггет :)

Share this post


Link to post
Share on other sites

Прани, подскажите кто сталкивался с таким:

Имею RB2011, В порт 1 приходит провайдер с Juniper SRX210, по влану 1, порт 3-10 в бридже для локалки (айпи в бридже 192.168.) в порт 2 подключен свитч, вот на него нужно прокинуть прямой влан 1 который дает провайдер, в влане 1 адресация 10.0.0.0.

Все остальные фичи микротика работают нормально, с ними разобрался, а вот с вланами пока не могу разобраться.

вам нужно снять ТЕГ на МТ?

Да, просто на МТ не совсем понятно как оно работает, тут нет такого, тегированный, не тегированный. Просто превык к другому железу, где для меня это более понятно, таггет, унтаггет :)

и того, объясняю на примере скажем мт450:

мт450 = 5 ether портов

для примера - на ether1 пришел чистый тегированный траффик, для примера vlan10, vlan20, и управления vlan111

нам нужно:

на ether2 нужно растегить vlan10

на ether3 нужно растегить vlan20

ну и конечно нужно иметь управление в vlan111

 

наши действия:

1)создаем bridge1, в bridge1 добавляем ether1(то с чего приходить сам аплинк со всемя тегами)

2) создаем vlan10,vlan20,vlan111 и указываем в Interfaces - bridge1 (то откуда приходят ТЕГИ)

3) создаем bridge2(можно его назвать для наглядности - bridge2-vlan10-unteg) и в этот bridge2-vlan10-unteg запихиваем собственно сам интерфейс с которого хотим снимать тег(это наш vlan10) и тот интерфейс куда мы хотим снимать тег (это наш ether2) - вот так происходит снятия тега

4) создаем bridge3(можно его назвать для наглядности - bridge3-vlan20-unteg) и в этот bridge3-vlan20-unteg запихиваем собственно сам интерфейс с которого хотим снимать тег(это наш vlan20) и тот интерфейс куда мы хотим снимать тег (это наш ether3) - все послнустью аналогично пункту 2, то есть снимай хоть N количество тегов, главное что физически интерфейсов хватало

5) для управления хватает просто в ip\adresses повесить ір на сам интерфейс vlan100, тут же в ip\adresses мы для удобности вешаем ір на bridge2-vlan10-unteg и bridge3-vlan20-unteg из сетки адресов которую растегируем.

Edited by fastvd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this