Jump to content
Калькуляторы

pim dm нихт арбайтен

имеется 2 коммутатора huawei s5328. На первом(S-A) в одном из портов источник мультикаста, на втором(S-B) приемник в виде компа с vlc плейером.

 

S-A

#

multicast routing-enable

#

igmp-snooping enable

#

vlan 100

igmp-snooping enable

#

interface Vlanif100

ip address 10.10.10.1 24

pim dm

#

interface GigabitEthernet0/0/24 (Здесь источник)

port link-type trunk

port trunk allow-pass vlan 100

 

#

vlan 200

igmp-snooping enable

#

interface Vlanif200

ip address 192.168.0.1 24

pim dm

#

interface GigabitEthernet0/0/23 (Здесь уходим на S-B)

port link-type trunk

port trunk allow-pass vlan 200

Если этот порт сделать пользовательским то отсюда можно забирать мультикаст.

 

S-B

#

multicast routing-enable

#

igmp-snooping enable

#

vlan 200

igmp-snooping enable

#

interface Vlanif200

ip address 192.168.0.2 24

pim dm

#

interface GigabitEthernet0/0/24 (на S-A)

port link-type trunk

port trunk allow-pass vlan 200

 

#

vlan 300

igmp-snooping enable

#

interface Vlanif300

ip address 192.168.1.1 24

pim dm

#

interface GigabitEthernet0/0/23 (Здесь пытаемся поймать мультикаст и не можем)

port link-type access

port default vlan 300

Если этот порт включить в vlan 200, то мультикаст ловим.

 

В такой же структуре пытался сделать на фаундри, результат аналогичен.

В теории все понятно и просто, но где-то ошибка.

 

интересует любой рабочий конфиг на любом железе не менее 2х устройств.

Share this post


Link to post
Share on other sites

он там и стоит, просто конфиг специфичный для huawai

 

S-A

#

multicast routing-enable

#

igmp-snooping enable

#

vlan 100

igmp-snooping enable

#

interface Vlanif100

ip address 10.10.10.1 24

pim dm

#

interface GigabitEthernet0/0/24 (Здесь источник)

port link-type trunk

port trunk allow-pass vlan 100

 

пож. выложите любой рабочий конфиг аналогичный описанной выше схеме

Edited by sasser

Share this post


Link to post
Share on other sites

конфиг рабочий просто надо было вначале правильно настроить unicast routing

Edited by sasser

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this