Jump to content
Калькуляторы

.pfx-файл в cisco IOS

Здравствуйте

На днях была поставлена задача выяснить, подойдут ли сертификаты, выданные нашим ЦСРК для использования в Cisco IOS.

Имееться эмуль GNS3, в нем 7200 циска.

Конфиг:

 

Current configuration : 1260 bytes
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname R0
boot-start-marker
boot-end-marker
enable secret 5 $1$q5uo$Zh0kDtKnwey1tq5Q20tcR1
no aaa new-model
ip cef
ip domain name cisco.com
crypto pki trustpoint mytp
fqdn www.cisco.com
subject-name cn=obu
revocation-check none
rsakeypair mytp
username admin privilege 15 secret 5 $1$1dBl$7/uUZLWZPQltlnl4KoiHC/
interface FastEthernet0/0
no ip address
shutdown
duplex half
interface FastEthernet1/0
ip address 220.110.55.20 255.255.255.0
duplex auto
speed auto
interface FastEthernet1/1
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
router eigrp 1
redistribute static
network 10.0.0.0
network 220.110.55.0
no auto-summary
ip http server
no ip http secure-server
control-plane
gatekeeper
shutdown
line con 0
password cisco
login local
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password cisco
login local
transport input telnet ssh
end

 

 

В качестве TFTP-сервака используеться локальный ПК, в папке обмена лежит *.pfx файл.

В вопросах крипты не силен, потмоу согласно мануалу (http://www.booches.nl/2010/02/import-pkcs12-certificate-on-ios-router/)

 

Я делаю следующее:

R0(config)#crypto ca trustpoint mytp
R0(ca-trustpoint)#fqdn www.cisco.com
R0(ca-trustpoint)#subject-name cn=obu
R0(ca-trustpoint)#revocation-check none
R0(ca-trustpoint)#rsakeypair mytp
R0(config)#crypto ca import mytp pkcs12 tftp: 12345678
% Importing pkcs12...
Address or name of remote host []? 220.110.55.22
Source filename [mytp]? cisco1.pfx
Reading file from tftp://220.110.55.22/cisco1.pfx
Loading cisco1.pfx from 220.110.55.22 (via FastEthernet1/0): !
[OK - 2996 bytes]

CRYPTO_PKI: Import PKCS12 operation failed, failure status = 0x705
R0(config)#
*Sep 22 14:54:36.490: %PKI-6-PKCS12IMPORT_FAIL: PKCS #12 Import Failed.

 

Сертификат не импортируеться=(. Где я допустил ошибку?

 

Заранее спасибо)

Edited by Former_Human

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this