Jump to content
Калькуляторы

RB450G перенос настроек с Linux нужен совет по переносу настроек dhcp сервера

Приветствую всех! Купил себе RB450G, но столкнулся с несколькими проблемами:

-сейчас работает linux, на нем dhcp сервер который раздает адреса привязываясь по мак адресу,(конкретному маку - конкретный ip), необходимо перенести все настройки на микротик.В 450G нашел как это делается через winbox, но абонентов не мало, очень много вводить по одному. В линуксе есть файл под названием "dhcpd.conf" - вот часть содержания которое относиться к присваиванию ip по маку:

host pc01-Losha {

hardware ethernet 00:1D:09:45:67:1A;

fixed-address 10.0.0.51;

}

host pc02-Misha {

hardware ethernet 00:18:F3:4B:2A:22;

fixed-address 10.0.0.53;

и т.д.

Кто знает, подскажите пожалуйста как можно все это сделать.

И еще если можно пару слов по поводу шейпера в Микротик - как он настраиваеться? В winbox его не нашел.

Share this post


Link to post
Share on other sites

/ip dhcp-server lease

add address=192.168.2.8 comment="Nokia E52" disabled=no mac-address=00:00:00:46:67:00 server=vlan-rmika

Share this post


Link to post
Share on other sites

В соседней теме... про rb450

Ограничить скорость по ip

 

/queue simple

add burst-limit=0/0 \

burst-threshold=0/0 \

burst-time=0s/0s \

direction=both \

disabled=no \

dst-address=0.0.0.0/0 \

interface=all \

limit-at=0/0 \

max-limit=1M/1M \

name=192.168.1.2 \

parent=none \

priority=8 \

queue=default-small/default-small \

target-addresses=192.168.1.2/32 \

total-queue=default-small

Share this post


Link to post
Share on other sites

/ip dhcp-server lease

add address=192.168.2.8 comment="Nokia E52" disabled=no mac-address=00:00:00:46:67:00 server=vlan-rmika

Большое спасибо за ответ! Но я имел в виду перенести файл целиком, чтобы не прописывать заново все руками. Может можно както зайти и подменить этот файл?

Share this post


Link to post
Share on other sites

чтобы не прописывать заново все руками. Может можно както зайти и подменить этот файл?

Простейший скриптик парсящий dhcpd.conf и генерящий кучу строк /ip dhcp-server lease блаблабла, затем простой копипаст в винбоксе

Share this post


Link to post
Share on other sites

чтобы не прописывать заново все руками. Может можно както зайти и подменить этот файл?

Простейший скриптик парсящий dhcpd.conf и генерящий кучу строк /ip dhcp-server lease блаблабла, затем простой копипаст в винбоксе

Да спасибо за совет, но Mikrotik на платформе линукса, я думал, что можно както залезть в файловую систему и заменить dhcpd.conf. Что вовсе никак нельзя залезть в файловую систему?

Edited by ur4ulf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this