Jump to content
Калькуляторы

Port-channel mpls ios-xe

Всем привет.

Есть 7606 и asr1002.

Между ними поднят port-channel

ASR

interface Port-channel2
description //MPLS_UPLINK//
mtu 1546
ip address 10.25.10.14 255.255.255.252
ip flow ingress
ip flow egress
negotiation auto
mpls ip
!
interface GigabitEthernet0/0/0
mtu 1546
no ip address
no ip redirects
no ip proxy-arp
load-interval 30
negotiation auto
channel-group 2 mode active
!
interface GigabitEthernet0/0/1
mtu 1546
no ip address
no ip redirects
no ip proxy-arp
load-interval 30
negotiation auto
channel-group 2 mode active

ASR1002#sh run | i mpls
no mpls ip propagate-ttl forwarded
mpls label protocol ldp
mpls ip

 

 

7606

 

 

interface GigabitEthernet2/20
description # Portchannel ASR1002 link 1 #
mtu 1546
bandwidth 1000000
no ip address
no ip redirects
no ip proxy-arp
load-interval 30
tag-switching ip
channel-group 2 mode active
!
interface GigabitEthernet2/21
description # Portchannel ASR1002 link 2 #
mtu 1546
bandwidth 1000000
no ip address
no ip redirects
no ip proxy-arp
load-interval 30
tag-switching ip
channel-group 2 mode active

interface Port-channel2
description # MPLS ASR1002#
mtu 1546
ip address 10.25.10.13 255.255.255.252
tag-switching ip

 

ASR1002#ping 10.25.10.13

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.25.10.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

ASR1002#sh mpls ldp neighbor

ASR1002#

Дебаг тоже ничего явного не выявил. На 7606 mpls точно рабочий, т.к. с таким же конфигом работает на других интерфейсах. За исключением того, что тут Port-Channel.

Куда копать?

 

p.s.

asr1000rp1-advipservicesk9.03.01.02.S.150-1.S2.bin

s72033-advipservicesk9_wan-mz.122-18.SXF17a.bin

Share this post


Link to post
Share on other sites

7606#sh etherchannel 2 detail
Group state = L3
Ports: 2   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0
               Ports in the group:
               -------------------
Port: Gi2/20
------------

Port state    = Up Mstr In-Bndl
Channel group = 2           Mode = Active      Gcchange = -
Port-channel  = Po2         GC   =   -         Pseudo port-channel = Po2
Port index    = 0           Load = 0x55        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
       A - Device is in active mode.        P - Device is in passive mode.

Local information:
                           LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi2/20    SA      bndl      32768         0x2       0x2     0x214       0x3D

Partner's information:

         Partner Partner   LACP Partner  Partner   Partner  Partner     Partner
Port      Flags   State     Port Priority Admin Key Oper Key Port Number Port State
Gi2/20    SA      bndl      32768         0x0       0x2      0x1         0x3D

Age of the port in the current state: 0d:06h:15m:33s

Port: Gi2/21
------------

Port state    = Up Mstr In-Bndl
Channel group = 2           Mode = Active      Gcchange = -
Port-channel  = Po2         GC   =   -         Pseudo port-channel = Po2
Port index    = 1           Load = 0xAA        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
       A - Device is in active mode.        P - Device is in passive mode.

Local information:
                           LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi2/21    SA      bndl      32768         0x2       0x2     0x215       0x3D

Partner's information:

         Partner Partner   LACP Partner  Partner   Partner  Partner     Partner
Port      Flags   State     Port Priority Admin Key Oper Key Port Number Port State
Gi2/21    SA      bndl      32768         0x0       0x2      0x2         0x3D

Age of the port in the current state: 0d:06h:15m:32s

               Port-channels in the group:
               ----------------------

Port-channel: Po2    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:10h:24m:03s
Logical slot/port   = 14/2          Number of ports = 2
Passive port list   = Gi2/20 Gi2/21
Port state          = Port-channel L3-Ag Ag-Inuse
Protocol            =   LACP

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
 0     55     Gi2/20   Active    4
 1     AA     Gi2/21   Active    4

Time since last port bundled:    0d:06h:15m:44s    Gi2/21
Time since last port Un-bundled: 0d:06h:15m:50s    Gi2/21

 

 

ASR1002#sh lacp 2 neighbor detail
Flags:  S - Device is requesting Slow LACPDUs
       F - Device is requesting Fast LACPDUs
       A - Device is in Active mode       P - Device is in Passive mode

Channel group 2 neighbors

Partner's information:

         Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Gi0/0/0    32768,5475.d0a6.d500  0x214             5s        SA

         LACP Partner         Partner         Partner
         Port Priority        Oper Key        Port State
         32768                0x2             0x3D

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Active      Short      Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No
         Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Gi0/0/1    32768,5475.d0a6.d500  0x215            25s        SA

         LACP Partner         Partner         Partner
         Port Priority        Oper Key        Port State
         32768                0x2             0x3D

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Active      Short      Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No
ASR1002#

Share this post


Link to post
Share on other sites

upd.

После ребута asr все заработало =\

Тему можно закрывать.

Спасибо индусам за спокойные ночи :)

Share this post


Link to post
Share on other sites

Можно каверзный вопрос, зачем вам на ASR1k MPLS ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this