Jump to content
Калькуляторы

Помогите с настройкой мультикаста проблемы с зоопарком железа

Есть следующая конфигурация:

мультикаст стример - cisco 3560g - D-Link DGS-3100-24TG - пользовательские свичи типа D-Link DES-3200-18

Не могу победить настройки мультикаста хоть перерыл кучу тем и форумов, помогите разобраться что я делаю не так.

 

конфиг cisco:

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service unsupported-transceiver
!
hostname ZCore
!

....

no aaa new-model
clock timezone MSK 3
clock summer-time MSKL recurring last Sun Mar 2:00 last Sun Oct 3:00
system mtu routing 1500
vtp mode transparent
ip subnet-zero
ip routing
!
ip igmp snooping querier
!
mls qos
mvr vlan 16
mvr
mvr mode dynamic
mvr group 238.1.1.1
mvr group 238.1.1.2
mvr group 238.1.1.3
mvr group 238.1.1.4
mvr group 238.1.1.5
mvr group 238.1.1.6
mvr group 238.1.1.7
mvr group 238.1.1.8
mvr group 238.1.1.9
mvr group 238.1.1.10
...

!
vlan 16
name iptv
!
...
!
interface GigabitEthernet0/1
description PBI first
switchport access vlan 16
switchport mode access
mvr type source
mvr immediate
service-policy input qos_policy
!
...

!
interface GigabitEthernet0/25
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
service-policy input qos_policy
!

 

конфиг 3100

 

create vlan IPTV tag 16 
config vlan IPTV add tagged 1:(1-24),2:(1-24) 
enable igmp_snooping 
config igmp_snooping IPTV state enable 
config router_port IPTV add 2:10 

 

конфиг 3200

 

enable igmp_snooping
config igmp_snooping data_driven_learning max_learned_entry 56
enable igmp_snooping multicast_vlan
create igmp_snooping multicast_vlan iptv 16
config igmp_snooping multicast_vlan iptv state enable 
config igmp_snooping multicast_vlan iptv add member_port 8 
config igmp_snooping multicast_vlan iptv add source_port 10

 

Проблема в следующем если на циске выключить квериер мультикаст начинает ломится во все порты без подписки при включенном ничего не показывает.

Share this post


Link to post
Share on other sites
Guest Andrew

надо на interface GigabitEthernet0/25 указать mvr type тоже.

Share this post


Link to post
Share on other sites

ну не слабо Вы темку апнули....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this