Jump to content
Калькуляторы

sup720-3b bgp маршрутизация между vlan

Здравствуйте!

Возникла такая проблема имеется cisco 6506 с управляющим модулем sup720-3b,

Имеется одно bgp соединение конфиг примерно такой:

 

 

router bgp XXXX1

no synchronization

bgp router-id X.X.X.2

bgp cluster-id XXXXXXXXX7

bgp log-neighbor-changes

network A.A.A.0 mask 255.255.248.0

aggregate-address B.B.B.0 255.255.254.0

aggregate-address G.G.G.0 255.255.254.0

aggregate-address A.A.A.0 255.255.248.0

neighbor T.T.T.1 remote-as XXX9

neighbor T.T.T.1 ebgp-multihop 5

neighbor X.X.X.1 remote-as XXX9

neighbor X.X.X.1 prefix-list ASXXXX1 out

no auto-summary

 

 

interface Vlan100

ip address X.X.X.2 255.255.255.252 ( Адрес bgp router-id X.X.X.2)

 

 

interface GigabitEthernet6/1 (Интерфейс через который приходит vlan100 с bgp)

no ip address

speed nonegotiate

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100-199

switchport mode trunk

 

 

interface Vlan200

ip address X.X.X.129 255.255.255.224 (Арес из сетки которая анонсируется через bgp)

 

interface FastEthernet3/3 (Интерфейс на котором сидит клиент vlan200)

no ip address

switchport

switchport access vlan 200

switchport mode access

 

 

interface Vlan300

ip address X.X.X.1 255.255.255.0 (Арес из сетки которая анонсируется через bgp)

 

interface FastEthernet3/3 (Интерфейс на котором сидит клиент vlan300)

no ip address

switchport

switchport access vlan 300

switchport mode access

 

 

 

Так вот при таком конфиге два клиента находящиеся в разных виланах могут друг друга пинговать но не пингуется адрес bgp router-id X.X.X.2 и bgp router-id X.X.X.1 и все что находится в сети провайдера за пределами bgp.

На самом роутере как не странно не пингуется адрес bgp router-id X.X.X.2 но можно пропинговать к примеру айпи адреса yandex.ru или какие либо другие адреса из сети провайдера.

Знаюшие люди помогите!

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this