Jump to content
Калькуляторы

2 циски 2 канала и OSPF чую игра в найди опечатку :)

Есть две циски. между ним 2 физически разные оптики. Нужно при помощи ospf настроить маршрутизацию и резервирование (в идеале и балансировку но это потом...).

 

вот конфиги

циска 1

interface Vlan97

description ospf

ip address 10.200.0.1 255.255.255.252

ip ospf network point-to-point

ip ospf 2 area 0

!

interface Vlan98

description ospf2

ip address 10.200.2.1 255.255.255.252

ip ospf network point-to-point

ip ospf 2 area 0

router ospf 2

router-id 5.5.5.5

log-adjacency-changes

redistribute static metric-type 1 subnets

 

 

Switch#sh ip ospf neighbor

 

Neighbor ID Pri State Dead Time Address Interface

3.3.3.3 0 FULL/ - 00:00:36 10.200.0.2 Vlan97

Switch#sh arp | in 10.200.

Internet 10.200.0.2 9 0014.a8a6.4b44 ARPA Vlan97

Internet 10.200.2.1 - 0015.fac5.2de5 ARPA Vlan98

Internet 10.200.2.2 24 0014.a8a6.4b45 ARPA Vlan98

Internet 10.200.0.1 - 0015.fac5.2de4 ARPA Vlan97

циска2

interface Vlan97

description ospf

ip address 10.200.0.2 255.255.255.252

ip ospf network point-to-point

ip ospf 2 area 0

!

interface Vlan98

description ospf2

ip address 10.200.2.2 255.255.255.252

ip ospf network point-to-point

ip ospf 2 area 0

router ospf 2

router-id 3.3.3.3

log-adjacency-changes

 

 

Switch#sh ip ospf neighbor

 

Neighbor ID Pri State Dead Time Address Interface

5.5.5.5 0 FULL/ - 00:00:34 10.200.0.1 Vlan97

 

Switch#sh arp | in 10.200.

Internet 10.200.0.2 - 0014.a8a6.4b44 ARPA Vlan97

Internet 10.200.2.1 24 0015.fac5.2de5 ARPA Vlan98

Internet 10.200.2.2 - 0014.a8a6.4b45 ARPA Vlan98

Internet 10.200.0.1 9 0015.fac5.2de4 ARPA Vlan97

почему ospf в vlan97 работает, а во влан 98 нет ???

пробовал также выключить интерфейс vlan97. с циске на циску зайти пробовал заходит. пингуются в интерфейсе vlan98, но ospf не работает.

что я делаю не так/

Edited by mukca

Share this post


Link to post
Share on other sites

конфигурацию физических интерфейсов с обеих сторон покажите.

оптика физическая или арендованные каналы?

Share this post


Link to post
Share on other sites

обе наши оптики. одна прямо из циске в циску другая из циске в длинк 3100 еще один 3100 и в циску

как раз не работает через длинки

циска 1

interface GigabitEthernet1/0/2

description UZEL 50 let 95 DGS3100

switchport trunk encapsulation dot1q

switchport mode trunk

 

!

interface GigabitEthernet1/0/9

description UZEL Andr c3750

switchport trunk encapsulation dot1q

switchport mode trunk

циска 2
interface GigabitEthernet1/0/1

description UZEL 50 let 87 WS-C3750G-24T

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,4,5,11,14,50,81,97,100,125,142,144,152,153,155

switchport trunk allowed vlan add 211,703

switchport mode trunk

!

interface GigabitEthernet1/0/2

description UZEL Pirogova 68/4 DGS-3100

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 17,98

switchport mode trunk

девятый порт первой циски идет сразу во первый порт второй

а второй порт идет через 2 длинка во второй порт второй циски

Edited by mukca

Share this post


Link to post
Share on other sites

ыыы на второй циске убрал влан 98 с 2 интерейса и добавил на 1 интерфейс. и сразу заработал OSPF в влан 98

 

так что это косяк длинков ?

 

мультикаст фильтринг может влият??

Share this post


Link to post
Share on other sites

ну на портах где надо убрать мультикаст фильтеринг есесна.

ну или прописать neighbor c обеих сторон.

Share this post


Link to post
Share on other sites
! VLAN

 

config vlan default delete 1:(1-24)

create vlan pir68 tag 17

create vlan iptv tag 50

create vlan ospf2 tag 98

create vlan switch tag 100

create vlan vlan131 tag 131

create vlan 142 tag 142

 

config vlan pir68 add tagged 1:(1-23)

config vlan iptv add tagged 1:(1-23)

config vlan ospf2 add tagged 1:(1,17)

config vlan switch add tagged 1:(1-23)

config vlan vlan131 add untagged 1:24

config vlan 142 add tagged 1:(1,22)

config gvrp 1:24 pvid 131

 

! FORWARDING TABLE

 

config multicast filtering_mode 1:(1-24) filter_unregistered_groups

 

! IGMP SNOOPING

 

enable igmp_snooping

config igmp_snooping iptv state enable

1 порт в сторону следующего длинка 17 порт в сторону циски 2

Share this post


Link to post
Share on other sites

ingress

спасиб настроил nonbroadcast

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this