Jump to content
Калькуляторы

Проблемы с ДНС + CISCO

я ставлю на FreeBSD , шлюз и днс циски, тоисть 192.168.5.10, то пингуются только IP сайтов, а сайты НЕТ!

А когда ставлю ДНС на FreeBSD , тот который дал мне провайдер , и он же на циске стоит, то тогда всё работает!

 

Почему так ? я ведь вказал в циске ДНС и в ней сайты пингуются!

 

(Пример)

IP-address 123.123.123.123

Шлюз 123.123.123.120

DNS 123.123.123.110

 

 

Вот конфиг:

 

Building configuration...

Current configuration : 4242 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 
!
no aaa new-model
dot11 syslog
ip cef
!
!
!
!
ip domain name mydomain
ip name-server 123.123.123.110
!
multilink bundle-name authenticated
!
!
!
!
!
username ххх privilege 15 password 7 
username ххх privilege 15 secret 5 
archive
log config
  hidekeys
! 
!
!
!
!
!
!
interface FastEthernet0/0
description Connectet to DataGroup ADSL
ip address 123.123.123.123 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.5.10 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer0
no ip address
shutdown
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 123.123.123.120
ip route 192.168.1.0 255.255.255.0 192.168.5.3
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 192.168.5.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit 192.168.1.0 0.0.0.255
no cdp run
!
!
!
!
control-plane
!
banner login ^C

^C
!
line con 0
password 7 
logging synchronous
login
line aux 0
line vty 0 4
access-class 23 in
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

 

Помогите разобраться!

Share this post


Link to post
Share on other sites

Сама циска не является ДНС-сервером. В настройках циски вы указали ДНС сервер, она и будет его использовать, чтобы сопоставить доменному имени Ip-адрес. Но она не является днс-сервером.

Edited by fedusia

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this