Jump to content
Калькуляторы

Etherchannel и IPCP CCP (ppp timeout) 718 ошибка

Подскажите в чем может быть дело.

 

Если терминация происходит на физическом интерфейсе

 

interface Gi4/0/0.8

description ONLY_FOR_TEST

encapsulation dot1Q 8

pppoe enable group testme

end

 

- То все работает,

 

если на портченале - не может согласовать IPCP, CCP - вываливается по timeout ppp (718 ошибка в виндовс)

interface Port-channel2.8

description ONLY_FOR_TEST

encapsulation dot1Q 8

pppoe enable group testme

end

 

 

в чем может быть косяк?

 

Со стороны свича (4948)

================

 

interface Port-channel2

description -- PPPoE_in

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 8

switchport mode trunk

switchport nonegotiate

 

 

interface GigabitEthernet1/7(8)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 8

switchport mode trunk

switchport nonegotiate

logging event link-status

load-interval 30

speed 1000

duplex full

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

channel-group 2 mode on

 

 

W1#sh etherchannel load-balance

therChannel Load-Balancing Operational State (src-dst-ip):

on-IP: Source XOR Destination MAC address

IPv4: Source XOR Destination IP address

IPv6: Source XOR Destination IP address

 

 

W1#sh etherchannel detail

 

Ports in the group:

-------------------

Port: Gi1/7

------------

 

Port state = Up Mstr In-Bndl

Channel group = 2 Mode = On/FEC Gcchange = -

Port-channel = Po2 GC = - Pseudo port-channel = Po2

Port index = 0 Load = 0x00 Protocol = -

 

Age of the port in the current state: 00d:05h:30m:43s

 

Port: Gi1/8

------------

 

Port state = Up Mstr In-Bndl

Channel group = 2 Mode = On/FEC Gcchange = -

Port-channel = Po2 GC = - Pseudo port-channel = Po2

Port index = 1 Load = 0x00 Protocol = -

 

Age of the port in the current state: 00d:05h:30m:40s

 

Port-channels in the group:

---------------------------

 

Port-channel: Po2

------------

 

Age of the Port-channel = 06d:01h:33m:27s

Logical slot/port = 11/2 Number of ports = 2

GC = 0x00000000

Port state = Port-channel Ag-Inuse

Protocol = -

 

Ports in the Port-channel:

 

Index Load Port EC state No of bits

------+------+------+------------------+-----------

0 00 Gi1/7 On/FEC 0

1 00 Gi1/8 On/FEC 0

 

Time since last port bundled: 00d:05h:30m:49s Gi1/8

Time since last port Un-bundled: 00d:07h:15m:48s Gi1/8

 

 

 

W1#sh etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

 

 

Number of channel-groups in use: 2

Number of aggregators: 2

 

Group Port-channel Protocol Ports

------+-------------+-----------+------------------------------------

2 Po2(SU) - Gi1/7(P) Gi1/8(P)

 

 

 

со стороны роутера

=============

 

interface GigabitEthernet5(6)/0/0

no ip address

negotiation auto

channel-group 2 mode active

cdp enable

hold-queue 4096 in

hold-queue 4096 out

end

 

interface Port-channel2

description DOWNLINK

no ip address

negotiation auto

lacp max-bundle 2

lacp fast-switchover

end

 

 

 

 

Port-channel2 is up, line protocol is up

Hardware is GEChannel, address is 0012.7f40.4078 (bia 0000.0000.0000)

Description: DOWNLINK

MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set

Keepalive set (10 sec)

ARP type: ARPA, ARP Timeout 04:00:00

No. of active members in this channel: 2

Member 0 : GigabitEthernet5/0/0 , Full-duplex, 1000Mb/s

Member 1 : GigabitEthernet6/0/0 , Full-duplex, 1000Mb/s

No. of PF_JUMBO supported members in this channel : 0

Last input 00:00:05, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/8192/0/0 (size/max/drops/flushes); Total output drops: 0

Interface Port-channel2 queueing strategy: PXF Class-based

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

176564 packets input, 10798568 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

65611 packets output, 4536206 bytes, 0 underruns

 

bba-group pppoe testme

virtual-template 3

sessions per-mac limit 2

sessions per-vlan limit 65530

sessions per-mac throttle 10 60 180

sessions auto cleanup

 

interface Virtual-Template3

mtu 1492

ip unnumbered Loopback0

ip verify unicast reverse-path allow-self-ping

no ip redirects

no ip proxy-arp

ip tcp adjust-mss 1452

no logging event link-status

peer default ip address pool pppoe pppoe1 pppoe2 pppoe3 pppoe4 pppoe5

keepalive 15 3

ppp max-bad-auth 3

ppp mtu adaptive

ppp lcp predictive

ppp authentication ms-chap chap ms-chap-v2

ppp authorization pppoe

ppp accounting pppoe

ppp pap refuse

ppp ipcp dns X

ppp ipcp predictive

ppp ipcp address required

ppp timeout retry 3

ppp timeout authentication 45

ppp timeout idle 3600

 

 

Share this post


Link to post
Share on other sites

Все верно, на GEC может быть только 1 активный линк для терминации PPPoE

Почитайте документик http://www.cisco.com/en/US/docs/routers/10...roadband/bb.pdf

так что не собирайте GEC на Downlink, проще раскидать vlanы по интерфейсам для балансировки нагрузки.

 

 

Share this post


Link to post
Share on other sites
Все верно, на GEC может быть только 1 активный линк для терминации PPPoE

Почитайте документик http://www.cisco.com/en/US/docs/routers/10...roadband/bb.pdf

так что не собирайте GEC на Downlink, проще раскидать vlanы по интерфейсам для балансировки нагрузки.

спасибо, почитаю

 

но вопрос остается открытым - даже если один линк в горячем резерве - и работает только по активному - почему авторизация проходит (обмер кадрами src-bras<->client ?) а дальше не идет? это так оно ограничивается со стороны циски что ли ?

Edited by 127.0.0.0/8

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this