Jump to content
Калькуляторы

Catalyst 3560 большое количество sw forwarding пакетов Причины?

Имеем:

WS-C3560G-24TS 12.2(25)SEE1 C3560-ADVIPSERVICESK

На каталисте есть vlan'ы с dhcp-пулами, которые в транке уходят на абонентские свитчи.

В последнее время скачет загрузка cpu, в процессе разбора полетов выяснилось следующее:

На малой нагрузке скорость роста очереди

#sh controllers cpu-interface | i sw fo

sw forwarding 1413657513 0 0 0 0

#sh controllers cpu-interface | i sw fo

sw forwarding 1413659555 0 0 0 0

~2k pps

На большой нагрузке - может достигать десятков тысяч в секунду.

Непонятно, откуда это берется, т.к. количество пакетов на sw-forwarding не совпадает с

#sh cef not

Slot No_adj No_encap Unsupp'ted Redirect Receive Options Access Frag

RP 42840126 0 42840248 0 0 0 1 0

#sh cef not

Slot No_adj No_encap Unsupp'ted Redirect Receive Options Access Frag

RP 42840181 0 42840303 0 0 0 1 0

~100-200 pps

В моменты скачков загрузки включался дебаг debug platform cpu-queues software-fwd-q, по результатам - большое количество tcp/udp пакетов, похоже на торрент.

То есть это не те пакеты, с которыми не справился CEF(т.к. по всем параметрам подходят для его обработки - adj,options,etc).

Непонятно, почему эти пакеты идут на процессор, а не на CEF.

Share this post


Link to post
Share on other sites

петля/битые порты на доступе?

конфигурацию бы увидеть.

Share this post


Link to post
Share on other sites

Петля исключена, пакеты передаются на фаст-свитчинг и благополучно роутятся куда положено, в таблице CEF пишет корректный некст хоп.

Битые порты на доступе дали бы коллизии или ошибки, ничего такого не обнаружено. Такая ситуация только на одном свиче доступа(и он не первый в цепочке), при этом при смене на нем пользовательского vlan'а проблема ушла (vlan идентичен предыдущему, только другой диапазон адресов).

Share this post


Link to post
Share on other sites

всё таки хотелось бы увидеть конфигурацию интерфейса с адресацией.

Share this post


Link to post
Share on other sites

Проблемный vlan:

interface Vlan242

ip vrf forwarding Users

ip address 10.1.138.65 255.255.255.192

no ip unreachables

end

ip dhcp pool Vlan242

network 10.1.138.64 255.255.255.192

netbios-node-type p-node

default-router 10.1.138.65

lease 4

Тот, на который он был заменен:

interface Vlan243

ip vrf forwarding Users

ip address 10.1.138.129 255.255.255.192

no ip unreachables

end

ip dhcp pool Vlan243

network 10.1.138.128 255.255.255.192

netbios-node-type p-node

default-router 10.1.138.129

lease 4

 

Vlan242 is up, line protocol is up

Hardware is EtherSVI, address is 001b.5388.2e6d (bia 001b.5388.2e6d)

Internet address is 10.1.138.65/26

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:40, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 103000 bits/sec, 66 packets/sec

840141 packets input, 70492950 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

788132583 packets output, 1797397097 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

 

Vlan243 is up, line protocol is up

Hardware is EtherSVI, address is 001b.5388.2e6e (bia 001b.5388.2e6e)

Internet address is 10.1.138.129/26

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:19:45, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

706051 packets input, 66259550 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

572007 packets output, 41180856 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this